Jump to content

Need Help Rebuilding Catalog File


Recommended Posts

I searched all over the internet and read all the posts about restoring a backup set, but I cannot get it to work. I was backing up to a Firewire hard drive named "1-Backup Set A" and my hard drive died and now when I try to rebuild the catalog, I get this error:

 

Trouble reading: “Retrospect Data” (0), error 208 (media content unrecognized).

 

I have the "Use FireWire/USB hard drives as removable disks" option checked and have restarted several times. The file was locked to start, but I have since unlocked it.

 

I used version 6.0 before (which I reinstalled) and then even tried version 6.1 to see if that helped. Same result.

 

if ANYBODY can please help I will be forever greatful.

Link to comment
Share on other sites

Best way to ask for help is to provide a step-by-step description of exactly what you're doing. Best to use the same terms that Retrospect uses, and note any buttons pushed and commands given.

 

For example, instead of posting simpley "when I try to rebuild the catalog" you could describe:

 

 

I attempt to rebuild the catalog by going to:

 

Tools->Repair->"Rebuild from removable disks"

 

I select my external FW disk from the Media Selection window and click OK

 

Retrospect displays the error "“Retrospect Data” (0), error 208 (media content unrecognized)"

 

It's also odd that you would discover that "the file was locked." Which file? In what way was it locked? File locking is something the Finder does, not Retrospect. What is the history of the external drive's volume (which is a Member of a Removable Backup Set)? Has the name of the volume been changed?

Link to comment
Share on other sites

Details:

 

1. Used Retrospec 6.0.xxx for the last 4-5 months to do weekly backups of my Powerbook and another iMac.

2. Used a FireWire hard drive as the backup destination by enabling Preferences > Media Handling > Use Firewire and USB hard drives as removable disks

3. Catalog file was stored in the Powerbook under the Documents folder. Backup set was called "Backup Set A"

4. Last week, the hard drive in the Powerbook died and was replaced.

5. I re-installed Retrospect 6.1 as that is the newest version -- I do NOT want to completely restore the drive, just retrieve various files that are now lost.

6. Launched 6.1 and went to Special > Preferences > Media Handling > Use hard drives as removable disks and checked the box. Restarted the computer.

7. Plugged in the external hard drive and it mounted as always, named "1-Backup Set A"

8. On that disk, there was 1 file - "Retrospect Data" and a folder "Desktop"

9. The file "Retrospect Data" was locked, as in the finder had locked the file.

10. Launched Retrospect again and went to Tools > Repair, then selected "Repair file backup set".

11. When asked to select the file, chose the "Retrospect Data" file on the "1-Backup Set A" disk mounted via Firewire.

12. Retrospect said the operation failed, the file was locked.

13. Went to the finder, got info on the "Retrospect Data" file and unlocked it.

14. Repeated step 10, then Retrospect tells me "The catalog portion of Retrospect Data is damaged. Would you like to repair it?"

15. I click "yes" and then it runs for about 1 seconds and stops. Log file reports "Trouble Reading: "Retrospect Data" (0), error 208 (media content unrecognized).

16. A new file is created on the drive called "Retrospect Data.cat"

17. That's all it does.

 

The external disk was not damaged, changed, used or even turned on until I tried this restore process. The "Retrospect Data" file on the external drive is still 107.45GB so it's still got something in it.

 

Thx for any help.

Link to comment
Share on other sites

Step 10 is the problem.

 

- You configured Retrospect to allow fixed platter hard drives to be treated as removable media.

- You Created a Removable Backup Set, using that hard drive as the first member of the set.

- It's not a File Backup Set, so the command to repair one of those is going to fail.

 

Try Tools->Repair->"Rebuild from removable disks"

 

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...