Jump to content

Backup skips some files ?due to privilege settings?


Recommended Posts

I use a script for backup of all files and folders (except a few .DMGs) in my user account (as well as all files and folders in /Users/Shared plus the /Library folder). When doing backups, I am always logged in my account with admin privileges.

Besides, I backup rotatively into several backup-set files that are each stored on different Firewire drives, all formatted with HFS+. All backup sets have their catalogues stored as separate files, right from the creation, and are not pwd-protected or encrypted.

 

Now I just tried to restore two text files that I managed to mess-up when almost done with them, only to find that not a single previous version of these files ever had made it into any of the backup sets.

They don't show up in any snapshot, nor can I track them searching for the files names. And I've never ever got an error on these files during backup operation!

 

While inspecting the snapshots, I realized that other text files located in the same folder do get backed-up.

Next, I noticed that there is small difference with regard to privilege settings between files that get backed-up and those other two files that never did. On the latter, for whatever reasons, the Other privilege is set to No Access. I changed this privilege to Read, and voila, on the next backup they got saved as well.

 

While this may sound like problem solved, this is actually where the problems start, apart from still having to re-do a considerable part of today's work. If Retrospect really skips on every file (as well as folder?) that has the Other privilege set to No Access, then working and relying on this software will become a major headache.

 

I mean, come on: I RW-own these files, they are part of my account from which I also run the backup, and the admin group has RW access to those files as well. Yet if I try to back them up even while being logged-into my account as an admin, Retrospect will still skip them because they cannot be read be others??

 

Does this mean, Retrospect behaves as yet another and non-admin user on the system? Should I maybe run Retrospect 'as root', using a tool like "pseudo"??

I checked the man and the web site for an overview primer on backup and privileges, but the typical privilege discussion focussed on Restore operations or backups between storage devices with different file systems.

 

All over sudden, lots and lots of questions and worries. I'll better stop for now. Looking forward to some solid clarifications and suggestions. TNX!

 

-Martin (R-Desktop 6.1.126 on OS-X 10.4.7 on PPC)

Link to comment
Share on other sites

Quote:

Should I maybe run Retrospect 'as root', using a tool like "pseudo"??

 


 

There is no need, as by design Retrospect runs as a root process. It doesn't matter what user is logged into the Finder, or if no user is logged in at all. That's why you see the Retrospect icon in the dock bounce, launch, quit, then bounce/launch again.

 

You can confirm this yourself; launch Retrospect by double-clicking on its icon, then visit Activity Monitor and see what it shows in the User column.

 

Here's what I just tried:

 

- Create a folder on my hard drive

- Populate the folder with some text files

- Change permissions for all files to rw-r----- me:me

- Launch Retrospect

- Define my test folder as a Subvolume

- Create a new File Backup Set

- Immediate Backup -> Source=Test Folder, Destination=File Backup Set. Selecting All Files

- Observe Operations Log confirms all files backed up

- Reports->Contents->File Backup Set->Test Folder Snapshot->Browse

- Confirm all files present

- Immediate Restore; all files recovered.

 

So Retrospect has read access to every file on my drive, no matter what their permissions are.

 

>I use a script for backup of all files and folders (except a few .DMGs)

 

This implies the use of some selector or selectors. They are often a cause of unexpected behavior. What exactly does your Script look like?

 

Dave

Link to comment
Share on other sites

Well, TNX for testing on your side as well as pointing me to Activity Monitor! (and indeed, Retrospect runs as root)

At least, I feel a bit more ground under my feet again with your confirmation that things are supposed to work the way as I myself had always understood it.

TNX for the hint that selectors can be a cause of problems; I've noticed this already in restore operations; so I often double-check with snapshots.

In fact, this script does not exclude any DMGs, but it's supposed to skip sparseimages as well as file names matchng "junk", and folders whose names contain "chache". And all items should be stored compressed.

 

On the problem at hand, for the life of me, I cannot repeat the issue. I'll probably do a full restore in the near future and then check side-by-side if any other items are missing, and if yes, I'll take it from there.

 

TNX again! -Martin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...