Jump to content

10.4.6 Retrospect 6.1, PMac G5 Quad - device driver support seems broken


Recommended Posts

Hello,

 

thought I would try out Retrospect 6.1 with the latest 6.1.5 driver update to see how well it performs on a PowerMac G5 Quad, running OSX 10.4.6, doing backup to DVD media.

 

The first thing I noticed is that it asks for "Configuring CD/DVD". I analyzed the driver file and LG 4165B (original Apple G5) is in there - why did it not recognize the drive? Anyway it would constantly hang, first asking for new media, than performing a write test.... nothing, the CD-ROM remains quiet, and no progress after several hours. Opening Monitor shows that Retrospect is taking 103 % CPU time, displaying in red that the program is not responding. Aborting the application causes a bus error, requiring to press the power-on button. I tried various media, including CD, DVD and RW, and also replaced the DVD-ROM with a Lite-on 1635S, same story. It creates the .rdi file, but seems to fail with any CD/DVD device. The media, after a restart, comes out untouched.

 

Is the configure procedure supposed to work on a dual or quad-core processor, which uses PCIe bus? It does otherwise not seem to recognize the CD-DVD drive.

 

Best regards,

Markus

Link to comment
Share on other sites

I tried it with an older version 5.1 today. It's basically the same story, albeit a bit different: It sees the DVD ROM in the device list, versions 6.1 did not , and Configure spins the drive. Retrospect still freezes, Monitor shows not responding, drive keeps spinning though. Still not a solution.

Link to comment
Share on other sites

Hi

I seem to be having the same, or at least a similar, problem. Recently changed from a Dual G4 to a Dual G5 (processor not core). I used the migration assistant and all seemed well. Thankfully I can retrieve/restore files without any problems using the internal super drive or the external firewire DVD (AOpen) which I configured on the old system. The problem appeared when I tried to back up. I get error 203/hardware failure when I use the internal drive, then a catalog out of sync message (tried 2 different sets/catalogs). When I tried the external drive I had the same problem as Markus...Spinning beachball-o-death then kernel panic when I have to force quit. No immediate help but maybe the extra info will help someone figure it out...

Thanks

Drew

Link to comment
Share on other sites

Hello,

 

I was going to do some sort of a program execution trace, maybe to see which function Retrospect is calling before it freezes. Unfortunately I don't have much experience with this, so I started to look around. I'm obviously getting borred ;-)

 

From what I can gather, Retrospect does not make this easy. It seems to me that it's a Carbon (OSX/Classic) application, which however won't run under OS 9, requiring 10.1.5 at least. Anyway it's using LaunchCFMApp, which is used for Carbon Applications. But it's also doing a relaunch of itself, at which point Shark or other Utilties loose trace of it. Those tools cannot attach to Retrospect anyway because it's a Carbon app. I tried to locate PEFviewer, but this seems no longer part of Xcode for Tiger. Maybe someone else with more experience has an idea?

 

Below is what I got so far:

 

Europa:~ BB$ ps -ax | grep Retrospect

207 ?? S 0:00.40 /Applications/Retrospect Client.app/Contents/Resources/pitond

562 ?? S 0:01.04 /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp /Applications+/Tools/Retrospect 6.1/Retrospect

596 p1 R+ 0:00.01 grep Retrospect

 

 

Europa:~ BB$ sample 562 100

sample cannot examine process 562 for unknown reasons, even though it appears to exist.

 

Europa:~ BB$ gdb /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp

 

(gdb) r /Applications+/Tools/Retrospect\ 6.1/Retrospect/Contents/MacOS/Retrospect

Starting program: /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp /Applications+/Tools/Retrospect\ 6.1/Retrospect/Contents/MacOS/Retrospect

Reading symbols for shared libraries . done

Reading symbols for shared libraries . done

Reading symbols for shared libraries . done

...

Reading symbols for shared libraries . done

 

Program exited normally.

(gdb)

 

So I examined if there is anything in the console logs:

 

May 8 01:44:11 Europa com.apple.SecurityServer: Succeeded authorizing right system.burn by process /Applications+/Tools/Retrospect 6.1/Retrospect/Contents/MacOS/AuthenticateUser.app/Contents/MacOS/../../../Retrospect for authorization created by /Applications+/Tools/Retrospect 6.1/Retrospect/Contents/MacOS/AuthenticateUser.app/Contents/MacOS/../../../Retrospect.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...