Jump to content

Another "Backup Set Format Inconsistency (7 at 0)" thread


Recommended Posts

I've been making incremental backups of my boot drive to a file on a different physical internal hard disk on my PowerMac G5 Quad for several months. I'm using Retrospect 6.1.126 with update 6.1.3.101, running OS X 10.4.4. I have 3GB RAM.

 

Backups were proceeding normally until January 15, when I began to have this "Backup set format inconsistency (7 at 0)" error during compare, and a few files would remain not backed up. They were all photos in the iPhoto Library, usually the same photos (but not always).

 

At that time, the problem was solved, but I'm not sure how because I took a shotgun approach: Repaired permissions, ran Cocktail's pilot, rebuilt the directory with DiskWarrior (no probs found), TechTool Pro's file tests (no probs found), backed up just the Pictures folder to the same backup set (no errors listed), trashed and rebuilt the backup catalog, and verified the backup was readable. There is a detailed account of this problem in another thread in this forum.

 

So everything was proceeding well again until today, February 13, almost 1 month later. I've installed no new hardware or software in the past several days. I began to get the "Backup set format inconsistency (7 at 0)" error again, and this time 3 files were "remaining," which I think means they were not backed up or not verified. These 3 remaining files were also photos in the iPhoto library folder.

 

Is it coincidence that ericmurphy's thread in this forum had the same "Backup set format inconsistency (7 at 0)" problem, and the files he had trouble with were also in his iPhoto library? This seems rather unlikely. What's going on here?

 

In any case, I selected a few of my shotgun interventions and here's what happened.

 

First I trashed my catalog and rebuilt it using Retrospect. This didn't fix the problem. Another backup had the same results, and the same 3 photos were shown as "remaining." (Maybe when Retrospect encounters whatever condition that causes the "Backup set format inconsistency (7 at 0)" error, it stops verifying.)

 

Next I ran DiskWarrior, rebuilt the directory (no problems found), repaired permissions (no permissions problems as far as I could tell), and then backed up just the Pictures folder to the same backup set using an Immediate Backup operation. Somehow, I think this last intervention is the trick.

 

After doing the above, I was able to complete another boot drive incremental backup without the "Backup set format inconsistency (7 at 0)" error. I didn't have to wipe and reinstall OS X, create a fresh user, nothing drastic.

 

My one remaining worry is whether my backup set is still healthy enough to restore the entire drive, should disaster strike.

 

And I still wonder about this "Backup set format inconsistency (7 at 0)" error...what it means, what causes it, and how to avoid it in the future.

Link to comment
Share on other sites

Well, sad to say it didn't last.

 

 

 

I updated my OS to 10.4.5 this evening, did another incremental backup of my boot drive, and received the "Backup set format inconsistency (7 at 0)" error again. And again, there was one file that remained to be backed up... a photo in the iPhoto folder... and I'm pretty sure it was one of those photos that was involved in the first set of errors noted in the post above.

 

 

 

I'd really like to solve this problem permanently.

 

 

 

Addendum: I did a backup of just the Pictures folder to the backup set, which completed successfully (i.e., backing up successfully the particular photo that remained, above). Then I repeated the incremental backup of my boot drive, which completed successfully this time. So it does seem that a way around the "Backup set format inconsistency (7 at 0)" error is to backup the Pictures folder alone, then run an incremental backup of the whole volume again. This still concerns me, however, and I wonder how reliable my backup set actually is.

 

 

 

I can't help but think this will require a patch to Retrospect, but question if this issue will ever be pinned down to its cause unless EMC sets out to reproduce and solve this problem.

Link to comment
Share on other sites

I did another test today: a completely new backup of my boot drive (not incremental). At the end of the backup, there was again the error, "Backup set format inconsistency (7 at 0)" and 21 files remained. Every one of these 21 files resided in the iPhoto library and were photos.

 

- 2/15/2006 10:27:35 PM: Copying Macintosh HD…

2/15/2006 11:14:34 PM: Comparing Macintosh HD…

Backup set format inconsistency (7 at 0)

(For this post, I deleted the 6 other errors for files that may be expected to change during the backup)

2/15/2006 11:58:42 PM: 7 execution errors.

Remaining: 21 files, 102.5 MB <------ALL OF THESE FILES WERE PHOTOS

Completed: 388182 files, 54.4 GB

Performance: 1362.5 MB/minute (1480.5 copy, 1261.8 compare)

Duration: 01:31:07 (00:09:18 idle/loading/preparing)

 

 

I'd really like some help with this!

Link to comment
Share on other sites

About the iphoto thing i've noticed it always occurs on a file that i've

exported out of iphoto 6, edited in photoshop and added back into the

iphoto library, the only change is usually a "_1" added onto the file

name, i.e. Img_1.jpg.

I've found i can get the backup to work without this error by

manually exporting the file out, removing it from the iphoto library, deleting the(_1) from

the name and adding it back. Generally i've noticed as long as there is somesort of name change, the backup won't show any errors.

PS don't change the filename in the iphoto library directory directly, without removing and reimporting the pic back into the library.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...