Jump to content

Backup Set Format Inconsistency (7 at 0)


Recommended Posts

I couldn't find this particular error on the Mac OS X forums, but I was wondering if anyone's come across this before. Here's what happens: Retrospect backs up data to DVD+R, then asks for the first member of the backup set (which currently has 27 members), e.g., 1-DVD Backup, when it's ready to compare. It loads the first DVD, then asks for the current member, at which point it starts the compare. The backup and compare seem to go fine (the only errors are mod date/time errors due to the long period waiting for media), but since my backups are almost always unattended, it's inconvenient to have to switch disks like this, especially when it seems so pointless. I've tried just ejecting and remounting the current backup set member, but Retrospect obstinately insists on seeing the first member of the backup set before it will accept the current member for verification. The only indication that anything is amiss, other than the unorthodox media switching, is an entry in the log with the above error message on compare.

 

Anyone with any idea as to what's going on?

 

Here's my system: PowerMac G5 dual 2 GHz, 3 Gig RAM, 250 Gig SATA drive, Mac OS X 10.4.4, Retrospect version 6.1.126, Driver Update 6.1.3.101, backing up to DVD+Rs with the factory-installed Superdrive.

Link to comment
Share on other sites

Eric,

I had this problem running an iMac 20" G5 Tiger 10.4.2 backing up my user account to external HD (firewire) (in retrospect file mode). I always had unsuccessful backups due to this error (occuring right at the end of the backup). I could still recover some files, but I was concerned that the backup was un reliable.

 

To fix the problem I:

 

1) backed up my internal iMac HDD with Carbon Copy Cloner (CCC) to my external HDD, reformatted the internal disk and re-installed OSX 10.4.2 from scratch, recreating my user accounts etc .

 

2) copied back the folders in my account from the Carbon Copy Cloner version on the external Hard Drive to the iMac (i.e: "Pictures, Music, Documents" etc ) - but NOT the Library folder. OSX created a new library folder, the only part of this folder that I copied back was my Mail and Safari bookmarks (this is because the Library also containes preferences which I think may have been the problem).

 

After this, Retrospect worked like a dream.

 

What caused the problem - I'm not sure, but when I purchased my iMac , I connected it up to my old machine running Panther and copied everything across to my new iMac using firewire. I am guessing that there was some issue or corruption with my old Panther accounts that were copied across to my new iMac and recreated in my Tiger accounts.

 

Of particular interest was that creating a new install of OSX and accounts also resulted in my new iMac running faster, brighter display and backgrounds and less SBBD (reinforcing that the issue may have been with the Preferences file).

 

Hope this helps..

 

Steve

Link to comment
Share on other sites

Wow...sounds like a lotta work, just to get rid of one Retrospect error!

 

But this problem just appeared a few days ago, with nothing else of note happening to the system. I've wiped out all of Retrospect's preferences, so it's unlikely to be a preference problem. And I frankly can't imagine what information Retrospect is getting by merely looking at the first member of a backup set, and then going back and successfully comparing using the current backup set member.

 

Pretty weird. I'll probably have to spring for a year of support from EMC to fix this one irritating problem.

Link to comment
Share on other sites

And now, to make matters weirder, the backup DVD has started mounting in the Finder. I thought Retrospect 6.x backup members were unmountable in the Finder? This happened after I reinstalled the most recent revision of Retrospect. I got a message from Retrospect that it didn't recognize the DVD, and then the Finder couldn't eject it because it was in use! I had to log out and back in to regain control of the DVD.

 

Why does it seem that whenever Retrospect runs into problems, the problems just get worse and worse until it stops working completely?

Link to comment
Share on other sites

Quote:

I thought Retrospect 6.x backup members were unmountable in the Finder?

 


 

Why did you think this?

 

Dantz came out with a file system plug-in for Retrospect 5 (I think it might have been first offered in a later build of 5.0, but for sure it was included in 5.1). Without the plug in, the Finder can't see optical disks; with it, you can.

 

You likely didin't have the plug-in installed before, and your "easy" install included it (a custom install can be used if all you want is the application without the system level components).

 

I _think_ the kext files are in /System/Library/Filesystems/ but I'm not sure, as I don't have them installed.

 

As for your disk in use issue, you haven't provided enough information to offer a suggestion. Knowing the exact steps you were taking would be needed before commenting.

 

Dave

Link to comment
Share on other sites

  • 4 weeks later...

The problem is resolved. It turned out to be a particular image file in iPhoto. I'm not sure exactly why that file was problematic, but removing the file solved the problem automagically.

 

If you're having a similar problem, I'd go through the log, try to figure out which file is the problem, remove the file, and hopefully you'll be good to go.

Link to comment
Share on other sites

I have been getting the same error "Backup set format inconsistency (7 at 0)" on a file backup since 1/29/06 but just noticed it now. In my case, 6 files are not being backed up. Based on other comments on this thread and on a companion thread in these forums (search for "Backup set format inconsistency (7 at 0)") the files not being backed up are iPhoto files. In my case, and I suspect everyone else's, the problem started with the first backup after upgrading to iPhoto 6. So the problem relates to some type of interaction between Retrospect and iPhoto 6. My guess is it has something to do with how iPhoto 6 rebuilt the photo libraries. Some comments have mentioned file names ending with "_1.jpg" being the problem files. While that may be true, it is not true that every file ending with "_1.jpg" is a problem; I have 6 problem files and 53 files with that ending.

Link to comment
Share on other sites

Wednesday, March 15, 2006 I made the following post w/o realizing there was a thread on it already. I have 5.0.4 iPhoto installed on my computer and I see no _1.jpg in the files listed in the error message.

 

Wednesday, 3-15-06 post: I have Mac OS X version 10.4.5 on my iMac and Express 6.1.126. I keep getting messages like the following one:

 

3/15/2006 1:29:54 PM: Copying Macintosh HD…

3/15/2006 2:48:25 PM: Comparing Macintosh HD…

Backup set format inconsistency (7 at 0)

File “DirectoryService.server.log”: different data size (set: 1546, vol: 1601), path: “Macintosh HD/Library/Logs/DirectoryService/DirectoryService.server.log”.

File “SystemEntropyCache”: different modification date/time (set: 3/15/2006 1:53:25 PM, vol: 3/15/2006 2:53:26 PM), path: “Macintosh HD/private/var/db/SystemEntropyCache”.

File “ntp.drift”: different creation date/time (set: 3/15/2006 1:50:30 PM, vol: 3/15/2006 2:50:37 PM), path: “Macintosh HD/private/var/run/ntp.drift”.

3/15/2006 4:04:24 PM: 4 execution errors.

Remaining: 8 files, 21.5 MB

Completed: 380218 files, 28.3 GB, with 11% compression

Performance: 377.1 MB/minute (373.3 copy, 381.0 compare)

Duration: 02:34:30 (00:00:55 idle/loading/preparing)

 

I have spent untold hours trying to find the info I need on the websites - to no avail. And I obviously can't backup my computer. This makes me a little crazy. Last year before Retrospect, I lost a lot of files on my old computer. The experts couldn't fix it. The thought of it happening again is trully frightening.

 

FYI for a little history if it helps: Last week I posted about an incorrect "disk full" message when trying to backup. This seems to be related to the problem.

 

Please help me if you can.

 

Thanks,

Faith W.

Link to comment
Share on other sites

Of the 4 execution errors, only the first one "Backup set format inconsistency (7 at 0)" is important. The other three are due to file changes between when the files were written to the backup and when the comparison occurred. These will self correct the next time a backup is performed.

 

As a result of the backup set format inconsistency, 8 files were not backed up, Unfortunately, the log does not identify the files. They are, howerver, identified in the exception report that Retrospect displays at the conclusion of the backup session. But, with default preferences, Retrospect usually quits automatically, so you'll never get to see the exceptions.

 

Try this. Under Retrospect preferences, under Unattended, select "Stay in Retrospect." Then rerun your backup. Snapshot (cmd shift 4), print or save the exception report. That will tell you exactly which files failed to backup.

 

Don't be surprised if you get some number other than what you got before. I would then verify that the files are undamaged by trying to open them from the Finder. I aso suggest you try to restore the files Retrospect says it failed to backup. (You don't have to do the restore, just have Retrospect search the backup for the files it told you shouldn't be there.) In my case, I found that some of the files were indeed backed up although I was unable to find any logical pattern for what is going on.

 

I'm beginning to suspect something very strange going on with Retrospect.

Link to comment
Share on other sites

The log doesn't show the files involved with this type of error, in my experience; when you do the backup and get the Format Inconsistency error, there is another window that opens automatically showing the files involved. Once you close that window, I have found no way of getting it back (except doing another backup). You need to look at the files in that window to see if they are image files ending in _1.jpg, or _2.jpg, etc. Renaming the files fixed the problem for me. I detailed the process in another post; you have to drag the files out of iPhoto to the desktop, delete them within iPhoto (and empty the iPhoto trash), then rename the files on the desktop and drag them back into iPhoto.

 

Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...