Jump to content

v17, multicast port unavailable, and unnecessary server install, solved

Recommended Posts

I'm just posting this for others, since I found the answer already.

Upgraded to v17 and at more or less the same time, migrated a client from a Macbook Pro 2019 to another almost exactly like it. After that, the client wouldn't work while showing the error "multicast port unavailable". Tried this and that (other network interface, reinstalling the client) to no avail.

Now, there's another problem, namely that Retrospect v17 changed its installscript so that you don't get to choose between installing the console/dashboard and/or the server, so it always installs the server even on clients. I just thought this was a nuisance, having to stop the server through the control panel. But clearly, it's potentially worse. (BTW, Retrospect support called this "streamlined install"..., why oh why....)

The solution was to run the uninstaller you can find in the Retrospect app package, then install without the server. The way to do that, i.e. to go around the installscript, is to open the Retrospect installer package and in there, under Resources, find the actual console application Retrospect.app in a zip file, unpack that and copy it to your /Applications folder. Now you've got the console app without the server daemon running on the same machine.

This made the error go away even without reinstalling the client yet again.

Maybe this saves someone else some aggravation.


PS: on another client I do have the server still installed but stopped and it doesn't have this problem, so it only happens sometimes.

Link to comment
Share on other sites

After installing it again on a laptop, I noticed it was slightly more convoluted to install without a server. The procedure in my previous message only worked because I had already had Retrospect installed and removed before that, but I didn't realize that made a difference. It does.

  1. So, download the full install file, the one without "au" in the name.
  2. Run the installer, which then installs both the console app and the server daemon whether you want it to or not.
  3. Open the Retrospect.app via "show package contents", go Contents -> Resources, run the Uninstall script. Now both the app and the server get removed.
  4. Open the install file you downloaded, Retrospect_17_0_0_149.zip, unzip and you'll get "Install Retrospect".
  5. Do "show package contents" on "Install Retrospect".
  6. Under Contents -> Resources, you'll find Retrospect.zip, unzip that.
  7. Move the resulting Retrospect app to Applications. 
  8. You're done.

The reason for first installing and then uninstalling, followed by a copy of the app is that if you only copy the app (step 5-7 above), the app runs the full installer anyway, dumping the unwanted server daemon in your machine. By doing an install then an uninstall then a move, the server daemon does not get installed the second time around.

One can only hope Retrospect come to their senses about this "streamlining" of the installer...

BTW, does anyone know why Retrospect wants to install the server daemon on every client? There must be a reason. Or?

Link to comment
Share on other sites

On 4/19/2020 at 2:40 PM, insont said:

BTW, does anyone know why Retrospect wants to install the server daemon on every client? There must be a reason.

I think I understand what you're trying to do -- your use of "client" had me confused, but I'm not sure what we should call a machine that runs the Console app. Manager?

But yes, it appears that the advertised "Console only" installer also installs the Retrospect Engine. Two simple solutions spring to mind:

  1. Run the full install, then stop the Engine in System Preferences (remember to uncheck "Launch on Startup")
  2. Download and run the .au app/installer, run the uninstaller as you describe, delete the /Library/Application Support/Retrospect directory. You can then run the app without it re-installing the Engine

TBH, I'd just do the first -- a lot less trouble, less chance of unintended consequences, and only ~70MB of "wasted" disk space.

Though I agree, it would be nice if the installers behaved as advertised!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...