Jump to content

-559 error for "client" running macOS 10.13 after 2 hours

Recommended Posts

I run a Recycle backup of my MacBook Pro "client" once a week, scheduled for 3 a.m. on Saturday. Lately I've discovered that if I stop working before 3 a.m. but leave the MBP up, Retrospect Mac 16.1 gets a -559 (network connection timeout) error for that "client" (it skips to backing up local drives) precisely 2 hours after I stopped using the MBP—apparently because a forced upgrade of my MBP to macOS 10.13 eliminates the slider for "Computer sleep" in System Preferences->Energy Saver's "Power Adapter" tab.   Re-running the Backup script with No Media Action completes the backup of the MBP, but notably that re-run takes less than 2 hours.

My first hypothesis was that there was a failure after two hours in one of my Motorola MoCA bonded 2.0 adapters, which for nearly a year I've had attached to the two ends of a detached coax cable running in my apartment between my study (which is where the MBP is located) and my bedroom (which is where my Mac Pro "backup server" is located). I developed that hypothesis because, about 6 months ago, the adapter in my bedroom seemed to go dead until I reset it with an unrolled paper clip. However last week I switched back to my 4-year-old Actiontec MoCA 1.1 adapters, and this week I got the same -559 error.

I upgraded my MBP to macOS 10.13 about 8 months ago. Before that I had the the slider for "Computer sleep" in Energy Saver's "Power Adapter" tab set to "Never", but that slider has been eliminated in macOS 10.13.

I noticed that the Retrospect Mac cumulative Release Notes has, for, "Mac Client: Fixed issue where client did not prevent macOS from going to sleep during backup (#7273)". My current hypothesis is that #7273 is no longer operative in 16.1, and the lack of a fix is showing up for clients running under macOS 10.13.

P.S.: The body of this post is copied from a Support Case I filed before posting in this Forum.

Edited by DavidHertzberg
P.S.: The body of this post is copied from a Support Case I filed
Link to comment
Share on other sites

The "Sleep" slider has been eliminated because they've tied computer-sleep and display-sleep together -- the default is that, when your display sleeps your computer does too.

But below that is a "Prevent computer from sleeping..." checkbox and, with that ticked, the display will turn off but the computer remain awake. That's how I leave my work iMac so I can access it from home of an evening.

That's how it *should* happen, anyway. Maybe you've got some borked settings from the "upgrade"? Check the "Power" section of a System Information report, "System Power Settings"->"AC Power", and the "System Sleep Timer" should be set to "0" (ie never) or the same as "Display Sleep".

Try leaving the MBP's Console running overnight, then searching for "sleep" in the morning -- if it is sleeping you should see some "prepareForSleep" messages from the apsd process.

It's a shame if the client no longer keeps the Mac awake during backup but, in your case at least, it should be an easy workround. And if your Mac isn't honouring your Energy Saver settings, try an SMC reset.

Link to comment
Share on other sites

Currently I've got "Prevent computer from sleeping automatically when the display is off" and "Enable Power Nap while plugged into a power adapter" checked. "Put hard disks to sleep when possible" and "Wake for Wi-Fi network access" are unchecked. Those aren't precisely the settings as of a week ago Sunday night (I was out of town Saturday); I since changed them per Nigel Smith's suggestion, and can't remember what they were before.

Retrospect Tech Support suggested that I change network timeout from 300 seconds, which is what it has been every time I've gotten a -559 error, to 9000 seconds.  I did so,

Saturday morning, since I was awake working on my MacBook Pro until past 3 a.m., I rebooted my  MBP before booting my Mac Pro "backup server", in order to see if the Recycle backup would run for precisely 2 hours before getting a -559 error. I then went back to bed. The MBP backup ran fine—including a Compare phase—for 3:45 hours; the "backup server" kept running the script to back up its local disks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...