Jump to content

soccClose error message during backup

Recommended Posts

Well this post is a bit long, but I tried to accurately describe the problems I've run into.


When attempting to back up a MacBook Pro (over ethernet) to a Disk Media Set which is stored on a hard drive connected to a Mac mini via USB 2 the operation never really got going. In the Retrospect Console viewing the backup script's progress the backup operation was hung up at "please wait..." in the summary window.  The log detail window said:

"soccClose: shutdown() failed with error 0".

I took a look through the documentation, but I found no mention of this error. Meanwhile, after 3 hours of the script being stuck on "please wait"  I told the script to pause, which seemed ineffectual. So I tried the stop button with the same result–I felt ignored. So I went away and pouted for half hour then came back and opened  System Preferences and clicked the button to stop the Retrospect Engine, but  that didn't seem to affect anything either. But I felt more patient this time and after 5 minutes Apple's Console app reported:

com.apple.launchd[1]: (com.retrospect.retroengine[65]) Exit timeout elapsed (600 seconds). Killing

That got the Retrospect engine finally stopped.

I could still ping the computer being backed up succesfully with Network Utility this whole time.

Rebooted the Mac mini, which got the Retrospect engine was running again. There was no log entries about the backup operation it was  running when the error came up. The activities pane did not list that the backup script had run either.

I tried running the same script that failed and it reports error -519  in 2 seconds, even though I could ping it and also refresh it in the sources tab. Weirdly, going to the add clients, the list doesn't show the MacBook Pro, but testing the address by choosing its IP does show the client. Also, when clicking "refresh" when viewing sources in the console  sidebar, the message "querying client" closes real fast. Suspiciously fast since other clients Retrospect can still backup on the network take several seconds to respond and close the query message.

Other scripts backing up different computers to the same media set worked ok. I made a new backup script for the MacBook Pro, but when it rans it immediately returned a -519 error (network communication failed). I also made a new media set, but running a backup got an immediate -519 error.

It ocurred to me to restart the MacBook Pro, which I don't think I did before. After doing that I ran the new script with the new Media Set and things behaved as they did in the biginning with the "please wait" and "soccClose: shutdown() failed with error 0" again.

Frustrating and confidence shaking. Not fun. Any ideas?

Mac mini OS: Mac OS X 10.8.5
Retrospect Version: 10.5.0  (145)

Retrospect client version:
MacBook Pro OS: Mac OS X 10.7.5


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...