Jump to content

Case-sensitive restores work ONLY on PPC clients

Don Lee

Recommended Posts

Retro 10.2.0 (221) running on Mac OS X 10.8.x


I would like to have a Mac OS X volume that is case sensitive, and back it up with Retrospect.  I generally test before I rely on them, and I have found that case-sensitive restores do not work on local volumes, nor with a "new" client.


If I have 3 files "FILE", "file" and "File" on a case sensitive volume, they are restored correctly on a Mac OS X 10.5 client running on a PPC machine. (client v 6.3.029), but that is the ONLY way I can get it to work correctly.


On local volumes (local to the machine running the Retro engine) they come out as "FILE", "File-1" and "file-2".  I get the same result on several variations of local volumes that are formatted as HFS case-sensitive.  I have also tried this on a Mac OS X client running 10.6.8, and Retro client 10.2.0 (221).  I formatted an external Firewire drive case-sensitive, journalled.  I got the File-1, file-2 result.


Obviously, this would not be acceptable where many files depend on case differences.


Is case sensitivity supported?  I am squeamish about relying on my 10.5 PPC system for something I need, and if I start doing this, it will be "production" for me.



Link to comment
Share on other sites

  • 1 month later...

When I tried this back in September, I could not get the case-sensitive restore to work.  Now that I go back and try to figure out exactly when it fails, I can't reproduce the failure.


Let's write this off to gremlins, or cockpit error on my part, unless/until I can put together a real test case.

Link to comment
Share on other sites

  • 3 weeks later...

Tried to reproduce this again yesterday, and could not do it. I've tried local (to the engine) filesystems, filesystems on Retro 6.x clients (Mac OS X 10.5), and Mac OS X 10.6 machine with a Retro 10.2 client, and all work flawlessly.


I hate this. Maybe I was drunk at the time.....


I'll keep trying. Having been convinced at one point that it was not working, I would be happier to find the precise combination of conditions that cause the failure, but so far, the bug has been too sneaky for me.


I'm relying on the feature now, so if it fails, I'll know it, and it will matter. ;->

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...