Jump to content

Retrospect 10 issues and problems

Recommended Posts

  • When doing backups the catalog is not updated. If your not aware of this, then doing restore would lead you to think backups where not done. You have to recover the backups done in the catalog before any attempt to do a restore!

  • I did erase a directory by error and when I tried to restore it I got the message “erreur -1101, file/directory not found » when I tried a second time all files and sub-directories where subsequently restored (it seems that the 1’st directory has to be created and the other ones are correctly restored) This is valid for Mac OSX and Windows 7 system

  • I moved a directory up one level and the backup did save the file in its new location, however when wanting to a restore a file it never did it. It claimed that there where no files to restore (even though I select the file and it was present in the backup)

  • I have noticed that several files are selected for backup and they have not been modified in any way. (This has happened twice where files of images that are very old and have not received any modifications) What mechanism are you using for detecting file/directory changes?

  • I have used threads to differentiate my backups, allowing the server to use 3 threads at a time. When I did an upgrade of Mac OSX and rebooted the system my setup where completely lost. It all came back to one thread and all the backups where set to the 1 thread only!

  • I’m using growl for my message alert, Retrospect 10 has no information of what script is running! It would be nice to have it as seen in Retrospect 9

  • When backup a Windows 7 64bit system you get a lot of errors when doing backup of the directory “C:\Windows\Temp”. Should this directory be added by default on the Privacy tab.

  • When you are in the section backups done, you can recover the job information only once! You can select the jobs you want to recover but the button is faded out and it’s impossible. The only way is to restart the Retrospect application.


I don’t feel comfortable with the quality of Retrospect 10, it looks like there are issues that should have been corrected.


In fact I have decided to downgrade back to Retrospect 9 and will wait for some time before upgrading.



  • Like 1
Link to comment
Share on other sites

I just updated my Retrospect and what a mess. It deleted Retrospect. I had to recover it from the Trash. I had to install a new engine. Plus, none of my scripts or activities show. The app folder looks the same as the one from my Time Machine backup but Retrospect is the newer version. Everything else is the same. I don’t know why none of my scripts, sources etc are showing.

Link to comment
Share on other sites

  • 3 months later...

I have been experiencing the same nagging issue of Retrospect 10 continuing to backup files that have already been backed up. I am about to throw in the towel on 10 and move back to 9. I sat on version 6 for years... I can do the same for 9 if I can bring everything back to correct operations.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...