Jump to content

VSS crashes, can't duplicate C volume


Recommended Posts

Until this week, I've been able to create a Duplicate of my System volume with just a couple of warnings. Now, however, Retrospect is unable to start VSS and the Duplicate operation begins with the error "Can't use Open File Backup option for System (C:), error -1017 ( insufficient permissions)", then produces about 70 errors before quitting with " Can't duplicate System State, error -1017 ( insufficient permissions)". This is new behavior, but I haven't been able to trace it to any particular update or other change. The Event Log errors are always the following:



Volume Shadow Copy Service error: Unexpected error calling routine Cannot find anymore diff area candidates for volume \\?\Volume{32eb0121-e478-11de-884b-806e6f6e6963}\ [0]. hr = 0x8000ffff, Catastrophic failure



Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details EndPrepareSnapshots({35596376-1998-4466-bbb5-d655bbc6728e}) [hr = 0x80042302, A Volume Shadow Copy Service component encountered an unexpected error.


I have used Disk Cleanup to clean out old shadow copies and restore points, to no avail, and I have re-registered the VSS components in the Registry, but the problem persists. Anyone else have this problem and know how to resolve it?


I'm using Retrospect 7.7.620.



- David

  • Like 1
Link to comment
Share on other sites

A bit more information:


I am running Windows 7 Home 64-bit.


When I try to run VSSADMIN to find out the writers or to delete shadow copies, I get the following errors in the Event Log and VSSADMIN also returns an error.


Event Log error 22:

Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and Name IVssCoordinatorEx2 is [0x80040154, Class not registered].


Event Log error 8193:

Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80040154, Class not registered


From VSSADMIN, I get:

Error: A Volume Shadow Copy Service component encountered an unexpected error.

Check the Application event log for more information.


And finally, when I try to register the components of VSS, several of them do not register or cannot be found. Yet, I have run System File Checker with no errors.


This problem seems to only affect Retrospect's use of Open File Backup. I can run Paragon Drive Backup, which also uses VSS, and can create Restore points.


Any help is greatly appreciated! I have tried several purported VSS fixes found on the Internet, but none have been successful and most I have not been able to run to completion because VSSADMIN does not run on my system, and none of the troubleshooting I have done has gotten it to run, either.

Link to comment
Share on other sites

One other detail: At about the same time, I started getting errors from Bitlocker at boot time. As I am running Windows 7 Home, bitlocker should not be on the system. I am wondering if something installed bitlocker on the system in a broken fashion, and that's causing a problem with VSS. I have no idea how to decrypt anything that might be encrypted and then remove bitlocker, if that's the case, and would be grateful for some pointers. What I've found on the Internet seems to apply only to a full, working installation of Bitlocker.

Link to comment
Share on other sites

In case anyone else has this problem and finds this thread, I was apparently able to solve the shadow copy / bitlocker parts of the problem by using mountvol /r to remove old mount volume data and mountvol /e to enable automatic mounting of new volumes. I don't know why this worked, but it appears to have eliminated the bitlocker errors, which in turn appears to have eliminated the VSS errors when I try to do an open file backup with Retrospect. Still not positive all is as it should be, but so far so good -- I did do a normal backup of my system volume.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...