Jump to content

Trying to restore, but Retrospect can't seem to do it without hanging! Help!

Recommended Posts

Retrospect 9

MacBook Pro 2GHz Intel Core Due

1GB Ram

OSX 10.5.8


Hi all,

I used to run Retrospect 6 on an old Mac Quadra with a DAT drive and 5 clients, and it was never a problem, it just worked.


But 2 years ago, we updated to Retrospect 8 on a MacBook Pro 2GHz Intel Core Due, a Drobo and the same 5 clients, everything still seemed OK. However, as I have now updated Retrospect to v9, its not OK. Backups themselves seem to be working fine, but if I want to restore anything, then I'm in trouble. Retrospect goes so slowly, takes an age to bring up the info I'm looking for and more often than not, falls over all-together (spinning wheel of death).


Has anyone else experienced similar issues, and do you have any pearls of wisdom for me? Is the MacBookPro too old/slow or the OS too old?


Please help me, I'm desperate here!





PS. I hate Retrospect, its enough to drive a man to drink!

Link to comment
Share on other sites

Thanks Maser for your reply. Yes, you are right about the bug. I have been in contact with them about this issue, and amazingly, within the hour, they replayed, acknowledging the problem, and offering me a download for a pre-release version This has worked perfectly, and now Retrospect is behaving as it should.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...