Jump to content

Restoring A Disk Is Easy. Not!

Recommended Posts

Yesterday I got serious problems on a disk in a Mac mini. Serious enough that I had to reformat and restore from a backup.

No big deal, because I use Retrospect 8.2, the last backup was 36 hours ago and I hadn't created any important documents/mails etc. on that mini since.


So I booted from a second disc with the Retrospect client on it. Reformatted the internal hard drive and started an entire disc restore from the Retrospect server.


That failed after about 9 GB. Why?


!Trouble writing folder "MiniPRO/Applications/CrashPlan.app/Contents", error -1017 ( insufficient permissions)


It was trying to restore the Crashplan.app file and that file has the "locked" attribute set. And because of that, Retrospect can't restore the file! :angry:

So I copied Crashplan.app from another location and removed the "locked" attribute via Get Info.


Started a new restore action to restore the remainder of the files. That ran all night and most of this day. But when I got home, I noticed that the restore operation had stalled and wasn't moving. Not a single bit had been restored in the past 17 hours!

Tried to stop the restore job, but that didn't work.

No response whatsoever from Retrospect.


So I tried to stop the Retrospect Server.

Didn't work either.


Rebooted the machine that runs Retrospect.

And of course, I lost the activity line in Retrospect, so I cannot view the logs of that restore job to see what went wrong and where.

Thank you Retrosuck. Beautiful piece of software that keeps log data and preferences all in 1 file. Nice architecture.


At this moment I've restarted the restore job for the third time.

Just to restore one lousy disk completely.

That's totally unacceptable for software that's supposed to help people recover from disaster.


Add this feedback to the list of customers who are getting more and more frustrated on a product that used to be good.

Link to comment
Share on other sites

Retrospect did it's job on the third attempt with good success. My drive has now been restored to the original state and I can reuse my Mac again.

But a restore operation like this with these kinds op troubles has really put a dent in the trust I put into this backup software.


I've restored before with Retrospect and never had issues like these.

I even walked away smiling when a disk crashed a couple of years ago, knowing that Retrospect would rescue me. And it did.


Now I'm not so sure anymore.

Link to comment
Share on other sites

Relying on more than 1 backup solution is certainly a good idea.

Next to Retrospect, I use TimeMachine for backups. But not for complete disks. That's why I have Retrospect and it has done an excellent job on that in the past.


Tools like SuperDuper and Carbon Copy Cloner are nice, but in my opinion not fit for real backups, because of the way people use the copies. When their disks crash, they always (*) take their clone disk, boot their Mac from it and shout how happy they are because they are back up and running in 5 minutes.

What they fail to see is that when that happens, they no longer have a backup.


(*) there are exceptions to this, but my guess is that 99,9% of the people work this way.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...