Jump to content

Bad backup set header

Recommended Posts

In reading a few of the previous posts (and being new to this forum) I'd like to know if anyone has resolved the error: "Bad backup set header" It seems that this is a common error in both the OS9 and OSX side of Retro (workgroup). The serious problem is that this kills a restore. I have a number of Macs and PCs served by Retro 5.0.205 writing to a SCSI AIT device off a G3 mac running 10.1.4. I've installed the Adaptec 39160 and v1.1 driver, but according to this forum, it seems that these "bad backup set header" errors happen when using Firewire devices as well. As a result of these errors, my backups are completely unreliable, and restores are killed. I have 12 GB of data that cannot be restored because of these. Is this an AIT problem?




I've tried the standard fixes: cleaned tape heads, replaced AIT drives, OS9.2 and OSX (both running Retro 5.0.205), and yet the errors keep happening.




I'm worried about my false sense of security with this version of Retrospect.









Link to comment
Share on other sites

The following article refers to DAT drives, but may be applicable to your situation:






Some users have reported "bad backup set headers" while attempting to back up to the Sony SDT-10000 or SDT-11000 (DDS-4) drives under OS X. All incidents have had a SCSI adapter in common, the Adaptec 39160.




Many of these users have installed updated 39160 drivers from Adaptec (versions 1.0.2 or 1.1). A subset of those users have been able to eliminate the problem by downgrading the driver to either a previous Adaptec version. This has not worked in all cases.




DantzLab has been able to reproduce the problem with driver version 1.0.2 and 1.1 from Adaptec. We can not reproduce it with version 1.0.0, the Adaptec-written driver supplied with the Apple OS X installation CD. Dantz recommends that for proper operation of devices under OS X with the Adaptec 39160 card, users should downgrade to the Apple-supplied driver.




To downgrade the driver, you must be logged into the Finder as root, or use a third- party utility that allows you to see, access and delete files owned by the system. Those familiar with the Terminal can su to root, if that account is enabled, and accomplish these steps in the Terminal.




1. Remove the driver version 1.0.2 or 1.1 by deleting the "Adaptec39160.kext" file from /System/Library/Extensions.




2. Replace the deleted driver with the one on the Mac OS X install CD. It is located in the same path on the CD (/System/Library/Extensions/Adaptec39160.kext). To navigate to this path, you must close the auto open CD window and reopen the CD to get to the root level.




If you have any problems with these instructions, you should contact Adaptec or Apple for further assistance.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...