Jump to content
Sign in to follow this  

Can't get linux client to work

Recommended Posts

Hi! I think I have done just about everything in order to get any linux client to make a backup without luck.

What happens is the following (after installing client software and adding client) on the server:

If I select "Properties - Volumes" I will get the error message "Can't track volumes, error -519 (network communication failed)" and after that I will get the error message "Sorry, couldn't connect to ..., error -505 (backup client reserved)" whatever I do. The client have to be stopped and restarted.

When making backup (proactive or immediate) nothing happens or error -519. On the client the message is "reserved by <server> for Preparing..." and the number of connections are increasing for every attempt.


I have Multi Server, Version 7.5.387, Driver


I have tried the following:

Ubuntu 7.04 with client 7.5.112, 7.0 and 6.5

PuppyLinux 2.15CE with client 7.5 and 7.0

Red Hat Enterprise Linux 4 with client 7.5.111

Red Hat Enterprise Linux 5 with client 7.0.112 and 7.0

and maybe some other combination.

None works but we backup about 50 XP/2k/98 clients and a few Macs without problem.


An irritating fact is that some year ago I installed a client on an older Ubuntu version to test and it worked directly. That was probably with server ver. 6.5


Any suggestions?

Does this server version work at all with linux clients?



Share this post

Link to post
Share on other sites

The Linux client works very well, at least most of the time. ooo.gif


My first thought is a problem with the network connection, perhaps a duplex mismatch. Run ethtool or mii-diag on your NIC (usually eth0) and see what it says for the duplex setting. Do you have access to your switch to find out what it is set at?

Share this post

Link to post
Share on other sites

I have Retrospect Linux Client 7.5.112 running with Ubuntu 7.04.


I first made sure that my Ubuntu Client Machine could communicate with the Window XP machine by reading a file from a shared folder.


Installed Bootup-Manager via Automatrix.


From Terminal prompt, I ran "sudo apt-get install alien" (used to convert the rpm file to deb)


From Terminal prompt, next you want to run " sudo alien -d -c retroclient-75_linux.rpm" to convert rpm file to a deb file


Next I went in via Natilus and loaded the Deb file via the GDebi Package Installer. It prompts for an access password.


Next I went into Bootup-Manager (System, Administration) and put a check next to "rcl" to allow client to load during startup.


Other than normal Retrospect setup, I used the "Sbackup" (loaded thru Automatix) as a template on what to backup. I delete "Sbackup" afterwards thru Automatix.


I am backing up my Ubuntu files with Retrospect 7.5 server for Windows.

Share this post

Link to post
Share on other sites

I finally was able to get my linux clients to work. I don't understand why but at least how.


My backup server (win2003) is behind a netgear fvs338 firewall setup to send port 497 traffic to the backup server. The server also has a Appgate 2.0 software firewall.


This (rather safe) setup works fine with windows and macos clients but linux clients only connects and then I usually get the "Backup client reserved" error. Using an old linux backup client computer that have been known to work before (with my old w2k server) and turing off software firewall and connecting behind the hardware firewall it finally worked. Some additional tests shows that turning off the software firewall makes the linux clients work without problem. Something differs obviously between how the linux client and the other two communiate with the server.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this