Jump to content
Sign in to follow this  
amkassir

Retrospect 10.1 Instant Scan resurrects after restart

Recommended Posts

I was delighted to see that Instant Scan can be disabled easily in the Retrospect prefs pane after upgrading to Retrospect 10.1.

 

Problem is, the setting doesn't stick after a restart. I don't really need Instant Scan for several of my smaller backups, and I don't really trust it yet. But do I really have to remember to disable it after every restart?

 

That is, do I have to resort, once again, to:

 

sudo launchctl unload -w /Library/LaunchDaemons/com.retrospect.retroisa.plist

Modify the RetroISA.ini file by changing
StartRetroISA=1 to StartRetroISA=0

 

The fact that the Instant Scan can be disabled in the GUI is kind of moot if you have to go back to the terminal, isn't it?

 

Comments welcome...

 

 

EDIT: I think the "RetroISA.ini" file name should be "retro_isa.ini".

Edited by amkassir
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for posting, good point.

I would surely like the RetroISA to be self-controlled at all times and permanent if tweaked.

 

Cheers.

Share this post


Link to post
Share on other sites

We have checked again and Instant Scan (RetroISA) stays enabled/disabled as expected after restarting the Mac.

amkassir, we will follow up with you via your existing support ticket on the installation issue.

Share this post


Link to post
Share on other sites

We have checked again and Instant Scan (RetroISA) stays enabled/disabled as expected after restarting the Mac.

amkassir, we will follow up with you via your existing support ticket on the installation issue.

Mr. Lee:

Thanks for your reply. I will look for further communication regarding this issue via my existing support ticket.

However, I thought also to continue discussion in this forum in case other users run into the same issue.

 

When figuring out how to solve this problem, it is probably useful to know that I did edit the "retro_isa.ini" file and used the launchctl command shown in the first post in this thread when running Retrospect 10.0, in order to deactivate the RetroISA process. After deleting the retro_isa.ini file and installing 10.1, I couldn't get Instant Scan enabled in the prefs pane until I undid my launchctl command by entering in terminal:

 

sudo launchctl load -w /Library/LaunchDaemons/com.retrospect.retroisa.plist

 

I'm suspecting now that the reason my Instant Scan process is always enabled after restarting the computer is because of this command, and perhaps specifically because of the -w modifier. I don't really know because this is not an area I'm knowledgeable about and maybe somebody can suggest a command I can enter in terminal to fix this?

 

Thanks.

Share this post


Link to post
Share on other sites

I'm suspecting now that the reason my Instant Scan process is always enabled after restarting the computer is because of this command, and perhaps specifically because of the -w modifier.

 

The -w option can cause the symptom you described, because it overrides Retrospect's control of Instant Scan. Apple's documentation also says: "In previous versions, this option would modify the [in this Retrospect's] configuration file. Now the state of the Disabled key is stored elsewhere on-disk." We are evaluating what steps are safe enough to post on our knowledge base to undo the -w option.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×