Jump to content
Sign in to follow this  
squibbydog

Keep receiving error -557 (transaction already complete)

Recommended Posts

I keep receiving error -557 on one of my clients (Windows 7 64 bit, client version 7.7.114). This is not the only client that I am having this error on, but this is a newly built client. I've run chkdsk on the client drive, no errors. Everything looks okay on the client, but continually having this error about 75G into a 150G backup. How can I turn on debug to show what specific file(s) Retrospect is having an issue with - if any?

 

I have also uninstalled and reinstalled Retrospect Professional, and still the same issues. The server version is 7.7.620, running on Windows 7 64 bit,

 

Any help greatly appreciated.

 

-Stephen

Share this post


Link to post
Share on other sites

Have had this problem several times. Uninstalling and reinstalling the client does NOT work. This requires removing the application from control panel / add/remove programs and then checking for any left over "retrospect data" in these locations and deleting them:

 

C:\ProgramData\Retrospect Client

C:\Program Files (x86)\Retrospect

C:\Program Files\Retrospect

C:\Documents and Settings\All Users\Application Data\Retrospect Client

 

Once everything has been cleaned and the "left-over" directories have been manually deleted, REBOOT, then reinstall the lastest client version again.

 

One other thing to note. Retrospect (from the server) does not automatially remove the "old" client that you just removed from the computer. You have to manually remove it from Configure / Clients in the left side panel options. So once you've cleaned the client side and reinstalled and re-add it to the server, you'll actually have 2 instances of the same client - the old "bad" one, and the new "good" one. Should that happen, make sure you don't accidentally point your backup script and/or backup set to the old client instead of the new one (once you've rejoined it to the server), or you'll still get the error -530 backup client not found, because of course, it won't actually exist as it was removed.

Share this post


Link to post
Share on other sites

I had this problem just in the last few days, it only started last Friday, yet the same script worked perfectly the night before and it continues to work on all sources except this one source. To investigate it further, I did a manual backup using the same source but I previewed the files that were selected. I identified the first file that it wanted to back up (all the ones before it were already in the archive) and deselected that file so that it wasn't backed up. I then ran the backup on the remaining files.

 

The backup completed successfully, so I believe that it was the specific file that was damaged in some way, and Retrospect was unable to successfully complete the backup, so it reported the error and gave up. I have deleted that file (it was a database backup that is created every night) and everything is working fine now.

 

So in my situation, the error had nothing to do with the client, it was a specific file. If you are reading this, you may find this is what resolves your issue. If nothing else, doing a manual backup and previewing the files will identify where it is getting stuck.

 

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×