Jump to content

Backup using script - can't access hard drive destination


gallin

Recommended Posts

I set up a script to back up daily to a hard drive located on another computer in my network. Each time the script starts I am asked to locate the member to back up to. When I select the disk I am asked for a username & password even though all computers on the network have access to all disks. No passwords are requred anywhere on this system. I can't seem to bypass this request. I did an immediate backup which worked, it's the unattended script that doesn't work. I assume there is a setting I overlooked - any ideas?

Link to comment
Share on other sites

Take a look at Preferences -> Execution -> Security and set up the "Run Retrospect as the specfied user" to be you (e.g. name, password, domain or machine name). Even though you don't mention your network setup (domain, workgroup), it's likely that the computers on the networks are recognizing that you're "[not] one of us." When you run the immediate backup you are logged in as you. When Retro runs unattended, it's a localsystem account and doesn't have network privledges.

Link to comment
Share on other sites

I did try your suggestion but when I go to Preferences -> Execution -> Security I don't find the option to "Run Retrospect as the specified user". I am using version 6.0.206 on a PC - perhaps the newer versions have different preferences than what I see.

 

My network setup is a workgroup, with each computer having access to all disks. We've made some adjustments to the setup but Retrospect still can't locate the file/directory on the other computer. Any futher suggestions are welcome.

Link to comment
Share on other sites

Sorry, you didn't mention which version you were using so I assumed the latest.

 

With older Retros, the option I mentioned didn't exist. With those you need to assigned the specific user (e.g. you, with network privileges based on the account you log into the machine with) to the Retrospect Launcher Service (Windows Control Panel or Start Menu, Administrative Tools -> Services) so that the Log On is "This account" (user ID & password) rather than the default LocalSystem account. The service then needs to be restarted.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...