Jump to content

error -625 (not enough memory)


tbell83

Recommended Posts

I searched the forums but didnt really find anything that was helpful.

 

Im running Retrospect Multi Server 6.5.350 on a Dell Poweredge 6650 1.4GHz Xeon Server with 3.5GB of RAM. Its attached to a Quantum Superloader SDLT tape drive. This machine is backing up multiple servers, including a fileserver, SQL server, and an Exchange server. Both the Exchange and SQL Addins are installed in Retrospect. The backups of all servers runs smoothly until the script reaches the C: drive on the Exchange server, which is the last volume to be backed up. The backup runs fine on the filservers, the SQL databases and the First Storage Group on the Exchange server, but when Retrospect gets to the C: drive on Exchange, it starts counting up the files and preparing for backup, but it never really gets anywhere. Eventually it will come back and give me a -625 out of memory error. It happens regardless of whether C: on Exchange is the first Volume in the script or the last. The client on Exchange is 6.5.136. There are approx. 2.7 million files on C: on Exchange.

Link to comment
Share on other sites

  • 1 month later...

It's a limitation of the software. Suggested workarounds are to break up the data into smaller backup "sources" (in your case, C:\exchange) so that there are less files per source. This is a HUGE pain if your source volume is your users share or similar (which would require that each user's folder be a seperate backup source.) That's the best solution to date, and should work, but might not be feasible in the real world.

 

Another thing I am trying is to lower the execution units. This is under Configure\Preferences\Execution\General

 

Theory here is that if you are running less than 4 executions (the defauilt setting) it is supposed to change how Retrospect allocates and reserves memory, which hopefully will free up more memory for your backup source.

 

I imagine any source over 1.5 million files will not get backed up, as that is the limit they reference in the KB. Heck, mine is unreliable with 900K files in one source, but it does back it up "most" of the time.

Link to comment
Share on other sites

Hi

 

This is indeed caused by the number of files and folders on the disk. Retrospect has to list them all up in memory and does currently not swap out the list when it gets too big.

 

As other users have pointed out you can get around the problem by defining seperate subvolumes as backup sources. This minimizes the total number of files that get scanned at one time.

 

If you have a lot of old data you might want to try zipping it up to lower the overall number of files on disk.

 

Thanks

Nate

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...