Jump to content

Can't back up by FTP (Error 225)


Recommended Posts

I can't seem to get Retrospect 5.0 (5.0.203) to back up to an FTP server. No matter what I do, I get Error 225 (FTP: no write privileges, bad name, or disk full). The help/knowledgebase for this error is not helpful and simply re-iterates the three possibilities, none of which are true.

 

 

 

1. I know the FTP user has write privileges, since it logs in successfully and creates a directory with the name of the backup set in the right place. It then creates a "0-Data" file in that directory, but then it quits. I have tried a test account, and even my own personal account on the FTP server. All directories in the path to the backup directory are accessible.

 

 

 

2. I don't know what is meant by "bad name", but I have tried all sorts of names, all of them simple filenames without spaces or special characters, e.g., "test", "backup", "mac-backup".

 

 

 

3. The disk is manifestly not full. I've tried it on various disks with ~ 26 GB free on the file system.

 

 

 

I have tried this on both a Linux (RedHat 6.2) and BSD (BSDI 2.0) server, both with normal FTP servers which have always worked fine. I can use an FTP client to transfer files to and from each by hand.

 

 

 

The Mac and the FTP server are on the same LAN, no firewall or filters.

 

 

 

Any ideas????

Link to comment
Share on other sites

I can't seem to get Retrospect 5.0 (5.0.203) to back up to an FTP server. No matter what I do, I get Error 225

 

 

 

Try visiting your Network preference pane and de-selecting all active ports except the one you're currently using for your TCP/IP connection. Retrospect seems to be unable to handle Mac OS X's built-in multi-homing capabilities.

 

 

 

 

 

Dave

Link to comment
Share on other sites

Thanks. That does seem to be the answer. I got an email from someone on the retro mailing list while the Support Forum was down, and gave it a try, and am able to do FTP backups now.

 

 

 

I hope this bug is fixed, because people (with laptops especially) often switch network ports on the fly. Until last month, I commuted daily between home (Ethernet) and office (Airport). Now I am working at home, and just have the Ethernet, but I liked having all the ports active.

 

 

 

In the meantime I hope this gets into the Knowledge Base, since the existing answers were not useful.

Link to comment
Share on other sites

people (with laptops especially) often switch network ports on the fly.

 

 

 

I've defined Location settings on my PowerBook. When I know I want to do ftp via Retrospect I just use the Apple menu (one of the few things it's good for) and select an appropriate location (that has been configured with a single port). Easy as pie...

 

 

 

 

 

Dave

Link to comment
Share on other sites

  • 11 months later...
  • 2 weeks later...
  • 3 years later...

Hello

 

I see this is a very old thread, but I am having the same issue. I just downloaded Retrospect today and have spent the last few hours trying to get it to work, with no luck.

 

Even though I find it absolutely ridiculous, I turned off all other network connections except for Ethernet. I also made sure FTP is checked in Services and Firewall in Sharing. I am still getting the same error.

 

"Device trouble: “Backup Set A”, error 225 (FTP: no write privileges, bad name, or disk full)."

 

I know the permissions are set to 777. I know I have the correct login, password and location, since there is now a folder called "Backup Set A" with a document called "0-data" inside.

 

I really need to get this working, since the only reason I purchased Retrospect is for the backup to FTP feature.

 

Back to turning off all other network connections, what is this about? I purchase a program, such as retrospect, to automate my tasks and make life easier. Now I have to remember to switch my network settings every evening or it won't backup? Seems a bit backwards to me.

 

Thank you in advance you for your assistance.

Cooch

Link to comment
Share on other sites

Amy wrote (in 2005):

 

"Make sure FTP Access is checked on both the Services tab and the Firewall tab"

 

Bah. There is no reason to enable the Mac OS X ftp server (Services) in order for Retrospect to access an external FTP server.

 

But you _do_ have to enable Passive FTP Mode (PASV) in the Proxies tab of the Network interface you're using.

 

Dave

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...