Jump to content

VssWEnumWriterMetadata: GatherWriterMetadata failed, winerr -2147024809, error -1001

Recommended Posts

Hello everyone,


I'm receiving the following error:


MapError: unknown Windows error -2,147,024,809

VssWEnumWriterMetadata: GatherWriterMetadata failed, winerr -2147024809, error -1001


Has anyone encountered this error?




I was running Retrospect MultiServer 6.0 on a WinNT Server 4 SP6a. My project decided to upgrade WinNT Server to Windows Server 2003......now I've been receiving these type of errors when my backup scripts were running at night.


My Action:

I copied and saved my original config60* files under /Prog Files/Dantz/Retrospect and then I uninstalled Retrospect.


I then reinstalled Retrospect; rebooted; copied back the original config60* files; and then I ran a quick backup test and I'm still receiving the same error.



Thank you for any insight!



Link to comment
Share on other sites

I have also been getting the same error in the Operations log ever since updating to Windows Server 2003. It occurs on either Retrospect Single Server 6.0 or MultiServer 6.5. Searching Microsoft I found that that error may be the following (which makes me suspect the Retrospect error should be MAPIError):

MAPI_E_INVALID_PARAMETER 80070057 -2147024809.

I am running Exchange 2003 on the system with MultiServer, but not the Single Server. We haven't purchased the Exchange add on for Retrospect.


I *think* the backups are all completing successfully.


The error in the log appears twice for every drive that gets backed up, once at the start and again just before the snapshot stored entry. On drives that have no modified files (hence have 0 files in need of backup), the error appears only once.


The Vss part of the error message had me again searching the MS Knoledge Base and I came across a few Volume Shadow Service hotfix articles (826936, 833167, 828481, 826751) all of which have been applied, but the errors still appear. {From looking for VSS KB articles, it appears that VSS, like several other components of Windows Server 2003, has some memory leaks... "Quality is job 1.1!"}



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...