Jump to content

Urgent: Restore Boot Drive


Recommended Posts

I hope someone can help with this!

 

I'm running OSX 10.2.8 on a TiBook, and my internal 48 GB drive failed. No problem, I have a backup set on an external Firewire drive. And I had to restore a failed boot drive a couple years ago, and it went very smoothly.

 

I'm using Retrospect Workgroup 5.0.238.

 

Okay, so Apple replaced my drive with an 80 GB drive (!) and installed 10.2.6. Following the "restore after a disaster" instructions, I updated to 10.2.8 then installed Retrospect on the internal hard drive. (I'm not sure I rebooted in there anywhere.)

 

I had ~35 GB to restore, and it took ~5 hours. Retrospect said it finished without errors. I quit Retrospect, and saw nothing strange.

 

Here's where it gets strange.

 

I restarted the Mac, and saw the gray screen with the apple logo in the center and the spinning thing near the bottom of the screen. After a few seconds of this, I got a "prompt" at the top left side of the screen!

 

The prompt says "sh-2.05a#".

 

I tried booting into single user mode (holding down CMD S at boot time) and I receive the same prompt once it comes up. I'm not familiar with messages in single user mode, but I don't see anything alarming.

 

I suppose the reason the Mac drops into single user mode during a "normal" boot is that there is something seriously wrong with the file system.

 

Has anyone here seen this symptom?

 

Any clues about how to recover?

 

Since it takes so long to "restore", I really hope I can fix things without having to re-run the restore. But in any case, I need to get this TiBook running as soon as possible.

 

Your help is most appreciated!

 

Enjoy!

 

-- Jim

 

 

 

 

Link to comment
Share on other sites

I thought I might have issues with the OS 10.2 installs, so I decided to try again.

 

I was very careful this time, but Retrospect still failed to properly restore my startup drive. When I boot, it automatically drops into "single user mode", and I get a prompt.

 

I installed 10.2.6 (?), then restarted and ran Disk Utility to set file permissions. Then I restarted into single user mode and ran fsck.

 

Then I installed 10.2.8 using the Combo updater. Again I restarted, ran Disk Utility to repair file permissions, and restarted into single user mode to run fsck.

 

Next I installed Retrospect 5.0.238. Once again I ran Disk Utility to repair file permissions.

 

Then I told Retrospect to "restore entire disk". Again, it took over 4 hours and completed with no errors or warnings:

 

+ Executing Restore from Backup at 1/23/2004 10:28 PM

To volume Macintosh HD…

 

- 1/23/2004 10:28:26 PM: Restoring from Backup Set A1…

1/24/2004 3:00:54 AM: Execution completed successfully.

Completed: 144499 files, 33.0 GB

Performance: 0.1 MB/minute

Duration: 04:32:28 (07:02:33 idle/loading/preparing)

 

I took a couple screen shots and copied & pasted the retrospect log into a file using TextEdit. I saved all three files to my external Firewire drive, just in case.

 

I noted one strange thing. After I saved the file from TextEdit to my FireWire drive, and quit TextEdit, I seem to have "lost" all my fonts. For instance, all my menus were "blank". I couldn't get the TiBook to restart, so I ended up holding down the power button.

 

I may have mentioned that Dantz doesn't want to discuss this unless I pay $70. They *did* suggest that I try downloading the trial version of Retrospect 5.1 and see if that helps. Unfortunately, the buttons for downloading 5.1 don't seem to work.

 

Now, I've been a Dantz customer for years and years - probably since Retrospect 1.0. I have bought many Dantz products, and currently own the "Workgroup" version. I'd like to think I've been a good customer and an advocate of Retrospect on various message boards. I guess that's part of my disappointment here.

 

Anyway, I'd certainly like to discover and correct "the problem" using single user mode, so I don't have to go through the many hour exercise that I described above.

 

If anyone has suggestions, I'm all ears!

 

Enjoy!

 

-- Jim

 

Link to comment
Share on other sites

Quote:

If anyone has suggestions, I'm all ears!

 


 

Jim,

 

The first thing that jumps out in your post is the part of the log that says:

 

Performance: 0.1 MB/minute

 

This is why it took so long, and is _way_ below what a Restore from a FW drive should be.

 

But you've tried this twice already, with similar results, so I won't suggest trying the same thing again. Instead, your best course of action would be to boot from a different OS X source and to run Retrospect from there.

 

One option might be to install OS X (any stable version) on the external FW drive. Then boot from that drive, and with Retrospect running on that drive, perform your Restore.

 

Another option would be to use some other OS X computer, and start your TiBook in Target Disk Mode. This will allow you to access its hard drive on the desktop of the host computer.

 

Lastly, you could purchase the Retrospect 5.1 update and use the included boot CD.

 

Once you're booted, the eventual goal would be to completely wipe the new TiBook drive, and do the restore. This way Retrospect won't be taking time to match files that already exist, and there will be less chance that something goes wrong with the "Live Restore" process (which puts items in a temporary location during the Restore, which is the only way you can be booted from a volume that is having system data written to it in real-time).

 

Beforehand you wipe the new TiBook drive, however, you should run some test Restores to guage the performance; choose a directory from your Backup Set with lots of small files, such as /System/, and Restore it to a defined subvolume you create on the TiBook. You should see performance closer to 100 MB/Min (internal 2.5 disks are not all that fast). If it behaves well, wipe the drive using Disk Utility and Restore Entire Disk.

 

I've done this lots of times; it should work as advertised.

 

Dave

Link to comment
Share on other sites

Dave,

Great reply, thank you!

 

Yes, I noticed the strange "performance" numbers too. And it happened both times. Yet, when I watched the restore, I was seeing performance ~100 MB/sec as you suggested. Go figure. I do have a bunch of large TIFF files in the backup set, so perhaps they're skewing the numbers.

 

I just finished trying something suggested in a different forum. I did an Archive & Install (and discovered it's 10.2.3, not 10.2.6) and it seemed to work after a fashion. It seemed to retain my applications and my data, yet Entourage lost track of my identity, and many (not all) of my Dock icons and settings were lost.

 

In any case, I think next I'll follow your advice, with a twist. I'll install OS X to a separate partition on the TiBook's internal drive, and then "restore entire disk" to a "clean" partition. Does that make sense? It might be a bit slower than booting from an external FW drive, but Probably not dramatically slower.

 

As soon as Retrospect 6 is shipping, I'll probably purchase the upgrade.

 

Thanks!

 

-- Jim

 

Link to comment
Share on other sites

Once again, this isn't going well.

 

I was able to partition the internal 80 GB drive into a big and a small partition. Then I installed 10.2.3 on the small partition, followed by Retrospect 5.0.whatever.

 

I made sure the big partition was wiped clean, and used Retrospect to "Restore Entire Disk".

 

The restore went fine, and finished after about 4.5 hours with no errors or warnings.

 

I used the Sytem Preferences to select the big partition as the startup device, and rebooted.

 

Unfortunately, I get the same symptom: Shortly after the chime, with the spinning thing in the bottom center part of the screen, it stops spinning and I get a "prompt in the upper left corner of the screen. The prompt says "sh-2.005a#".

 

So, it appears that Retrospect is doing something wrong, either when it backed up my 10.2.8 system to start with, or when it restores it. I was hoping the problem was a glitch of some sort when Retrospect tried to overlay the restored OS "next to" the currently running OS, but apparently this wasn't the problem.

 

The good news is, I can boot on the smaller partition and examine the files and directories on the big partition.

 

Can anyone suggest what might be corrupted here, or how to fix it?

 

I suppose I could once again do an "Archive and Install", but I'd really prefer to make this work without that, since I know from earlier today that my system won't be totally "back to normal" if I do that. I wonder if a different "flavor" of installing 10.2.8 with the Combo Updater would just "refresh" the OS on my big partition, but leave my settings in-place?

 

Best Regards,

 

Jim

Link to comment
Share on other sites

Hi

 

Have you tried restoring from a different snapshot in the backup? How about booting from your second partition and then restoring your earliest snapshot. If that boots properly try the same process again with a newer snapshot. I would _not_ erase the disk in between these restores as it will save a bunch of time and Retrospect should be removing un-needed files on its own anyway.

 

All disks including the original source disk are formatted HFS+ right? (sorry - just have to ask)

 

Thanks

Nate

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...