Jump to content

scripts running when scheduler disallows


TLReed

Recommended Posts

I'm running win 6.5 multi-server and have several scripts that run daily. I've noticed that if I have waiting executions they run regardless of the allowed schedule set up in the script.

 

Just now I had a server backup script finish running during working hours, and two other scripts waiting to be run that were delayed from the night before. Both the waiting scripts have an allowed run schedule set to allow launch at 8 PM and stop at 8 AM, but they go ahead and run anyway during the day. How can I stop this behavior?

 

I see the schedule in the preferences is set up for 24 hours, but I thought the schedule in the script should supersede the preferences allowed run schedule.

 

 

Link to comment
Share on other sites

Hi,

 

When a script is waiting for a resource (source or backup device) it will execute as soon as the resource is available. This happens Regardless of the actual script start time.

 

You may have to set a global time limit on Retrospet to get the executions to stop. Are you using proactive backup or standard scripts?

 

Thanks

Nate

Link to comment
Share on other sites

Quote:

natew said:

Hi,

 

When a script is waiting for a resource (source or backup device) it will execute as soon as the resource is available. This happens Regardless of the actual script start time.

 

You may have to set a global time limit on Retrospet to get the executions to stop. Are you using proactive backup or standard scripts?

 

Thanks

Nate

 


 

I'm proactive backup or one script and it runs 24/7 when standard scripts are not running.

 

The problem I am referring to occurs with standard scripts that have a schedule for allowed operation set up in the script preferences. If the script is going to run anyway, what's the point of having the allowed schedule preference in the script?

 

If I set up a global allowed run-time, will that disallow the proactivebackup script running?

 

TIA.

 

Todd

Link to comment
Share on other sites

Hi

 

So just to make clear, you have specified the start time of your script using the schedule option and the allowed run time using the schedule option in your script preferences right? You have done this for every script?

 

Can you post the exact settings you have in there? Have you specified an execution unit in any of your scripts?

 

You are correct that a global schedule will shut off the backup server as well.

Thanks

Nate

Link to comment
Share on other sites

Quote:

natew said:

Hi

 

So just to make clear, you have specified the start time of your script using the schedule option and the allowed run time using the schedule option in your script preferences right? You have done this for every script?

 

Can you post the exact settings you have in there? Have you specified an execution unit in any of your scripts?

 

You are correct that a global schedule will shut off the backup server as well.

Thanks

Nate

 


 

Yes. I have a scheduler in my script preferences that specifies operation Mon-Fri starting at 8 PM, and ending at 8 AM, weekends 24 hours. The script start time is at 10 PM.

 

I have not specified an execution unit in any of my scripts, just using the default. Not sure how to do so in any event.

Link to comment
Share on other sites

Hi

 

I am going to try to test this.

 

In the meantime go to your Retrospect preferences and set the number of execution units to 1.

 

Also set the Wrap up time in your scripts to be 1 hour or less - the Wrap up time is the time that the script is allowed to exceed it's scheduled quit time

 

Thanks

Nate

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...