Jump to content

Spaces in user name for "Always run Retrospect as the specified user"


awnews

Recommended Posts

I was just helping a friend out with a Retrospect Pro 6.5 problem (I had bought it for him as a thank-you gift and after I found out that he wasn't backing up his stuff, so I'm obligated to provide some level of tech support...). The PC is running XP SP1 and is in a Workgroup.

 

We were trying to set up the Preferences-->Security-->Always run Retrospect as the specified user (so RP would access his work server even when logged off) but kept getting errors (no such login, info invalid, etc. paraphrased). The login info was:

 

User: Tom Smith

Password: *******

Log on to: tspc (note: name of Workgroup PC)

 

By trial and error and using some alternate login accounts, we eventually figured out that the problem was the space in the name. Even though "Tom Smith" is a valid login name for Windows, Retrospect wouldn't accept it in this dialog. After we were able to enter info with another dummy account, we then changed the main login to (e.g.) "tomsmith" and entered the new account info here and then Retrospect was happy.

 

Although spaces in names may not be a good idea and may cause problems in some environments, I believe that they *are* legal in a Windows environment. Retrospect should accept valid login names *or* (big or!) document that it won't accept spaces in login names and provide a better error message ("even though this is a legal login ID for Windows, we won't accept it because it has spaces and we don't feel like it..."). As a matter of fact, the whole "Always run Retrospect as the specified user" area could use some better documentation (examples, domain vs. workgroup usage, etc.) and error messages. One suggestion--instead or requiring that users always type in this info, how about providing an (optional) "Select..." button to allow users to select from accounts already on the PC and filling in the info for them.

Link to comment
Share on other sites

Hi

 

You have a point (actually a few points)

 

Ideally Dantz reccomends creating a "retrospect" user account which would get around the space in the user name issue. Most users will use that account or the Administrator account which is probably why this hasn't come up til now. You are right though - it should be better documented.

 

Nate

 

Link to comment
Share on other sites

One big problem with the using a "dummy" admin-level account for Retrospect (e.g. "Retrospect" or "Administrator") is that it won't give Retrospect any network privileges. It would work fine for running on the local machine but would fail as soon as the user tried to access a network resource such as a file server (which is what my friend is doing at his backup destination) which requires a login ID (workgroup name/password or domain).

 

I doubt if I can convince the IT guy to give out "spare" accounts for backups (rouge logins). And even if I could, it would mean that the saved backup would be in a separate directory (login per user ID) not accessible to my friend's normal user ID.

 

Link to comment
Share on other sites

The problem we were having with using the "currently logged user" option is that my friend frequently logs into the PC remotely using the XP Remote Desktop. This logs out the current user (which would have probably allowed RP to run otherwise) when he logs in and then leaves *no* user logged in after he quits out of Remote Desktop. So RP would try to launch with no login (local or network) privileges and fail. Setting up a specific user seemed like the best way around this, and it is working as of last night.

 

One other option is to look into the new XP option:

 

Manage my network passwords

 

available on a per-user basis. It might/should be possible to set things up so that a given user/account (e.g. "Retrospect") would give a pre-set up login/password on a per server/domain/workgroup basis, allowing network access even though the actual username isn't recognized by the network resources.

 

Link to comment
Share on other sites

Hi

 

You may be aware of this already but just in case...

 

When retrosepct lauches as "logged on user" and no one is logged on it lauches as the "local system account" on the local machine. Windows does not allow this account to access network resources no matter what. i.e. it can't use another valid username and password to login to a network share.

 

However the local administrator account is allowed to log into any network share using any valid user name and password. All you need to do is set retrospect to run as the local administrator of your friends machine. Then configure the automatic logon setting in the configure volumes menu in Retrospect.

 

Let me know if there is something else that prevents this from working in your setup

 

Thanks

Nate

 

Link to comment
Share on other sites

Change this permission under Config->Volumes->LogIn As... options. Change that permission under XP Users & Groups. Change another one under the Retrospect Security tab and another under the NT Services area. I'm sure you'll be having fun in tech support...

 

In this case I think the "KISS" method works better. After changing the user name to remove spaces (something Dantz should fix in a future version), the system is able to log into the PC and network without any errors. One advantage to doing this is that Retrospect will run with the *same* permissions as the user--if the user can do it, so can Retrospect. Permissions don't have to be changed all over the place (note: RP could help with a unified way to view and change permissions for users, volumes, etc.) and we're less likely to have "but it works when I run it manually instead of letting RP autolaunch!!"

 

Thanks for the suggestions but I think things are OK for now.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...