Jump to content

RP Dup failures and other strange error messages


awnews

Recommended Posts

Running Retrospect Pro 6.5 RDU 4.4.110 under XP SP1.

 

I'm trying (and failing) to run Duplicate operations from a local harddrive on an XP SP1 PC to a remote Linux machine via Samba and over a T1. The log below is from last night's attempt, where I run ran a local backup. Note that I've made minor hand-edits to the log for privacy reasons. I manually stopped each of the duplicate attempts after 9:30AM, which took *forever* do to incredibly sluggish response from RP (see other post regarding slow RP behavior when editing "remote" Dup scripts).

 

A few things to note:

 

0) The first Normal backup (local HD to local HD, using a normal backup) ran fine.

 

1) What in the world is going on with the:

 

menuLReset: GetMenuItemCount failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

 

sequence? This started with the 2:25 AM duplicate attempt (note that this was a local duplicate, from local PC drive to another local PC drive on the same XP PC) and ran with this error message until I stopped it about 9:30AM.

 

2) When the next job started at 9:30AM (should have started after the 2:25AM job but that "ran" all night,so I had to manually TM quit RP and then relaunch it), I got the:

 

"VssWAddVolToSnapshot: AddToSnapshotSet failed for volume \\?\Volume{28e1fcae-918f-11d7-9467-806d6172696f}\, winerr -2147212521, error -3043" message.

and

"Can't use Open File Backup option for Designs on Drive V (V:), error -3043 (the maximum number of Snapshots has been reached)"

 

What is Retrospect talking about? This is a *Duplicate* from a local harddrive to the remote Linux/Samba/via T1 server, and there *isn't* a "Snapshot" for this operation. And I don't know why there are "too many" Snapshots since there shouldn't be *any* snapshots for a Duplicate.

 

==== RP 6.5 log

 

+ Retrospect version 6.5.319

Automatically launched at 9/23/2003 2:15 AM in user account MYPC\bigadmin

+ Retrospect Driver Update, version 4.4.110

+ Normal backup using V_Data_Short at 9/23/2003 2:15 AM

To Backup Set V_Data_Short...

 

- 9/23/2003 2:15:05 AM: Copying Docs on Drive V (V:)

9/23/2003 2:24:26 AM: Snapshot stored, 48.9 MB

9/23/2003 2:24:29 AM: Comparing Docs on Drive V (V:)

9/23/2003 2:25:26 AM: Execution completed successfully

Completed: 1422 files, 386.2 MB, with 3% compression

Performance: 406.4 MB/minute (406.4 copy, 413.6 compare)

Duration: 00:10:20 (00:08:26 idle/loading/preparing)

 

 

+ Duplicate using Libs_Monday at 9/23/2003 2:25 AM

To volume Monday on Drive W (W:)...

 

- 9/23/2003 2:25:28 AM: Copying Libs on Drive V (V:)

9/23/2003 2:28:45 AM: Comparing Monday on Drive W (W:)

9/23/2003 2:28:53 AM: Execution completed successfully

Completed: 710 files, 26.6 MB

Performance: 35.8 MB/minute (19.6 copy, 227.6 compare)

Duration: 00:03:24 (00:01:55 idle/loading/preparing)

menuLReset: GetMenuItemCount failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuLReset: GetMenuItemCount failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

..... a ton more deleted .....

 

..... I had to force quit RP since it wouldn't give me back control. And then I manually relaunched it ....

+ Retrospect version 6.5.319

Launched at 9/23/2003 9:30 AM in user account MYPC\bigadmin

+ Retrospect Driver Update, version 4.4.110

 

+ Duplicate using Designs at 9/23/2003 9:30 AM

VssWAddVolToSnapshot: AddToSnapshotSet failed for volume \\?\Volume{28e1fcae-918f-11d7-9467-806d6172696f}\, winerr -2147212521, error -3043

Can't use Open File Backup option for Designs on Drive V (V:), error -3043 (the maximum number of Snapshots has been reached)

To volume Designs on project on linuxbox.remote.com...

 

- 9/23/2003 9:30:27 AM: Copying Designs on Drive V (V:)

9/23/2003 9:30:46 AM: Execution stopped by operator

 

+ Duplicate using Designs at 9/23/2003 9:30 AM

9/23/2003 9:31:04 AM: Execution stopped by operator

 

+ Duplicate using Taxi at 9/23/2003 9:31 AM

VssWAddVolToSnapshot: AddToSnapshotSet failed for volume \\?\Volume{28e1fcae-918f-11d7-9467-806d6172696f}\, winerr -2147212521, error -3043

Can't use Open File Backup option for Taxi on Drive V (V:), error -3043 (the maximum number of Snapshots has been reached)

9/23/2003 9:31:17 AM: Execution stopped by operator

 

+ Duplicate using Taxi at 9/23/2003 9:31 AM

To volume Taxi on Drive V (V:)...

 

- 9/23/2003 9:31:17 AM: Copying Taxi on project on linuxbox.remote.com

9/23/2003 9:32:24 AM: Execution stopped by operator

 

Link to comment
Share on other sites

Hi

 

This is indeed odd. It may be a red herring but make sure you turn off the open file option in your script. I'm guessing that the too many snapshots has something to do with the way Retrospect is seeing the size of the samba volume. i.e. it mistakenly thinks it is too big or something.

 

What version of Samba is this?

 

I know this is basic but you may want to try using new configuration files since all of your duplicates are acting funny. Is file system corruption on the source side a possibility. Basic again but try running a scan disk just in case.

 

Nate

Link to comment
Share on other sites

Guest psykoyiko

Quote:

GoAWest said:

menuLReset: GetMenuItemCount failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuLReset: GetMenuItemCount failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

menuEnableOSItem: EnableMenuItem failed: 1401.

menuLAdd: UInsertMenu failed: 1401.

..... a ton more deleted .....

 

 


 

Do you have debug logging turned on?

Link to comment
Share on other sites

I don't know what version of Samba is on the far end but I'll find out.

 

I do have Open File Backup (default included option for XP, not the Add-On) turned on on my (XP SP1) end. Of course this is a Dup and also should only be relevant on the XP end, not the far-end Linux/Samba box.

 

I don't have an "special" (i.e. I didn't enable/disable/change anything in this area) debug logging turned on. A check of CTRL-ALT-PP shows it's set to the default level "3" for all items.

Link to comment
Share on other sites

Hi

 

For debugging purposes give it a try with the Open file option off. The open file option will not run on network file shares so we know it is not trying to run on the samba server. More than anything I want to see what error it gives with open file turned off.

 

Nate

Link to comment
Share on other sites

The far end server is running redhat 9 kernel 2.4.20-8smp, samba 2.2.7a.

 

I will turn off Open File backup and give it a try, but wonder why it would lead to the error messages I reported. I run Backups (rather than Dups) from the same XP SP1 box (and drive and files) with OFB turned on and don't get any errors. And I run Dups from that same box (and drive and files) to another drive in the same box, again with OFB turned on. So this problem was only coming up when I was trying to run Dups to the remote Samba box. I'm not backing up any files on a network share and OFB is *only* being used for files on the local (XP NTFS) harddrive.

Link to comment
Share on other sites

I'm duping nightly between two drives on the same Windows XP box now and it's working fine. So I'm pretty sure this is a RP --> Samba/Linux issue, and your suggestion about APIs is correct. In a previous post, I had mentioned that I got a bunch of error messages regarding "short file names" when trying this this same dup (XP->Samba/Linux)--obviously the "short files names" on Windows are meaningless under Linux. So it seems that RP6.5 is (too) PC-centric at times.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...