Jump to content

Removable Disk Backup Problems (incorrect can't find catalog error)


Recommended Posts

My scenario:

 

Retro 5.038 server.

 

5 Firewire Drives (extended format) each week, I backup to a different drive (the first week, I backup to Drive 1, the second week to Drive 2 and so on...)

 

 

 

My problems occurs when I try to rotate one of the drives off site.

 

 

 

When I unplug the first drive ("Week 1"), the Week 2 backup fails to start because Retrospect gives me an error saying it can't find the Week 1 catalog.

 

 

 

The Week 1 catalog *is* gone because its on Drive 1. ....BUT Retro should NOT be looking for Week 1 Catalog!!!!

 

 

 

If I leave Drive 1 plugged in, then everything goes off without a hitch and the data does get backed up to Drive 2 (so no, I don't have any simple schedule or target errors)... Also, I've tried rebooting, ejecting drives, etc...

 

 

 

Is anyone doing a Firewire drive backup that includes rotating one of the drives offsite? How are you setting this up & have you experienced similar problems.

 

 

 

Is there a way to separate the backup data from the .cat file? Is there a way to make retrospect stop looking for the 1st drive's .cat file (or ignore the error & continue on)?

 

 

 

Further Info:

 

From what I've, the backup data and catalog (the .cat file) must be in the same location. I've actually tried to move the catalog file to the main Retro directory but it then gives me another error about how it can't backup that much data (I think its getting confused and thinking there isn't enough room on the internal boot drive (there isn't) instead of looking to the Firewire drive capacity)...

 

 

 

Any info/help would be *greatly* appreciated...

 

 

 

THANKS!

 

Eric

 

 

Link to comment
Share on other sites

hmmm... a reasonably good point.

 

In fact, now that I've thought about it, I've just got a single script doing everything & one of the script properties is the 5 catalogs. I forgot that when you do a tape backup its different ...catalogs are supposed to stay on the drive (unlike removable drives). So the single script looks to make sure all its properties are there and errors out.

 

Now... I've just made 5 scripts with each script responsible for one week and one drive. Now week 3 works fine when Drives 1 and 2 are gone because Script 3 is only concerned with finding Drive 3 and Catalog 3...

 

Thanks for jogging my brain.

-Eric

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...