Jump to content

Retrospect Desktop just quits

Recommended Posts

Now that I have upgraded to the release version of Retrospect 5.0 for Mac OS X, the problem that I had with the preview version has persisted. After scanning the volume, updating privileges, icons, etc. and just as it seems about to start the backup, Retrospect crashes. This is true regardless of the backup device (I've tried two CD-RW drives and a firewire hard drive). I uninstalled the preview with the utility provided and started with a new backup set/file. This is not a crash that generates a message from the OS. It is very quiet. I've turned on the console's error logging and the crash is logged but, I don't find anything of use to me in the logs. Very disappointing especially since Dantz won't provide tech support without paying almost as much for the single-incident support as the cost of upgrade...




Has anyone experienced this problem and solved it?

Link to comment
Share on other sites

No solution, but you're not alone. I also got a "quiet" crash, but for me it happened during Verification. Not a bad time for it to do so, but still, you don't really want your backup software to crash ever. I've got no crash log in /Library/Preferences/Retrospect, and the Retrospect log has no notice of it. I've got the Console logging Crashes, and there's no Retrospect log, but LaunchCFMApp.crash.log has an event at about the right time (I was away from the computer when it happened).




Is there anyway to contact Dantz about this w/o shelling out bucks, or is this it? I'm not looking for an immediate solution - I'm still considering this (and OS X) a beta - but I assume my Console log may have some useful information. I'm unwilling to pay money to help Dantz troubleshoot its software (well, more than the amount I paid to buy it).




Evan Evanson


B&W G3/400 (rev 2) w/ XLR8 G4/500 upgrade


OS X 10.1.2


Retrospect 5.0


Que PCI Firewire card


Yamaha 2200EZ CD-RW mechanism, Oxford 911 FW converter

Link to comment
Share on other sites





That is exactly what is happening to me. "there's no Retrospect log, but LaunchCFMApp.crash.log has an event at about the right time" - same here. Not much to go on. It was suggested that I try trashing prefs and starting with a very small backup, like a folder with a few document. I will try that and see if the results are different. I was trying a complete backup of a fairly large, complete hard drive. I've also tried different devices and had the same problem with all of them. I'm trying to back-up a stock TiPB G4 to an external firewire cd-rw or hard drive.




Dantz is very good about refunding your money if you can't get satisfaction. Since I have about 55 days more to see what happens, I think I will wait a while before giving up. I've been using Retrospect for many years and generally have been very satisfied with the company. I think they went through a lot to get Retrospect 5.0 for OS X out the door even if it still has rough spots (but OS X has lots of rough spots, too).




Good luck...

Link to comment
Share on other sites

To follow up on an earlier suggestion, I was able to backup subvolumes. I selected my Documents directory and was able to complete an immediate backup. Now I'm backing my hard drive up a major directory at a time. Maybe there is something in one directory that was causing the problem.

Link to comment
Share on other sites

In reply to:

Have you tried it on your machine without the third party CPU upgrade? Just a stretch, but perhaps the software isn't compatable with this non-Apple hardware?

Boy, I hope that's not it, but just to be sure I'm now running Retrospect w/ the original G3 in place*. So far it's been up for 20 minutes, and has succeeded in scanning my X boot drive w/o crashing - I'm regret to say that we may have found the problem (at least in my case - doesn't explains hfalls's problem).




For the record, I should add that yesterday I found that Retrospect 5.0 works perfectly well for me while running w/ the XLR8 upgrade card under OS 9, so I can at least back up my X drive that way.




In reply to:

Could any of your folder's names be longer than 31 characters? If so, that might cause the quit.

I doubt it, but I'm not sure. There're definitely some .webloc files on my Desktop that're longer than 31 characters, though. Is there a command I can type into the Terminal to locate all directories w/ names longer than 31 characters? I'm not quite as UNIX-savvy as I hope to be eventually.




Evan Evanson


Stock G3/400 (ignore the sig file)


Que PCI FireWire card


Yamaha 2200EZ FW CD-RW




*and I can't think of any more dramatic proof that Mozilla's fine on a G4 and unusably slow on a G3. Sigh...

Link to comment
Share on other sites

Well, that's it. I just completed successfully backing up and verifying my 5.8 G OS X boot disk w/o a hiccup. I would have never gotten past the first 2 or 3 CDs if I had the G4 processor in. The clear verdict is:




As of 4/2/02, Retrospect 5.0 is incompatible with the XLR8 MAChSpeed Zif G4 MPe card (at least that's true of this card in my G3/400).




Feh. Wonder how that warranty is worded.




Evan Evanson

Link to comment
Share on other sites

Double feh. Typed too soon. It looks like it's the Cache Enabler software that's the culprit. Deleted the files, and swapped the G4 card back in - Retrospect ran fine, backed up fine, and in fact I left it on all day w/o a single crash. If anyone else has problems w/ an XLR8-upgraded machine, I recommend removing the files:










/Applications/Utilities/XLR8 MACh Speed Control




That may well do the trick - certainly did for me.




Sorry for commandeering the thread, but I figured I should post my solution for anyone else in the same boat.




Evan Evanson

Link to comment
Share on other sites

I tracked my problems down to one folder with java classes and .jar files in it. I compressed the folder into a .sit archive to preserve the files without exposing Retrospect to the individual files and everything ran fine so the problem is resolved. Retrospect now runs great. It took backing up my volume directory by directory to find it but... I've reported this to Dantz tech support. I think they should be able to make Retrospect more robust when it encounters these problems in the future.




BTW, I also have had problems with XLR8's cache control software (not with Retrospect). I finally had to install the OS 9 version and enable the cache before rebooting into OS X before it worked. There are also a couple of free alternatives that work as well (BUT DON'T install both at the same time) if it Retrospect doesn't like it.

Link to comment
Share on other sites

I had not thought of backing up a volume at a time, I will try that too.




I have narrowed by original clueless LaunchCFMApp crash down to scanning one particular volume, much like one of the other posters. I am now trying the 203 update, but the only difference so far is that I don't get a crash log, I still get the crash.




I have noticed that /Library/Preferences/Retrospect/Retro.Icons (5.0)


gets huge after scanning the bad volume. Scans of five "good" volumes generate a 12 KB file. Scanning one "bad" volume causes the file to grow to over 500 MB, as well as Retrospect crashing. I initially noticed the problems after running out of disk space after multiple crashes, and the file was well over a GB.

Link to comment
Share on other sites

> Poster: NCSUCPE


> Could any of your folder's names be longer than 31 characters?


> If so, that might cause the quit.




Yes indeed. A few subvolume scans to check the whole disk is not the problem, a


find ./ -name "??????????????????????????????*" -print


and one 36 character folder name in my downloads folder


Intellimouse English (US and Canada)




After a rename of that one folder, I can now preview the backup files for that volume without a crash. Since one of the features of Retrospect 5 running on Mac OS X is "Complete long (255 character) filenames", I am a little surprised that folders are not included, I assume that is a bug rather than a feature!

Link to comment
Share on other sites





We've actually been able to pinpoint the problem and are working on a solution.








Retrospect uses information stored in the retro.icons file to match files to their file type based on icon. If Retrospect adds information about an icon from a file with a long name, it corrupts the retro.icons file and the program quits with no further information.










Retrospect quits with no crash log or other indication. The retro.icons file, at /Library/Preferences/Retrospect, grows to a very large size.










Try to narrow down the problem file, and change the name to something shorter. Note that not all long filenames will cause problems.




We are working on a solution to address this problem directly.





Link to comment
Share on other sites

  • 2 weeks later...





It's been two weeks since your last post on this serious error. It looks like a couple of releases have been made since you talked about this in 5.0.203 (5.0.205 is currently shipping). Is there a solution in sight? In all my tests, this failure happens on every OS X Mac (I've tested on seven machines). There are files longer than 32 characters that belong to Apple applications that I don't believe can be moved or deleted. For instance:














Macworld readers are complaining that they can't reach Dantz to get support on this problem without paying for a support incident, and some readers have been told -- after paying for a support incident -- essentailly what you already said in this forum (that the problem is known and a fix is in progress).




If there is a fix for this problem, can you please respond to this thread and explain it? If there isn't, I would think Retrospect would say something in the ReadMe documents, in the knowledgbase, the FAQ, and when OS X users place an order. I can't prove this, but I suspect that Retrospect will not perform a complete backup for anyone under OS X. Long file names are routinely generated by the OS itself.




This is the kind of bug about which Dantz should be completely open with its customers. Retrospect customers have told me they feel cheated after paying for the program and then having no access to get information about this bug. My own searches found only this one thread buried in the user forum.




Can you please respond?




Mel Beckman


Contributing Editor


Macworld Magazine



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...