Jump to content

Ecrix VXA-1 / Adaptec 2930

Recommended Posts

I can't get 5.0 Desktop to work with my Ecrix VXA-1 and Adaptec 2930 (the combo works


fine with 4.3 under MacOS 9.0.4). I have the Adaptec 1.1 driver. Symptom is


that backups hang after some number of GB written (doesn't consistently fail at the same


point) or I get "error 102: trouble communicating". It's also much slower than under OS9.


Suggestions welcomed.



Link to comment
Share on other sites

If your storage device has a wide 68-pin interface, make sure it is connected to a wide 68-pin SCSI adapter. Many issues have been found when wide devices have been connected to a narrow 50-pin or 25-pin SCSI adapter.




This is noted on our device support page, and it may be why some configurations, such as a VXA drive on a 50-pin 2930 card, aren't working.

Link to comment
Share on other sites

What is the best recommended scsi controller for reliable use with a SCSI VXA drive under OSX? I am getting the exact same problem as "miw". Indeed, I have the same 50 to 68 pin dilemma with an Adaptec 2930CU in a dual 1Ghz G4 running 10.1.3. Does anyone have a rock-solid configuration with the SCSI VXA-1? What adapter are you using? Are there any possible software workarounds (for example any settings in the secret prefs)? Thanks for any advice!

Link to comment
Share on other sites

BTW, I've also been pursuing this issue with Adaptec. Here's their reply. I tried


removing all the extraneous drivers as they suggest, but it made no difference.








Confirm that the only driver for the 2930 is as follows.








This file can be found under the System\Library\Extensions folder, and


is version 1.1. If you do not have this file please download it from


the link provided below.










Please note that these drivers will need to be removed from OS9, prior


to installing the new driver these drivers cannot be removed while


under OSX.




Below is a list of drivers that you will find in the System \ Library \


Extensions folder of OSX.














These drivers will all be beta drivers. These should be removed from


the folder. Once removed confirm that the only driver that is installed


for the 2930 under OSX is version 1.1.




Additional items that you may want to check are as follows.




Termination: The tape drive should be terminated if it is the last or


the only device on the SCSI bus.




SCSI ID: The ID of the tape drive should be set to an ID that is free.


In other words no two devices should share the same id. (Quick note,


by default the 2930CU are set at the factory to ID 7 and should not be






Connections: The 2930CU has a 50-pin High-Density connector and will


only accept devices with also have a 50-pin connector or lower. 68-pin


devices are not supported on this adapter. Please confirm that your


tape device is not a 68-pin device. ^8-pin to 50-pin converters are


also not supported. If your device is a 68-pin device then you will


need to change the 2930 for a 29160.




If you have any other questions or require additional assistance please


feel free to write us back or call us at 408-934-7274.




Adaptec Technical Support.

Link to comment
Share on other sites

I have read of numerous instances of incompatibilities with Retro 5 & the 2940U2B, but I myself have not seen them. My setup is :




Mac OS X Server 10.1.3 w/ 768 MB Ram


OEM 2940U2B SCSI Card running 2 (stock) 9.1 GB drives and 1 18 GB SCSI HD, & a VXA-1 tape drive.




Works great for us, but...YMMV





Link to comment
Share on other sites

I was having problems using Retrospect 5 with my VXA-1 and Adaptec 2906 (see my separate post).


Just for the heck of it, I tried running the backup under Mac OS 9, and it worked without a hitch. I suspect that there are some issues with the OS X version of Retrospect or with Adaptec's drivers for OS X.

Link to comment
Share on other sites

  • 2 weeks later...

I swapped out the 2930CU and got a new Adaptec 29160 and 68pin to 68pin cable and all seems well with Ecrix VXA-1 under OS X now! Hurrah!





Link to comment
Share on other sites

  • 4 weeks later...

I have the *exact* same problem. I have gone through all suggestions listed in this thread and they didn't help - I removed old Adaptec drivers and updated the firmware to the latest on the VXA-1. I still get 102 errors. I have only that one device on my SCSI card. Plus I use Granite Digital cable and terminator which show green link lights. It's not a cable problem.




I am running Retrospect Server 5.0.205.




I have a 50-pin SCSI-2 VXA-1 drive that always worked under Mac OS 9 and Retrospect 4.3. Can people please say what computer they are using. I am using a G4/400 AGP Tower.




Based on the number of views, this is a common problem. I hope Dantz (or Adaptec?) will fix this issue.




Anyone who has this combination working (50 pin VXA-1 drive, Retrospect 5, Mac OS X, Adaptec 2930 SCSI card), please let us know. Even if the SCSI card is a different one.

Link to comment
Share on other sites

For the record, my machine is a G4/450 AGP Tower.




My problem is now solved, but no thanks to Dantz.




I first pursued the problem with Adaptec, who tried very hard to locate the cause.


After making sure I had the latest driver installed, they suggested I get


the latest VXA-1 firmware (which I already had) and then mailed me, at no charge,


the latest BIOS EPROM for the 2930 (v4.3), but the problem remained.




During my investigations I discovered that even under my "working" configuration


(MacOS9.0.2/RD4.3) my backups would not verify (I hadn't been running with verification


for a year) - I was getting around 200 verify errors in a 20GB backup. I am still mystified how


this can occur, giving the much-touted read-after-write head arrangement on the VXA-1.


After explaining the problem, Ecrix offered to exchange the drive (thank heavens for 3-year


warranties). Even more fortunate, they had no SCSI VXA-1s in stock, so offered me a


Firewire model.




Since installing that, I have had no problems. Backups run smoothly and verify under


both 9.0.2/4.3 and X/5.0; however they are twice as fast under 9.0.2/4.3, streaming continuously (whereas under X there is a pause every minute or so for about 10s).




I am still no wiser as to the cause of the problems with the SCSI adapter and tape drive.


It is clearly Dantz's responsibility to fix this: they are the only vendor doing certification


of machine/adapter/device/software configurations, and if a particular combination does


not work they should be providing real assistance, instead of asking for money before even responding. I wonder if _anybody_ has this particular configuration working.




The support options are ridiculous. I came within a hair's breadth of returning my software


and getting my money back. I am under no circumstances going to pay for support for


a product which has never worked for me.




If Apple had provided support for SCSI tapes under the BSD personality (i.e., if the


appropriate device entries appeared in /dev) I would have used the UNIX dump/restore


in preference to Retrospect any day. It's too bad Dantz has a monopoly on the Mac backup


market - they seem to be behaving ever more like monopolists, producing poorer products


and inferior support. Wake up Dantz! All it will take is one decent competitor to take


your market.



Link to comment
Share on other sites

  • 1 month later...

Has anyone resolved problems with the Apaptec 2930 and VXA (50 pin connectors)? Is the drive really faulty? Or is there a Adaptec driver or VXA firmware version which fixed things?




I too have been having hardware related error messages using this combination, but not often, perhaps one or two a week. I avoided the problem for a while by using a SCSI-firewire convertor, and had almost trouble free backups until the convertor broke. Forced back to the direct SCSI connection, I immediately had hardware error messages again.




I've just switched to an Adaptec 2906, but got a "trouble communicating" on the very first backup. I have switched to a different VXA drive to see whether the behaviour is any different.




I was using:


Ecrix VXA-1; version 2959; driver Ecrix VXA DC (5.01)


I am now using:


Ecrix VXA-1; version 2848; driver Ecrix VXA DC (5.01)


and I believe there is a newer firmware version which I am about to track down.




Somewhat worryingly I have two Adaptec extensions present:


Adaptec290X-2930.kext (1.1.0)


Adaptec2906-2930.kext (1.0.0)


I'm going to try and get rid of the older one.



Link to comment
Share on other sites

If a 50-pin VXA drive is connected to a supported 50-pin card (with any updates applied) and you are still having problems, go through some devie troubleshooting: swapping the cable, trying it on a new computer, trying a new terminator. In OS X, if the device is LVD you have to have an LVD-SE terminator on it (it's usually printed on the terminator). Some users have tried an HVD terminator which fits the connection but just doesn't work.

Link to comment
Share on other sites

Sorry you are having so much trouble.




I had essentially the same problems. Using OS X 10.1.5 in a PM 7500 upgraded with a G3 400 processor card with an Adaptec 2930 SCSI 50 pin card. This is connected to the VXA-1 drive through its 50 pin connector. I could never seem to finish a backup. Retrospect would freeze at different points in the process requiring a reboot of the system. This did not seem to be as much as a problem with the preview version and of course never a problem with OS 9.




Using the suggestion of a previous here in this same thread, I used Apple System profiler to check my extension set. To make a long story short, I had two versions of the Adaptec driver-1.1 and 1.02. I proceeded to delete the 1.02 driver and rebooted my system.




Viola! I have been backuping away. I have completed a 6 gig backup of my main system as well as a backup of 2 Macs and 2 PC's in my home network without incidence.




I do not know if this is your problem but worth a shot. Good luck!

Link to comment
Share on other sites

edwardmd wrote:


> To make a long story short, I had two versions of the Adaptec driver-1.1 and 1.02.




Since deleting my older driver, I have run backups for four days without an error. I'm waiting for a week of clean backups before I stop holding my breath, but it is looking hopeful.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...