Jump to content

Retrospect Engine crashing during restore


EWTHeckman
 Share

Recommended Posts

Good Morning,

 

I'm attempting to restore a folder from about 2 weeks ago. (~\Library\Application Support\MobileSync\Backup\, that's my iPod backup folder) I have Retrospect doing the restore to a new folder.

 

So far the engine has crashed both times I've tried to do the restore. Here are the details from the console:

 

12/20/10 11:34:06 AM com.roxio.RetroEngine[815] #3> lmSizer: element space full, size = -1595056116

12/20/10 11:34:06 AM com.roxio.RetroEngine[815] #3> lmSizer: element space full, size = -1596104692

12/20/10 11:34:06 AM com.roxio.RetroEngine[815] Assertion failure at "elem.cpp-1913", on threadID 0x38C81000

12/20/10 11:34:07 AM com.apple.launchd[1] (com.roxio.RetroEngine[815]) Exited with exit code: 255

 

12/21/10 9:25:25 AM com.roxio.RetroEngine[86470] #3> devctrlrDevLogin: no login, refnum 0x16ca

12/21/10 9:25:25 AM com.roxio.RetroEngine[86470] #3> devctrlrInstMake: unavailable refnum 0x16ca

12/21/10 9:25:25 AM com.roxio.RetroEngine[86470] Assertion failure at "ex_idevop.cpp-956", on threadID 0xDE01000

12/21/10 9:25:25 AM com.apple.launchd[1] (com.roxio.RetroEngine[86470]) Exited with exit code: 255

 

 

Any suggestions on how to get this restore to work?

Link to comment
Share on other sites

I had a similar problem recently -- I tried to restore a bootable copy of my server to an external drive and Retrospect would crash each time it tried to restore a file within the Apple "Address Book" application package.

 

No idea why. Retro Engineers thought that maybe there was corruption in the initial backup of the file.

 

I was able to work around this by backing up my server to a new media set and then copying past backups from the old media set to the new media set (as "Address Book" hadn't changed) and then I could restore the snapshot from the previous backups. Weird.

 

Anyway...

 

 

Can you restore *anything* from your backups? Or are you crashing only on attempting to restore that one particular folder? What if you attempt to restore just some of the files *within* the folder and not select the enclosing folder for restore?

Link to comment
Share on other sites

Can you restore *anything* from your backups? Or are you crashing only on attempting to restore that one particular folder? What if you attempt to restore just some of the files *within* the folder and not select the enclosing folder for restore?

 

I've done successful restores in the past. In this case, it did eventually work on the third try. It seems that each time it crashed, it was preparing to ask for a particular tape which wasn't in the library. At least each time I tried again, it asked for a tape which it hadn't requested on the previous attempt.

 

BTW, feature request: It would be really nice if the Console displayed the name of the tape being requested in the Activity Summary area instead of making me click the media selection button. (That dialog doesn't handle me swapping tapes in the library very well.)

 

 

Er, that would be

~/Library/Application Support/MobileSync/Backup/

 

Um… yeah… That would be one of the hazards of routinely typing DOS path names. :eyes:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...