Jump to content

Rebuild 6.1 tape set in Retrospect 8.2


Recommended Posts

Dear All,


I am trying to restore data from a Retrospect 6.1 backup using Retrospect 8.


I can't find any documentation for it but the steps I am taking are:


- Go to Media Sets

- Click the Rebuild icon

- Choose Tape, Removable, or Optical, then click next...

- Select the tape (have also tried selecting the tape drive and library)

- Select a folder for the catalog file.

At this step I get the message "An error occurred"


I have tried new folders and have set the permissions for everyone to read write but I cannot get past this window.


I am running Mac OS X Snow Leopard Server with a Sony AIT5 library.


Any advice would be great,


Many thanks,


David Lee


Mac Support London - Independent Consultant/Engineer

Link to comment
Share on other sites

I'm seeing the exact same thing, also on a Sony AIT-5 library. I have a tape in the drive. I tried putting the catalog in both \Library\Application Support\Retrospect\Catalogs\ and ~\Documents\.


The Storage Devices area displays Content unrecognized for every tape created with Retrospect 6.


Here's the message which shows up in the Console messages:


9/24/10 8:04:06 PM Retrospect[75710] BackupSetsController::clickOkForRebuildDeviceCatalogSheet exception: ArcNameUnpack error (name , vol -1)

Link to comment
Share on other sites

I will confirm this works: the tape has to be in the actual drive mechanism, not just in the library. This was killing me as well (8.2 with Scalar i40). This has been stumping me all morning, and I finally came looking here and found this thread.


The error message is exactly as described: just a small red message within the window when trying to select the folder. Nothing is entered in the log (as far as I can tell). If the message a least showed on the earlier page it would be easier to diagnose, since it would indicate a problem with the source. But when it appears on the destination page it leads users to believe there is a problem with the destination (permissions, etc.). It appears the message is coming then because that is the final step before actually running the rebuild.


A better workflow would be to add a wizard (similar to the immediate backup wizard). Allow the user to specify how many tapes are present in the media set, and if using a library, to indicate the tapes that are part of the set.

Link to comment
Share on other sites

I will confirm this works: the tape has to be in the actual drive mechanism, not just in the library.


There may be more than one issue here. I'm well aware of the difference between "in the library" and "in the drive" (where it can be read and written to), and in my case it still failed even when the tape was in the drive.


I wonder if the drive type makes a difference? The original poster has an AIT drive, as do I.

Link to comment
Share on other sites

My past experience with SCSI has led to more aggressive habits than simply turning on the library before launching the engine. I only turn SCSI devices off if the computer they're connected to is off, and I always turn them on before starting the computer. That has been true of how I've handled this library.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...