Jump to content

8.2 Upgrade Waiting for Media


Recommended Posts

I upgraded my engine to 8.2 yesterday and now I can't seem to run any of my backups. Let me fully explain my setup.

I am running the Engine on a Mac Mini Server(Intel Core 2 Duo w/ 4gb ram, 10.6.4) and the backups are actually being stored on a network volume on another server that is mounted by retrospect. The share is AFP. It has been working perfectly for a while but after the upgrade it always says, "waiting for media". When I click the Choose Media button the volume that the backups are located on does show up however if I choose the location of the backup it simply says that it is already a member of the set. I've tried the following(and probably more but this is all I can remember):

-rebooted the server, multiple time

-attempted to create a new media set on the volume, same result

-mounted the volume by hand write to it usign the finder to ensure that there is not a problem with the share, works fine

 

 

If anyone has any ideas I would GREATLY appreciate it. I have been testing retrospect for two months now for our organization and I literally just put in the order to pay for it on Monday and I'm beginning to regret that decision! Thanks in advance!

Link to comment
Share on other sites

backups are actually being stored on a network volume on another server that is mounted by retrospect. The share is AFP. It has been working perfectly for a while but after the upgrade it always says, "waiting for media".

 

The usual cause of this is Mac OS X's temporary renaming of network share points when that share point is mounted more then once.

 

For example, if you restart your Mac, then mount a network share (/Volumes/Foo/) on the Desktop, the actual name of that share (as seen via the "mount" command in Terminal) will be "Foo"

 

If you then use Retrospect to mount that same volume on the Engine host Mac, Retrospect will show it in the Sources list as "Foo" but the actual name (again, as shown in Terminal) will be "1-Foo"

 

While this renaming is not persistent across restarts, once Retrospect is configured to look for "Foo" at the path "/Volumes/1-Foo/" it won't look for it anywhere else, and/or if Retrospect is configured to look for it at "/Volumes/Foo/" but the share has already been mounted by some other process (say, Finder) then Retrospect won't find it there, either.

 

How to check:

First visit Sources->Foo and inspect the "Path" column (Right click on the column header row and add it if necessary).

 

Next, visit Media Sets->YourProblemMediaSet->Members(tab) and inspect the "Location" column (would it have killed them to have named these two columns the same thing?); is the Member on the same path as the Source?

Link to comment
Share on other sites

Thanks for the reply and yes, the sources are the exact same. I actually had that guess myself and check the /Volumes directory and the source is the same as the media set member, both are located at /Volumes/backups.

 

I have also attempted to remove the source and add it back w/ the same result.

Link to comment
Share on other sites

If Retrospect can't find the Member for the Script you can try the Edit Member button (pencil icon) in the Members tab of the Media Sets window, but if that doesn't work you may need to Rebuild the catalog. I found a bug in the beta (that is not listed in the change log) that caused multiple Members to be created by trying to use the Repair and/or Verify buttons, but you could try one of them first to see if it works for you.

Link to comment
Share on other sites

I'm also having the same problems as aethiolas. The only difference is that my share is SMB.

 

With a 'file' type media set, I'm continuously asked for new media, and end up with a series of empty directories on the server:

 

Retrospect
fileset
 1-fileset
  Retrospect
   fileset
    2-fileset
     Retrospect
      fileset
       3-fileset

(hopefully that look like an indented directory tree)

 

If I change the mediaset type to 'disk', backups proceed immediately from 'Preparing to Execute' through 'Creating Snapshot' in a matter of miliseconds. Checking on the server indicates that only 12Mb have been transferred each time, not several Gb - that is, no backup is occurring.

 

I have re-installed everything from scratch, including re-creating mediasets, scripts and sources.

 

Rolling back to Retrospect 8.1 immediate restores functionality.

 

Really hope to find a solution for this, as 8.2 looks like it has some useful interface tweaks.

 

Syros

Link to comment
Share on other sites

Ok so I've been messing around with this for a while and I did manage to fix MY issue though I can't promise it will help for you but it worked on 6 media sets for me so I hope so. Here's the full steps I followed, they may be overkill but it worked so I done it!

 

1. Media Sets->Choose your media set-->Members->Click the Pencil Icon to edit and rechoose your locatino.

2. Click your media set again.

3. Click repair. For me this took like 5 seconds to run at most, even on large backups(500gb+).

4. Once that is finished click verify. Let the verify finish. Obviously this may take a while depending on the size of your backup and speed of your network. Some of mine took multiple days.

5. BACKUP!! WOOOHOOO

 

Once again, I don't know if this will work for you b/c I can't repeat the tests again b/c I'm not about to break it again but now I can backup and restore with my old media sets w/o any issue. Good luck!

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...