Jump to content

"This is already in use by another media set"

Recommended Posts

Hello, I'm using retrospect 8 for macintosh and have been running into an incredibly weird problem.


Every single LTO tape that I'm inserting says "this is already in use by another media set". This happens both when the "needs media" prompts me and I insert a tape, and when I add a tape as a new member (which it allows, renames to what I want, says there is 0 byte written to it and 400gb free space, but gives me the same error).


These are all factory ready tapes, they're completely blank. I've even tried to do a thorough erase of them, and it's made no difference.


Please help!!

Link to comment
Share on other sites

It would help if you provided some information as to the version of Retrospect 8 you have. I suggest updating to the recently-released Retrospect 8.2.0 (399), which has many fewer bugs than earlier versions, if that's not what you are running.


Are the tapes barcoded?


Also, have you tried stopping and restarting the Retrospect engine? Have you tried rebooting the machine on which Retrospect engine is running? Have you tried power cycling the LTO drive?



Link to comment
Share on other sites

Thanks for your reply! Yes, I'm using the updated retrospect 8.2.0 (399), I've tried restarting the engine, rebooting the machine, powercycling the drive. I've even - in the middle of these errors - changed the computer in which retrospect and the LTO drive were running from.


I'm not sure if the tapes are barcoded, if this is something that I'd physically see - no. However, I've been using tapes from the same batch (that came blank from the factory) throughout my entire back-up set, and this is only something that is happening now.


*Tear* Any other ideas?

Link to comment
Share on other sites

Same problem for me too. Running ver 8.2.0 (399) tools and engine with Overland Powerloader AIT3 library on Intel 2.66 Quad core w 8 GB RAM . I am getting the same "Already in use..." popup whenever the loader requests a new tape. Attempted to add tapes to the media set before backing up with the same result. Have found that if I stop the backup and run the script again, it will use the tape but will need to be stopped to access the next one....


Controls for loader have been somewhat deprecated compared to ver 6.

Link to comment
Share on other sites

I have the 'This is already in use by another Media Set' problem as well when I transfer backups from disk to tape. If the script selects backups using 'Copy most recent backups for each source', then it prompts for media whenever it needs to verify the recently written tape, even if the transfer doesn't require a new blank tape to complete. If the script selects backups using 'Copy selected backups', then it prompts for media only when a new tape is required to complete the transfer. If the data fits on the current tape, the transfer completes like it did in prior versions of Retrospect.


The only remedy I have found to clear the activity is to click the Stop button to cancel the verification.


Apple Xserve 2x3 GHz Dual-Core Intel Xeon (OS X Server 10.6.4)

Retrospect 8.2.0 (399)

ATTO Tech Express PCI UL5D LP (Driver 4.4.1 / Firmware April 10, 2009)

Exabyte SCSI 320 PacketLoader 1 x 10 1U (Library Firmware A110 / Drive Firmware 3221)

Link to comment
Share on other sites

  • 2 years later...

Are you switching tapes through Retrospect or through the device itself? I have found that if you load the tape(s) through the device while Retrospect is running it gets confused about what tape(s) are actually in the device. If you do not use Retrospect to eject and load tapes the best thing to do is follow these steps: 1) Quit the Retrospect console, 2) stop the Retrospect engine, 3) eject and load appropriate tape(s) into the device, 4) once all tape(s) are recognized start the Retrospect engine, 5) once the engine is started, start the Retrospect console, 6) go to backup devices and verify that Retrospect recognizes the newly loader tape(s). If it does you should not see the "already in use" message when you try to erase the media.

Link to comment
Share on other sites

  • 2 months later...


  I have the same problem with my LTO (4) that the OP is having.  I am running 8.2 (399) on OSX server 10.5.8 and am trying to backup 20 TB to tape. I was not having an issue until tape 13 and now it says the blanks are all part of another media set. I am only running one media set and one backup script.  My tapes are barcoded. I have rebooted the server, I have relaunched Retrospect, I have started and stopped the engine, I have rebooted my LTO device (Tandberg Ultrium LTO4 8 slot loader). I am at a loss. Plus it takes 30 minutes to scan the drives before it tells me the tape is part of some other set, so thats very annoying.  I have also manually assigned a tape to the backup set hoping this would solve my issues and I still got the same error.  I am hoping someone has a solution or I will start a new media set and start over to see if that works. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...