Jump to content

restoring retro8 application support folder


Recommended Posts

Hello

 

I've had to do a fresh install on my backup machine (running OSX 10.6 server).

before going ahead with the erase and install i backed up the Application support folder for retrospect 8 hoping it would save my preferences etc etc.

 

I've now completed the setup of my backup machine - reinstalled retrospect 8 (and updated) - i stopped the engine and restored the retrospect 8 application support folder however my machine still recognizes it as a new install of retro 8 and doesn't restore the old sources and old setup… etc

 

did i miss something out!?

 

the application support folder was definitely not corrupt as it was all working before i went ahead and did an erase and install…

 

 

any help/support/advice would be much appreciated

 

i have around 60 machines i backup on a daily basis and really don't want to start from scratch…

 

many thanks in advance

Link to comment
Share on other sites

Did you restore the /library/application support/retrospect folder?

 

If so, did you recover the "config80.dat" (or "config80.bak") files?

 

If so, then stop the engine and replace the "default" config80.dat file with the version you recovered and restart the engine.

 

You should be all set then.

 

Or, if that didn't work for some reason, rename the restored "config80.bak" file to "config80.dat" and use that.

Link to comment
Share on other sites

Do you have more copies of "config80.dat" or "config80.bak" you can restore?

 

I've moved backed up/restored copies of these files to other machines and replaced them accordingly dozens of times and this has always worked.

 

Try this: From what you restored (and compare the file size -- is it larger than a default config80.dat), make sure -- after you stop the engine -- that you replace *both* the config80.dat and config80.bak files -- not just the .dat file.

Link to comment
Share on other sites

Update: the restore .bak & .dat files are around 40MB each however when i follow Maser's advice to

 

- stop engine

- restore the original .bak & .dat

- start engine

 

i've noted that they go from being around 40MB each to 94KB & 745KB each... it looks like either retrospect is overwriting them or stripping them files of the preferences....

 

- ive also attempted restoring the entire original retrospect app support folder... either way I'm having no luck!

Link to comment
Share on other sites

Hello

 

I've not backed up any of my users or servers for 24 hours - I'm getting a little concerned.

 

is there a support number i can call to get some help based in the UK - even if its paid support to resolve this issue.

 

the restore app support folder is not just not working > if i need to start from scratch again then i'd much rather get to work asap.

 

any advice would be much appreciated....

 

 

Link to comment
Share on other sites

Do you have the same problem if you move those "restored" files to another computer and install Retrospect there?

 

And have you tried the 8.2 beta?

 

 

The other thing to try:

 

Stop the engine. Delete the "config80.dat" and "config80.bak" files.

 

Take the restored "config80.bak" file -- rename it to "config80.dat".

 

Put this restored/renamed "config80.dat" file *ONLY* in the directory.

 

Start the engine. What happens?

 

(It's entirely possible the size of the file may shrink depending on how old the file is when it goes live.)

 

 

And, is this your *only* backup of "config80.dat"? Or do you have others you can restore?

 

Link to comment
Share on other sites

Maser - thank you for all your help on this one - i tried everything and finally got thing working with your final suggestion! much appreciated.

 

 

 

The other thing to try:

 

Stop the engine. Delete the "config80.dat" and "config80.bak" files.

 

Take the restored "config80.bak" file -- rename it to "config80.dat".

 

Put this restored/renamed "config80.dat" file *ONLY* in the directory.

 

Start the engine. What happens?

 

 

 

for future references:

 

a) what files should i be backing up to avoid this happening again

 

b)having answered A) can i set a script to have retrospect back those files up on a daily basis?

 

once again - thankyou!

 

Link to comment
Share on other sites

A) -- You should probably backup the /library/application support/retrospect folder daily. Based on your results of your problem, if you want to limit things, maybe just backup the ".bak" file?

 

B) Yes. Set the folder as a "Favorite Folder" and just back that up to it's own media set. That's what I do here (as well as doing a finder copy -- with the engine quit -- of the "config80.dat" file before and after I make any major changes

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...