Jump to content

catalog file - incomplete?


Recommended Posts

i lost my C drive this morning, and along with it, my catalog files. the actual backup files are on a NAS, and weren't affected. i restored the C drive onto a new physical drive from a ghost image i made in mid-Jan 10. booted up, no problem. looks good - just need to replace a few files from backup...


so, the last incremental backup was 4/12/10, and there are RDBs with that date in the folder. 4/8, 4/5, 4/1, 3/28, etc., also. they range from 12/19/09 to 4/12/10. i just started this backup set in December 09.


so, i started Retrospect, told it to recreate the catalog files from disk, pointed it at the folder where the .RDB files live, and let it run while i went to work....


when i got back home, it had finished rebuilding the catalog, so i used Find Files to try to recover my Eudora mailbox files; i told it to search for all files with the *.MBX extension. it found two of them.


and, the two it found were from 7/12/[color:blue]08[/color] and 7/2/[color:blue]05[/color].


(predates the earliest RDB by at least a year)


these being mailbox files, they are updated every day. there is absolutely no way these files are the latest versions.


i know the incremental backups work - i've recovered files from them many times in the past - including .MBX files. but now... ?


what is going on here ?


using 7.6 now (because that's what was on the ghost drive), but the backup files i think were made with 7.7 ? (no way to verify that)

Edited by Guest
Link to comment
Share on other sites

i also do full backups monthly to a USB drive. just to make sure it was OK, i took a look at it, too. of course i had to recreate the catalog for that one, too. but when that was done, it showed no files (or snapshots) newer than 2/10. double fail.


so, having given up on recovering any files, i tried to do a new backup to the Incremental backup set (the one on the NAS). Retrospect then said the backup set was corrupt. i tried to repair it, and that also failed ("can't use a non-valid backup file..."). triple fail.


this is completely unacceptable.

Edited by Guest
Link to comment
Share on other sites

7.6 can't correctly generate catalogs from 7.7 backup sets ?

Yep, once you do the upgrade, you can't go back. You might want to read the "Read Me" next time before you do such an update, especially the section entitled "Upgrading from a Previous Version of Retrospect". From the Retrospect 7.7 for Windows Read Me:


Older Backup Sets: If you are an upgrade customer, you can use your older Backup Sets with Retrospect 7.7. However, once you use a Backup Set with Retrospect 7.7, you can no longer access it from earlier versions of Retrospect.


Link to comment
Share on other sites

a couple of suggestions for EMC:


1. make it easier for people to recover their registration info.


the ghost drive i had to fall back to only had 7.6. and while i had already upgraded to 7.7, and had been running it for a couple of months, i wasn't sure if i had upgraded or not - my lost emails included my 7.7 registration info.


i looked all over the EMC web site but found no way to recover my key (or to see if i had even upgraded). AFAICT, there is only a web form for "requesting a key" (whatever that means), and which has so far generated no response, 24 hours after i filled it out. i called the support line, but after a 30 minute wait in the queue, i gave up.


in the end, i ended up buying a new 7.7 license, as an experiment. happily, it worked.


2. if there is no forward compatibility, when an older version encounters newer backup data, it should give a useful error message ("this backup set was created with version X.X of Retrospect, please upgrade"), instead of proceeding as if nothing's wrong.


there's a big difference between thinking your backup data is completely hosed for some unknown reason, and the simple matter of grabbing the latest version from your website.

Edited by Guest
Link to comment
Share on other sites

You and I are in agreement with this. Many times, at least in the 18 years that I have been using Retrospect, an upgrade process has warmed over the backup sets and made them incompatible with earlier versions.


Many times, instead, the older backup sets are simply treated as "read only", and you have to do a "transfer" from the older backup set to a new one in order to be able to update the older backup set and preserve backup history.


It's worse with the Retrospect 8.x for Mac update, which cannot read any older backup sets made by any earlier versions. I can't imagine why anyone would expect to be able to retrieve old backup data from a backup program's earlier backups, but what do I know. I thought that was the whole point of a backup program.


As for registration information, the present situation has always been the case, which is why we maintain a file for each software product with copies of purchase receipts, license keys, etc., although I believe that it is possible to contact EMC customer service (when you can get through) and provide proof of purchase and get a license key.


Useful error diagnostics have always been a problem with Retrospect for years and years.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...