Jump to content

Files visible in restore preview, but cannot restore?

Recommended Posts

Hello everyone. I am having a problem restoring some files that I would really like to recover.


I am able to locate the files in the media set they were backed up to, and everything looks good in the preview prior to restoring. When I ask it to perform the restore I get the following error and the job immediately fails.



!Trouble writing files, error -2351 ( File is encrypted)

4/7/2010 12:54:52 PM: Execution incomplete

Remaining: 18304 files, 7.2 GB

Completed: 1 files, 1 KB

Performance: 0.1 MB/minute

Duration: 00:00:09 (00:00:09 idle/loading/preparing)


I have tried restoring the data to several different locations. It fails with the same error in each location. Any suggestions?

Link to comment
Share on other sites

I've not seen that error, so some questions to start with:


1) Is your media set locked? If so, does the same thing happen if you first unlock the media set before attempting the restore?


2) "1 file" was completed according to the log -- Usually Retrospect restores things alphabetically -- is there something odd about the *next file* that would be restored? Some weird name/size/something else?


3) Can you restore *any* files from that media set to your locations? (Or restore from other media sets if you have any others?) What kind of locations are you restoring to? Can you restore to the *engine* computer?



Link to comment
Share on other sites

1. The media set is unlocked. I can restore other favorite folders from the same media set to the same restore destination, but not this particular folder.


2. The only file that the script successfully restores each attempt is desktop.ini. The second file is then created with a size of zero bytes and the script fails. I tried manually deselecting the second file from the restore and the new second file (would have been third file before if the script had gotten that far) was created with 0 bytes and the job failed.


3. This is to a local disk on the engine computer.


Other files from the same client, but not the same favorite folder, can be restored without any problems.

Link to comment
Share on other sites

error -2351 ( File is encrypted)

Remaining: 18304 files

I can restore other favorite folders from the same media set Other files from the same client, but not the same favorite folder, can be restored


So your Media Set contains restorable files, including (but not limited to) files from this same client.

- What OS is the client?

- Is there anything about this source/Favorite Folder that would explain the "encrypted" error? What's the path to the Favorite Folder?


Of the 18,304 files in the Favorite Folder we know that neither the first nor the second will restore. Have you tried others? The seven thousandth? The last?


Just to see if the failure is Retrospect's inability to write (as opposed to an invalid file stored in the Media Set's Member) can you setup a Copy Media Set script and transfer this Source into a new, empty Media Set (won't solve the problem as experienced but might provide some helpful info)?




Link to comment
Share on other sites

I am going to pull the machine and take a look at it today. I will be able to answer these questions more once I have a hold of the computer.


Luckily, the data is still safe on the original machine. This was a routine "what if" test that Retrospect appears to be making a failing grade on so far.


The client is Windows XP, SP3. Retrospect client 7.6.107. The data in this favorite folder is located at the root of the system drive. Although nothing strange should have been done to the data, I will have to take a close look at it this afternoon before I can say for sure. Thanks for the suggestions. I will let you know what I discover.

Link to comment
Share on other sites

If you can't restore the data to the Mac engine computer, then the problem is likely not with the Windows client specifically (as any engine-client interaction issues would be taken out of that picture...)


Since you still have the original data, I'd suggest backing up the same data to a new media set and see if you still have a problem restoring the data from that new media set.



Oh, and you *could* try the Retrospect 7.7 client for Windows -- I run that on my XP SP3 machines with no issues. (But, I'd be surprised if this made any difference...)

Link to comment
Share on other sites

Well, the end user of the machine is to blame for this I suppose.


All of the files are encrypted using Windows XP's EFS (Encrypted File System). It looks like Retrospect's statement (error) was entirely accurate and the files are actually encrypted.


And that brings me to my next question. Shouldn't Retrospect either support restoring these encrypted files, or give a warning and fail to back them up? What is the purpose of backing up 8GB of files that cannot be restored? I will log in as the user and decrypt the files and then back them up again, but I wish this hadn't come as such a surprise. I have never seen any sort of error about the files in the logs.


Good thing this wasn't an actual disk failure.

Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...