Jump to content

Version 7.7 locked range conflict on pst file


Recommended Posts

Just upgraded to 7.7 from 7.6. (Including the patch). I have a duplicate job that copies pst files using open file backup. In version 7.6 it worked flawlessly. Now at 7.7 I get message "locked range conflict" There are no VSS errors. Also my full system backup appears to work OK and backs up the PST files without a problem. I think this is a bug inversion 7.7.

here is the log

- 12/17/2009 12:08:43 PM: Copying Documents and Settings on HP_PAVILION (C:)

File "C:\Documents and Settings\Administrator\Local Settings\Application Data\Microsoft\Outlook\Before_2008 Folders.pst": can't read, error -1111 ( locked range conflict)

File "C:\Documents and Settings\Administrator\Local Settings\Application Data\Microsoft\Outlook\Personal Folders.pst": can't read, error -1111 ( locked range conflict)

File "C:\Documents and Settings\localadmin\Local Settings\Application Data\Microsoft\Outlook\xwprice_Outlook.pst": can't read, error -1111 ( locked range conflict)

12/17/2009 12:14:43 PM: Comparing rbc_pst_etc on My Book1 (G:)

12/17/2009 12:14:43 PM: 3 execution errors


Edited by Guest
Link to comment
Share on other sites

Thanks for the reply. It does not display "preparing for open file backup". I have made some screen shots that I can send.

It goes from scanning to preparing to execute.

At that time the MS event viewer shows VSS starting without any errors. As soon as duplicate starts the errors previously sent appear in the Retrospect log.

I have checked the job and the use open file backup option is checked.

The product shows that open file backup is licensed.


Any suggestions?

Link to comment
Share on other sites

Now that I submitted my case to tech support how do I follow its progress?

It's obvious that duplicate is not using the open file backup for some reason so I hope we can continue the case.


The phone call method was quite painful with a hold for almost 30 minutes to find out what to do to create the debug info. so I hoped I would receive emails or links to a support site to carry on the case. So far I have had no response.


Thanks for looking into this for me.





Link to comment
Share on other sites

  • 5 weeks later...

Just talked to Keith -- he remembered you. Talked about VSS events and some very deep tech stuff, most of which I do not understand. I just want my pst file duplicated every day. This bug has already cost me four months of e-mails.


I ran the event view while he was on the phone with me and sent him a screen shot of the error report I get from both the Event View and from Retrospect when it fails to dupe the file.


Overall, pretty shabby support on a product that people buy to save their digital lives.


Let's keep all our fingers crossed.

Link to comment
Share on other sites

Uhmmm... I didn't have my coffee yet but isn't this an obvious problem? :yawn:


You always get a locked range conflict when Outlook is running. Log out the user of the client and try the backup then. It shouldn't generate a locked range conflict then.


This is due to the fact the pst is in use (an open file if you will) when Outlook is running and Retrospect can't backup an open file (without a special add-on).


So it isn't an unexpected problem and if you have logged out the user you are trying to backup, the problem shouldn't happen.

Link to comment
Share on other sites

Not as obvious as it seems. Although you'd think ...


Retrospect is set to do open file backups and the license is valid to do so, meaning I have the add-on. There's even a special setting in the Retrospect config area for Outlook.


The error occurs regardless of whether Outlook is open or not, or whether anything else that Outlook might depend on is open.


Quitting Outlook was the first thing I tried.



Link to comment
Share on other sites

Ahwell, I reread the first post and finally saw "open file backup"... I think I need some more coffee still...


So quiting Outlook didn't help... Did you try logging out? Even better, restart the client and do not log in. Try the backup again and see if that helps.


Not meant as a fix, but as a workaround.

Link to comment
Share on other sites

The same thing is happening today although the error is slightly different. EMC technical support was no help and at one point was intimating that they did not view this as a problem of 7.7. It is certainly related to the inability of open files backup to work properly. I have since reverted to retrospect 7.6 where there is no problem (there never was -- it works flawlessly with Windows XP, Windows 7/32 bit, and Windows 7/64-bit). The only problem according to technical support is that retrospect 7.6 on a Windows 7 machine will not backup the registry properly.


I wish retrospect would give some credence to this issue. I purchased retrospect 7.7 hoping to have the latest update when now the only thing it is doing is collecting dust.

Link to comment
Share on other sites

I just ran Retrospect with Outlook closed. The pst file *was* backed up, but I got this error message in the log: File "E:\System Volume Information\9{3808876b-c176-4e48-b7ae-04046e6cc752}": can't read, error -1017 ( insufficient permissions)

E is the drive on which the Outlook files reside (source, not destination).


I'm surprised that a product with the maturity of Retrospect has a bug in what I'd consider to be a core function, that is, open file backups. Not sure users should have to resort to "workarounds" when buying software from a company with the reputation of EMC.


If I have Retrospect on a schedule, why would I have to manually quit Outlook so that it can run if open file backup is set? That would seem to eliminate the advantage of a process that happens automatically.


I am experiencing this on W7 64-bit, local drives (non-network), latest version of Retrospect: 7.7.208.


Thank you.

Link to comment
Share on other sites

You can see the user ID that the client is running under in the Processes tab of Windows Task Manager. (You'll have to show processes from all users, of course.) It's probably one of the special IDs such as LOCAL SERVICE.


Then open the properties of the PST file, go to the Security tab, and see if that user ID has (at least) all the Read permissions. The easiest way to check the permissions is probably to click the "Advanced" button, go to the "Effective Permissions" tab, and select the User ID that the client is using.


If that ID doesn't have read permissions then your system probably has some nonstandard access controls on that drive or its subfolders that prevent the Retrospect Client from accessing the files.


-- Pete

Link to comment
Share on other sites

Great thought. I checked the permissions as you suggested (I am the only user of this PC in a home office environment) and although administrator was given full permissions, my user name was not. So I changed all that and then ran the dupe script.


Unfortunately, the result was the same:


+ Duplicate using My Docs at 1/27/2010 11:19 AM

To volume My Docs Dupe on External (G:)...


- 1/27/2010 11:19:10 AM: Copying My Docs (E:)

File "E:\E-Mail\archive2.pst": can't read, error -1111 ( locked range conflict)

File "E:\E-Mail\Outlook.pst": can't read, error -1111 ( locked range conflict)

1/27/2010 11:23:15 AM: Comparing My Docs Dupe on External (G:)

1/27/2010 11:23:16 AM: 2 execution errors

Completed: 3 files, 626 KB

Performance: 0.8 MB/minute (0.4 copy, 36.6 compare)

Duration: 00:04:05 (00:02:43 idle/loading/preparing)


Link to comment
Share on other sites

Thanks for reporting on the results of your re-test.


Are you sure that the Retrospect Client actually runs as your user ID? I'm pretty sure that the Retrospect 7.6 client runs on the Local System account.


The default ACLs allow the Local System account to have full access to just about everything. If those ACLs have been changed then I suspect that most backup programs will have trouble.


-- Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...