Jump to content

Backup to DVD - "Needs Media" error

Recommended Posts

Running 10.6.2 on a MBP (2.53 GHz Intel Core 2 Duo, 4GB 1067 MHzDDR3, 270GB available hard disk space) and trying to backup to DVD using trial download of Retrospect 8.1.


When executing a scheduled script or using the backup button, I get a "needs media" error with a blinking black and white question mark icon. I've tried it with several new DVD-Rs, putting the disc in before starting the program and at the "needs media" prompt, but I can't get past the "needs media" error.


I have set up an optical media set. It has a gray pencil icon with a line through it. Retrospect recognizes my optical drive.


Please help. Also is there a user guide for retro 8? All I can find is the quick start guide which doesn't help.

Link to comment
Share on other sites

I assume that you have activated optical support by modifying retro.ini as described in the article "Retrospect 8.x for Macintosh Optical Support (9720)" in the knowledgebase.




However, if you can eject the tray from the Finder (e.g. using the eject button), then the Retrospect Engine does not have control of the drive.


What you need to do then, is to eject the drive, stop the Retrospect Engine (from within System Preferences), restart the Retrospect Engine, and then close your tray by pushing on it.


Now, the Retrospect Engine will have control of the drive and you will only be able to eject the tray from within Retrospect.


Retrospect should then operate normally.

Link to comment
Share on other sites

Also is there a user guide for retro 8? All I can find is the quick start guide which doesn't help.

No, there is no user guide. Apparently documentation is not a priority, and the Retrospect group does not have a documentation person on staff. The product was only announced a year ago at Macworld in the first week in January 2009.


Think of the program as a game, with twisty turny passages, all alike. Program operation has to be learned by trial and error. Many bugs, so it's hard to tell what the correct behavior should be.



Link to comment
Share on other sites

Hadn't seen that article, thanks. I changed the retro.ini file as instructed but still having same problem.


Even followed the steps in "How to tell if your optical device is supported by Retrospect 8" because I'm not sure what the "disclosure triangle" icon is (is that the green orb with a check in it???) - it said my device was configured and ready to use but still having the same "needs media" error.


Stopped & started the retro engine, quit and restarted retro app but still no luck.


When I put in the DVD whether before retro is running or at the needs media prompt, it is still controlled by the finder.


If only Time Machine could backup to DVD I wouldn't have to deal with Retrospect ever again!

Link to comment
Share on other sites

AHA! But quitting the retrospect app and reopening it works now!!! Holy crap, it's a miracle! I'm backing up to DVD as I write.


But does this process need to be done EVERY time you run a backup to DVD? No wonder they haven't gotten the user guide done yet.


Thanks, jsobel. You saved me from wasting countless more hours of my life.

Link to comment
Share on other sites

Although, I don't have any experience of how this works with a slot DVD, I think that once the Retrospect Engine takes control of the DVD, you don't have to repeat the procedure.


However, if you want to use your optical drive for anything else in between backups, you certainly do need to.


For example, after a restart.


I always restart with the mouse button down, in order to eject my backup DVD before startup. In this way, when I push it to close after startup, Retrospect takes control again.


No wonder they haven't gotten the user guide done yet.


No, I don't think this hassle is related to the lack of user guide, but it certainly is the reason why they have backup to optical media disabled by default.


Apparently they can't share the optical drive with the Finder, and are waiting for Apple to come up with a solution. I can't understand why... It was working somehow in version 6 of Retrospect.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...