Jump to content

Mac Boot Failure after Full Restore


Recommended Posts

I am sure I am missing a simple step somewhere - but I tried to restore a "entire" drive from a Retrospect 8.0.736.1 for Mac complete backup to a replaced boot hard drive on a first generation MacPro. The "restored" drive failed to boot, shutting down the computer. There are forum threads about a similar problem with Windows, but not with Mac OS. The Knowledge base and Tutorials have not helped. I have successfully restored files / folders from Retro 8 but never had tried to restore an entire drive. Test and an actual "disaster recovery" from previous versions of Retrospect - both WIndows and Mac versions - have worked without problems.

 

[color:blue]Configuration:[/color] The MacPro utilizes Mac OS X 10.5.7 and runs a native and a WIndows XP virtual machine under Parallels Desktop 4.0 for Mac. The Parallels VVM HDD files reside on a physical drive separate from the drive containing the Mac OS and files. OS specific Retrospect Client software is installed on both the Mac and the VM. Retrospect 8 runs from the Mac and on a Tech Tools Pro 5.0 eDrive on an external firewire hard drive.

 

[color:blue]Process:[/color] A complete backup of the Mac boot drive was performed from the Mac based Retrospect to the external hard drive. VM files were not included. The backup completed as usual without problems except for several log and antiviral files. The backup was updated from the eDrive based Retrospect without any error messages or un-copied files reported immediately prior to the restore. The 500GB Mac boot drive was replaced with a new 1TB drive and formated from the eDrive with Apple's Disk Utility. The initial restore was made via the Restrospect Restore Wizard for replacing the entire drive to the time of the complete eDrive backup. The process completed without errors; the restored drive's integrity was verified by Disk Utility's First Aid. Visual inspection of the drive via Finder confirmed file transfer. The drive failed to boot. A second attempt was made by refomatting the drive and installing the Mac OS. A Retrospect restore from the eDrive using the files and folders replacement option ran without errors. That restore also failed to boot.

 

[color:blue]The questions:[/color] Is this related to the change in drive capacity and some restored system file looking for the original drive ? Or is there a more appropriate way to restore a drive, or as in this case, transfer data to a replaced drive in Retrospect 8 ?

 

Utilization of the Mac OS DVD and a Time Machine transfer did not have a problem in restoring the system on the new drive. Retrospect 8 offers file / folder restoration through a very workable GUI of both my physical and virtual machines, but the ability to recover from drive catastrophes and the ability to transfer data to new drives is of paramount importance.

 

Any thoughts appreciated.

Link to comment
Share on other sites

To do a full system restore you must install a temporary version of the Mac OS on the disk first.

 

Basically you format the disk, install 10.5.7. Boot from the disk. Install Retrospect and then perform a full disk restore onto the running system.

 

We have an open bug that can cause a boot failure if the destination disk for a full system restore is empty. This is fixed in the next update we have coming in a few weeks.

Link to comment
Share on other sites

Thanks. I have appreciated your comments throughout the forums and beta testing. Will the bug fix obviate the need for running Retrospect restore from the new / destination drive for complete recoveries or is that protocol the one that is needed for "disaster recovery" ?

Link to comment
Share on other sites

Until I have tried it myself, I will not say 100% on anything.

 

Totally reasonable. I wish I had enough spare hard drives to try it myself myself.

 

Any idea why, if every file is backed up and every file is restored, an off-line boot volume restore to an empty volume doesn't work as expected? Is it a Blessing issue?

Link to comment
Share on other sites

Any idea why, if every file is backed up and every file is restored, an off-line boot volume restore to an empty volume doesn't work as expected? Is it a Blessing issue?

It's much more complex than that. Mike Bombich, an Apple engineer and author of Carbon Copy Cloner, discusses some of them on his web page.

 

Most likely culprits are:

 

(1) not restoring metadata properly, more a problem with Tiger and Leopard than prior OS versions;

 

(2) restoring too much - cached system states that shouldn't be restored;

 

(3) changes in filesystem partition layout over time;

 

etc.

 

I haven't been able to test Retrospect 8 because it doesn't yet support our configuration and/or requirements.

 

Russ

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...