Jump to content

"Resynchronizing (slow)"

Recommended Posts

Here's the situation. I have a Mac that's hooked up to a Sony DDS4 DAT via SCSI that the designers use to restore their archived jobs from. A couple of years ago, it was running Retrospect 4.0.




Last year after the box was upgraded to Retrospect 4.3, some tapes refused to be recognized. Despite futzing with Retrospect's SCSI settings, driver updates etc, this could not be rectified. The only solution was to use Retrospect 4.0, which could see and restore from the tapes fine. Both versions were left on the machine and the designers new which tapes had to be used with version 4.




Unfortunately, I need to recreate a catalog from a borked tape set. The first tape in the set seems unrecoverable, both 4.3 and 4.0 cannot even read the header and deem it's content "unrecognized". The second tape can be read in 4.0, however recreating the catalog is proving almost impossible. During the catalog repair process, "Resynchronizing (slow)" constantly appears, at the rate its going the 20 gig DAT tape will take days just to re-catalog.




Now, this can be a legitimate error for damaged tapes, however Dantz does have a driver update for 4.1 which supposedly rectifies this error when it shouldn't appear. As the catalog process is in fact progressing (just glacially), my hunch is that it's a driver issue. Of course, Retrospect has dropped support for versions below 4.1, and as 4.3 can't even recognize the tape, right now I'm screwed. What I'd like to know is that if this 4.1 error is applicable to 4.0 as well, or is my hunch way off?




Some more recommendations to adjust any settings in 4.3 to make it recognize tapes backed up with 4.0 (not all of them don't work however) would be appreciated as well.




I'll add that I have a second identical Sony DDS4 drive on another machine with the same results, so it's not a problem with the drive.





Link to comment
Share on other sites

Content Unrecognized: This error message is basically a hardware error being reported by your tape drive. When you go to Configure>Devices and insert a tape, Retrospect waits


of the tape drive to report the name of the tape.




When content unrecognized is reported, this means that your tape drive has read the header of the tape and is now reporting to you that the header does not contain readable data. Although your tape contains data, it is not readable Retrospect data.




This could be caused by several things.




1) Dirty tape heads


2) Bad or damaged tape


3) Tape created in a compression drive trying to be read by an incompatible non-compression tape drive


4) Tape written on a tape drive with heads out of alignment.


5) Failing read heads or failing tape drive.




If a tape is created in an older or failing tape drive, then the tapes are often not readable by a new tape drive. This is usually caused by head alignment problem or by drive compatibility between the old and new drives.




If a tape was recently created in a tape drive and now that same tape drive is unable to read the tape, then this could have a few causes:




1) Dirty tape heads


2) Flaky tape heads that are not reading data correctly


3) Tape damage during storage (Electromagnetic fields of some kind), environmental conditions.


4) Physical damage to the tape








At the time of the backup was verification turned on? If yes and no errors took place, then this means at the time of the backup your tape was readable and something has changed to make the tape unreadable.




If the tape is only readable by the original tape drive and no other tape drives, then this indicates that the tape was written when the heads were aligned in a very specific and non-standard position.




Resynchronizing (slow) indicates the tape drive is having difficulty reading the contents of the tape. Retrospect 4.3 optimized the device drivers for better performance. Existing SCSI issues may not have appeared with older versions as a result. Try disabling 'Fast and Wide SCSI' in Retrospect by going to the Special tab, holding down the Option key, and clicking Preferences. Under HW Compatibility, check the box to 'Disable Fast and Wide SCSI.' Try your recatalog again.




If no tape drives can read the tapes at this point, then this means you would need to contact a Data recovery service.

Link to comment
Share on other sites

Thanks for the reply, but you'll note that these tapes which read as "content unrecognized" in 4.3 _will_ successfully recognize under 4.0. Mentioning that however was likely needlessly confusing, while receiving "content unrecognized' is a problem for some tapes, in this particular instance the one tape which can be recognized under 4.0 is also recognized under 4.3, the problem right now is re-creating the catalog.




Under 4.3, the catalog process starts and goes for 10 seconds, but then just hangs; Retrospect does not lock up, however no further progress on the catalog is made. Along with the content unrecognized issue, this behavior as well is why 4.0 & 4.3 are kept on the same machine for these few tapes which have a problem with 4.3, so this is not an isolated incident. This has been tried on 3 different systems with two tape drives (models identical however). Disabling FAST/WIDE SCSI makes no difference.






So, to summarize:




Using Retrospect 4.0, at least one of the two tapes can be recognized and the catalog process beings (the first tape in the set looks to be damaged). However, 5 minutes into the process, "Synchronizing (slow)" appears, and it slows to a crawl - from 200 meg/sec to under 5. It still proceeds, just at a glacial pace. From Dantz's knowledgebase, the 4.1 drive update can correct this, assuming the tape isn't damaged. Considering that the catalog is ongoing, yet extremely slow, leads me to believe it could possibly be a driver issue. Of course, this is version 4.0 - the 4.1 driver update will not work. As it's 4.0, there is no "Disable Fast/Wide SCSI" option, so strike that.




Using Retrospect 4.3, the same tape will be recognized just as it is in 4.0, however as mentioned the catalog process goes nowhere. It appears to start, the tape spins, and Retrospect just sits there. This behavior has been seen before on some tapes, reverting to 4.0 solved the issue. SCSI settings do not change this.



Link to comment
Share on other sites

The Knowledgebase indicates that 4.1 can rebuild catalogs faster then previous versions, but I don't see what you are seeing about a driver update. I'd be glad to take a look at the article you are reading if you can provide me with the name or the link. Building a catalog faster (as 4.1 and later versions do) will not resolve the issue you are experiencing. Nor are 4.1 or 4.2 updaters available.




Retrospect 4.0 gets a few minutes into reading the tape and Retrospect 4.3 can't read the tape at all. It sounds like you have a damaged tape. If new tapes can backup and restore fine (indicating that the hardware is functioning properly), yet you consistenly have problems with these old tapes, then you would need to contact a Data Recovery shop for retrieval of data.




From the Knowledgebase:




Resynchronizing (slow)




If you get the message 'resynchronizing (slow)' for longer than 10-20 minutes while rebuilding a Backup Set catalog from the backup media the recatalog or updating process has failed and will not continue any further. At this point you must stop the operation.








Generally the format of a tape written in Retrospect consists of a header chunks of data and end of data markers (EOD). These EOD markers are crucial and must be written before a tape drive closes and finishes with a tape in the drive. During hangs or unexpected stoppages the drive usually doesn't have a chance to write an EOD marker so the end of where the tape was left off is often left in this precarious state of missing an EOD marker.




Subsequent access of the tape, as in an attempt to update the catalog, could result in a hang or "resynchronizing (slow)" message. A hang during backup will result in a 'Catalog out of sync' message in a subsequent append to the same tape. This is because the catalog is written to in periodic increments in which case a hang or freeze would create a discrepancy between what's on the tape and what's recorded on the catalog. This is why you need to update the catalog after such events.




Due to the realities of EOD markers on tapes a crash or hang on a tape backup is pretty severe and usually hard to recover from. You often cannot continue that Backup Set. The ideal thing would be to start a new StorageSet altogether.





Link to comment
Share on other sites

It's from the 4.1 Driver 1.8 Update Read me:








"There is a problem with the DDS-4 DAT driver of Retrospect 4.1 Driver Update version 1.7, but that problem is fixed by the Retrospect 4.1 Driver Update version 1.8. The problem affects DDS-1, DDS-2, and DDS-3 format tapes used in DDS-4 drives. It would cause Retrospect to sometimes report error 102 (trouble communicating), "Content Unrecognized", or "resynchronizing slow" while reading from or writing to DDS-1, -2, and -3 media in DDS-4 drives."






Now, this may imply that this bug was *introduced* in driver update 1.7 and subsequently does not exist in prior versions, but I can't be sure based on the wording above.




The fact of the matter is, under 4.0 I actually don't consistently have problems with these old tapes. While 4.3 won't recognize some of them, the same tapes through 4.0 continue to catalog and restore from them fine. Backups are being done under 4.3 to duplicate these (as always seems to be the case, not these ones yet!), however the originals work just fine under 4.0, with the exception of these of course. The behavoir that 4.3 exhibits with this tape is the exact same behavoir it exhibits with some others that work fine under 4.0, which is why I'm interested in versions between the two. As mentioned, the catalog _does_ proceed under 4.0, files and folders are continually being added, the pace becomes a crawl, but it does not stop (albeit so slowly that for all intents and purposes, it might as well). 4.3 on the other hand, cannot catalog it at all, although it at least does recognize the tape in the drive.




While that doesn't imply that there are no problems whatsoever with the tapes (there likely are), it is odd that 4.0 proceeds without error for these problem tapes until now, hence I've been trying to narrow down exactly what 4.3 is doing differently. The disabling fast/wide SCSI looked to be it, but alas.




Naturally I'm aware of data recovery services, but I'd sooner flail about for a week trying alternate methods before spending what would amount to an employee's salary to recreate the lost gigabytes of artwork by hand. :)



Link to comment
Share on other sites

Which version of Retrospect were you using when writing these tapes originally?




Which drive were you using? The Sony DDS-4, also known as the SDT-10000?


If I understand your posts correctly, you are using the Sony DDS-4 tape drive with Retrospect 4.0, not 4.1?

Link to comment
Share on other sites

I don't have 4.1, only 4.0 and 4.3. For the first tape, I can't be sure which Retrospect version was used as it was already archived with data before I took over support of this department, I'm assuming it was done with 4.0. That tape cannot be recognized be either version. The second tape was done with Retrospect 4.3, that's the one Retrospect 4.3 cannot catalog, and 4.0 will start the catalog process before the resynchronizing error occurs and slows it to a crawl. What I'm curious is if the Driver Update 1.8 for 4.1 fixed a specific bug with 1.7, or this synchronizing error will occur with all prior versions of Retrospect and driver packages. As mentioned, I understand that there is probably tape damage, yet I want to rule out driver problems before commiting to a data recovery service.




My mistake on the drive model however - both drives are Lacie DDS4 SDT-11000, although I believe they're based on a Sony mechanism.

Link to comment
Share on other sites

The SDT-11000 is not supported for use with Retrospect 4.0. This drive was qualified and supported with Retrospect 4.1 and RDU 1.7. RDU 1.8 addressed specific issues with this drive. Retrospect 4.0 may have recognition for this drive, as you've seen, however backups and restores would be unreliable and unsupported.




We currently recommend minimum versions of Retrospect 4.3 and RDU 2.2 or higher due to compression issues with earlier versions.




You are correct - LaCie uses the Sony mechanism in this particular drive.

Link to comment
Share on other sites

An update: An older Sony DDS2/3 drive was found, cleaned multiple times, and the first tape of the 2 tape set restored succesfully. Phew! The second tape however exhibits the same issues, 4.0 will catalog it but become erratic. It's a DDS4 tape, so it won't work in the Sony. Why these Lacie drives were purchased when 4.0 didn't support them is beyond me. (:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...