Jump to content

Retrospect Professional Not Responding on Vista 64 bit


Recommended Posts

I am using Retrospect Professional 7.6 with the latest updates applied

It is installed on Windows Vista Ultimate x64 (64 bit)

Retrospect is constantly not responding!

If I wait long enough (more than 5 min) it will eventually start responding again.

The published system requirements say Retrospect Professional works on Vista 32/64

I need help to get this working properly.

Please let me know if any additional information is needed.

Thank You,



Link to comment
Share on other sites

I’m currently at work so can’t give precise answers to all the questions.

The machine has 8 gigs of ram

There are at least 100 gigs of free space on the hard drive Retrospect is installed on. (More like 200) (The drive is a WD 500 gig drive)

Just minimizing and maximizing the Retrospect window causes it to “not respondâ€

I don’t know where to begin trouble shooting. I’ve used Retrospect for years with no issues. Prior to Vista 64 I was using XP professional.

The tasks I was performing were to recreate an existing Retrospect 7.5 catalogue that was on a 500 gig WD MyBook and restoring the contents of the backup set.

With a lot of waiting retrospect will respond again and the necessary configurations/selections can be made.

Just to be clear I anticipated the hours it would take to actually recreate the catalogue and restore the files. The issue is the configurations/selections.

Link to comment
Share on other sites

There is no network attached storage being used.

All drives are either in the computer or directly attached via USB2.0. FYI, there are 3 drives in the computer and the MyBook attached.

The drive I am working with is the C: drive. The two additional drives in the system have different drive letters assigned to them than in the previous system the cataloged was created on.

Link to comment
Share on other sites

  • 1 month later...

I have the same problem. It only happens when I am doing a backup of the drive that has Vista installed on it. When it gets to the "Registry" part of the backup, it locks the Windows UI for several minutes.


What is interesting is that Sidebar gadgets still update and operate, and you can mouse over some vista window widgets and they produce mouse-over effects, but I cannot click on anything, change windows, use the task bar, keyboard, or anything. I can only move the mouse around and get some mouseover effects. Actually, the status bar in Retrospect still animates the icon next to the "One execution running..." text.


I am on Vista X64 SP1, Dell Precision M4400 w/8GB RAM, Retrospect Pro 7.6.123, and am backing up to an eSATA drive. I have remote shares mounted as drive letters but I cannot unmount them as this is a work machine and the drives are mounted upon login via batch script. Unmounting the drives is not an acceptable solution.

Link to comment
Share on other sites

  • 1 month later...

I have (or had) a similar problem. I am running Retrospect on a XP-based system and have several computers on a LAN. I've just added a Vista 64 Ultimate computer to the mix and have experienced the backup hanging while performing a backup of the Vista 64 machine.


I also happened to notice the timing of the hang. It coincided with the power options: I didn't have the computer going to sleep but I did have the display turning off after 15 minutes. I changed this to 1 hour and the backup nearly finished but hung-up at the hour mark. I changed the setting to 4 hours and now the backup completes. I don't know why this is the case but it seems this gets me around the hang-up problem.


BTW the only reason I looked here was because I was looking for the Wake on LAN setting [it's actually in the Device Manager] but it was fortunate because the 15 minute display setting was a default setting on my system. Setting Wake on LAN didn't fix the problem.


Hope this helps...

Link to comment
Share on other sites

  • 2 weeks later...

Okay, maybe I can shed a little light on some of this. Here is how I'm setup: Lenovo M58 with E8400, 4 GB RAM, 750 GB drive and a 1 TB drive.


Retrospect runs on the 750 GB drive and backs up to the 1 TB drive. I have 1 client which is a Lenovo T400 with 4 GB RAM. Both PCs running Vista 64 Bit Business and connected via 1000 Mb network switch.


The M58 is new and was installed 2 weeks ago and Retro 7.6.123 was installed at the time and configed with scripts to auto backup both PCs to the 1 TB drive on the M58. As I usually just set and go with Retro I didn't check to make sure the backups were successful until this morning when I found out they were not running.


When I launched the Activity Monitor a small dark blue window opened which displayed 'EMC Retrospect' in the upper left and to the far right what looked like a 'power button' - a round orange circle with a vertical line inside and a typical (other than color) X in the upper right corner. Clicking the orange button made it flash slowly, but after some time (maybe a minute) it stopped flashing.


I could not get Retro to launch until I got 'properties ' on retrospect.exe and set it to compatability XP SP2 mode. Now it launches and I have my M58 backup running. The T400 is another story. It will not backup. When the script launches it conntacts the client (I see that on the client itself in the status box), but when the file backup starts I get a -519 error.


Have any of you guys tried compatability mode? I was really baffled by the odd display and I could not find any entries in the KB on this.


When my M58 backup is finished I will work on the T400 (network client) to see if I can figure out why I can connect to it and configure it, but not backup (-519).

Link to comment
Share on other sites



In Vista 64 Home Premium if I enable compatibility mode then Retrospect asks for an Administrator user login when started. Although I have two Administrator user accounts configured it won't accept either of these!!


In Home Premium you can only be a Standard User or an Administrator. The Snap-In for modifying membership of Groups is not enabled nor can it be. I wonder if this is my issue? I note you are using the Business Edition.

Edited by Guest
Link to comment
Share on other sites

Well, I have bad news again. My odd display is back and Retorspect is not working again. Looks like that was a one day fix.


I have to get this resolved as I won't get any backups until I do. Hopefully someone has seen this goofy display before and can help out with this.


Link to comment
Share on other sites

Well shortly after my last post Retrospect decided to launch and I was able to at least get a backup run. Oddly enough if I launch the Retrospect Activity Monitor I get the odd window, but if I launch Retrospect it works now.


I have a hunch about something. I noticed when Retrospect finally launched the log showed my laptop had an error -530 (backup client not found), but it was an hour before the script should have launched.


Also, I have 2 NICs on my laptop, a wired and a wireless. The wireless is always on, but the wire is not always on. It seems as though Retro can 'see' the client on my laptop using the wireless, but it wants to backup using the wire. If the wire is not online at the time the script runs Retro will launch and start the backup, but when it comes time to start copying it will get an error -530.


I'm still working on this. I'll update you if I find anything else.



Link to comment
Share on other sites

  • 3 weeks later...

Well, I have Retrospect limping along now. The auto script fails everytime so I have to remember to run the script manually. For some reason it will run if I launch it manually, but not automatically.


I get the following errors:

'Can't use Open File Backup option for Local Disk (C:) on , error -519 (network communication failed)'


'Can't reserve backup client , error -519 (network communication failed).'


Manually run the same script and it completes without a problem.


Any help here from EMC??

Link to comment
Share on other sites

  • 3 weeks later...

This all seems to be a problem with Retrospect and 64 bit OSes and/or anything newer than XP/Server 2003. I have two servers running Small Business Server 2008 (SBS is only available as 64 bit) and have the same issue of the constant "not responding". It will work for 3 seconds, then hang for 30 in this constant annoying cycle that makes it almost impossible to get anything done in it.


There's also other issues like frequent crashes, and a known issue of Retrospect not backing up Exchange mailboxes that they've been working on a fix for months but no sign of it yet.


I also use it with Windows Server 2003 and it's rock solid, stable, and trouble-free. I think, for them to claim it's compatible with 64-bit Vista/SBS/Server 2008 was motivated by $$$ and not actual compatibility.



As for the Network Monitor box that you have that keeps popping up it's because Retrospect launcher will start up Retrospect in the background as a System process. When you get that, open up the task manager, go to processes, and check 'Show processes from all users' and you will see Retrospect.exe running as SYSTEM. Kill that and you can start it back up normally.


To keep it from happening, you have to go into Configure->Preferences->Startup and un-check 'Enable Retrospect Launcher service' Then, you will have to keep Retrospect open all the time in order for it to run scheduled executions if you have them.


Retrospect doesn't seem to handle the new security model in Vista/Server 2008 well.

Link to comment
Share on other sites

  • 1 month later...

I finally fixed the -519 problem. It turned out to be my wireless card. When the Retrospect Client was installed and ran on my laptop for the first time it made the initial connection and backup using the Wired NIC. Now if the wireless is enabled when the backup script runs it will fail with -519, but if I switch off the wireless before the script runs everything is okay. My laptop will ping either way, but Retrospect wants to see only the wired NIC.


Okay, after tinkering with the other problem for some time I have noticed the following:


IF Retrospect is currently running a backup script and I try to launch Retro or the monitor to see the current status of the backup I get this odd dark blue window (RetroMonitor.exe) with no info on it. If I wait until the backup script is finished (monitor the client window) then Retro and the monitor window work as expected and the odd dark blue window does not show up.


Retrorun.exe (*32) is always running and Retrospect.exe runs when the scripts execute. (This is obvious).


Anytime I try to launch the monitor directly I get the funny dark blue window (RetroMonitor.exe), but as long as no scripts are running, and I launch Retro the monitor window will run as expected when Retro launches. Is the blue box what you refer to as the Network Monitor box kcorbin?


I was able to get the blue window and the monitor open at the same time. Both show up as RetroMonitor.exe, one owned by SYSTEM (the dark blue window) and one owned by my userid.


I think this all adds up to Retrospect not being 100% compatable with Vista 64 and maybe 32 as well.

Link to comment
Share on other sites

The behavior you're seeing in Retrospect is expected. Here's the breakdown of how Retrospect runs on a Vista or Server 2008 box:


Because the application is an application AND it runs as SYSTEM or a specified user AND it is not a service, Vista (and 2008) will assume the program needs to run in the protected desktop environment. Call this an incompatibility or whatever you like it is how the operating system treats the application. This behavior only happens during an automatic launch.


If one were to open Retrospect and minimize the application to the task bar one could get access to the application and all its tasks at any time.


I am currently running Windows 7 on my main machine and minimizing Retrospect (it's just an icon in Win7) means that Retrospect still automatically launch scripts but I still have access to the entire application.


Hope that helps.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...