Jump to content

Backup Sets Constantly Corrupting Catalog

Recommended Posts

We have Retrospect 7.0 multi-server. It runs on a Windows Server 2003 machine with plenty of cpu and ram (dual processor, dual core, opteron 8000 series at 2.2Ghz, with 8GB of ram)


Anyway, We have the system connected to a Dell MD1000 disk array via SAS. The array has 12 300GB SATA drives in it. This is used for disk backups at various intervals from all of our servers.


Then we have a weekly tape backup scheduled to do a backup set transfer from our disk backups on the raid array, onto our Dell PowerVault Tape Library (16tapes, 1 drive, LTO3)


The problem is that every once in a while while doing backup set transfers, retrospect will prompt for the source. (when transfering to tape, or when transferring between multiple disk backups)


For example, for a given server we have 12hour backups, daily backups, weekly backups and monthly backups. Each one is it's own backup set. Configured to keep the most recent 2 backups. (so we retain the 2 most recent of each time period, giving us a nice spread of data retention with fine grain backups, and good disk efficiency)


So when I run a transfer from the most recent 12hour into the daily backup at the end of the day, it will sometimes prompt for the 12hour backup... Time out, and then skip it... Backups are still running INTO the 12hour backup just fine, it's only if I try to transfer out.


It turns out rebuilding the catalog will fix this problem. But this happens at least once per week on one of our something like 100 different backup sets. And catalog rebuilds take a LONG time...


Now that we have the tape library, things are worse... Since I archive all the most recent backups to tape in one script, and if a single backup set is corrupt like this, it stops the backup, so I have an incomplete tape backup... By the time I manage to rebuild all the backup sets that failed, and restart the tape run, it's a different one and so on...


What could be causing this problem? and how can we get around it?


This is SEVERELY impacting our ability to use these backups... because of our inability to transfer data offsite we have basically no disaster recovery capability in the event out local site has a catastrophe large enough to damage the disk backups... And even then our disk backups are of questionable status because of these repeated failures.

Link to comment
Share on other sites

Come on guys, I don't even get a "We don't know" answer? I see retrospect staff replying to plenty of other topics that have been posted more recently than this one, and I'm sitting here listening to crickets, and watching tumbleweed blow by...


I'm starting to wonder if the solution to this problem is simply to buy anther product...


Anyone have any suggestions at all?

Link to comment
Share on other sites

I'm starting to wonder if the solution to this problem is simply to buy anther product...


Have you tried the latest version of Retrospect? You are 2 version back now. Current is 7.6


I don't know the answer to your question off hand, have you tried calling tech support directly for help?

Link to comment
Share on other sites

We haven't tried the newest version yet. As the upgrade to 7.6 from 7.0 is not free (we would need to purchase an upgrade).


As for support, I'm pretty sure our support contract has run out by now. This version was purchased 3-4 years ago...


The main reason we haven't bought the new version is that 7.0 still recieved updates, supports all our hardware, and we don't need any of the new functionality offered in 7.6. So justifying a purchase when this version "should work fine" is tricky to get past the finance people.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...