Jump to content

How long does updating an existing catalog take?

Recommended Posts



I've been running a legacy version of Retrospect (2.0i) on a legacy Mac (actually a Macintosh emulator for Windows with Mac OS 8.1) for years without a problem. The File StorageSet has grown to about 780 MB over the years.


But something went wrong during the last backup. When I tried to backup again, I was adviced that the catalog was out of sync with the StorageSet and that I should use Tools:Repair:Update Existing from the Directory window.


I tried that but after whipping through the files in the storage set, the dialog windows just showed two gears turning for a long time. So I finally cancelled the operation.


I then copied the storage set and Retrospect to a real Mac (albeit just a 8100/10) and started the repair process once again. Unfortenately, with the same result: It took a couple of minutes to step through all the files in the storage set and has been showing the turning gears ever since. It's been at it for a couple of days now :-)


What should I do? Any advice is welcome.


Thanks in advance,


Link to comment
Share on other sites

I seem to remember that Retrospect 2.0i had some severe limitations as to numbers of files, etc., that it could handle, and you had to tweak the application memory allocations using ResEdit to get it to perform with real-life situations. But that was over 15 years ago, when we installed 2.0i on a PPC 8100/100 running ASIP 4.1 on MacOS 7.5.3 or something similar. Don't think that Retrospect 2.0i can handle today's number of files, and this may be part of the original problem. I think that technology has moved on...


Our 2.0i tapes can still be read by Retrospect Mac 6.1.x, though, for which we have been thankful on those rare occasions when we have had to dig out the past.


It may be that some tweaking with ResEdit is needed.




Link to comment
Share on other sites

What should I do? Any advice is welcome.

Respectfully, after a little thought, what you really ought to do is to come forward out of the dark ages and run on current hardware and software.


If you are determined to stay on that 8100/100, I suggest that you put MacOS 9.2.2 or so on that machine and then upgrade to Retrospect 5.x, which is the last version that runs on MacOS Classic. Rebuild/repair from there.


Retrospect 5.x comes on the CD for Retrospect 6.x.


That's my suggestion.



Link to comment
Share on other sites

Thanks for your suggestions!


First, I guess I should explain my odd hardware and software setup. A number of years ago I came from a Macintosh dominated IT infrastructure into a purely Windows PC environment. Only for my private contact & time management, I'm still using Mac software, because there was no lossless path for moving the data from Mac to Windows. So I'm rather happily using a Macintosh emulator on my (Windows) notebook. But its only a 68k emulator, so I'm stuck with Mac OS 8.1 and legacy software versions. The PowerMac 8100 is just a machine from the basement that I reactivated for repairing the old storage set.


As suggested, I installed Retrospect 2.1 for the catalog update/rebuild. Unfortenately, it behaves just the same as 2.0: After stepping through the files in the storage set within a couple of minutes, it does not terminate.


I'd be happy to try some ResEdit magic, if somebody could point out what I might do. Also, I do have access to a PowerMac with Mac OS 9.1 on it. But I have to admit that I'm somewhat reluctant to buy Retrospect 6 just for running Retrospect 5 once - without even knowing if it will work. Is there a legal way to get something like a time limited test version of Retrospect 5 somewhere?


Here is some additional information I collected: The total number of files in the storage set is 1683. And this is what the detail log says about the last successfull backup, the error message, my initial repair attempts, and the storage inconsistency:

D   Retrospect version 2.0i
   launch at 28.09.2008 18:59 Uhr

+   Normal Backup using Backup Malte at 28.09.2008 18:59 Uhr
   To StorageSet Backup Malte.

-   28.09.2008 18:59:18 Uhr: Copying Malte
   28.09.2008 19:00:02 Uhr: Comparing Malte
   28.09.2008 19:00:16 Uhr: Execution completed successfully
       Completed: 2 files, 6.927 KB, with 49% compression
       Performance: 6,9 MB/minute (9,2 copy, 28,9 compare)
       Duration: 00:00:58

   Quit at 28.09.2008 19:00 Uhr

D   Retrospect version 2.0i
   launch at 05.10.2008 18:45 Uhr

+   Normal Backup using Backup Malte at 05.10.2008 18:46 Uhr
   To StorageSet Backup Malte.

-   05.10.2008 18:46:03 Uhr: Copying Malte
       Catalog out of sync with StorageSet "Backup Malte".
       Use Tools:Repair:Update Existing from the Directory window.
   05.10.2008 18:51:30 Uhr: Execution incomplete
       Remaining: 2 files, 6.975 KB
       Completed: 0 files, zero KB
       Performance: 0,0 MB/minute
       Duration: 00:02:49

D   Retrospect version 2.0i
   launch at 05.10.2008 18:51 Uhr

+   Executing Recatalog at 05.10.2008 18:52 Uhr
   To StorageSet Backup Malte.
   05.10.2008 19:15:15 Uhr: Execution stopped by operator
       Duration: 00:22:53 (00:00:02 idle/waiting/loading)

+   Executing Verify at 05.10.2008 19:15 Uhr
   To StorageSet Backup Malte.
       StorageSet format inconsistency (3 at 376107)
       StorageSet format inconsistency (3 at 541413)
   05.10.2008 21:17:37 Uhr: Execution stopped by operator
       Completed: 1683 files, 780,1 MB
       Performance: 6,4 MB/minute
       Duration: 02:01:51
   Quit at 05.10.2008 21:18 Uhr

Edited by Guest
Link to comment
Share on other sites

The total number of files in the storage set is 1683.

Ok, then you clearly are not running into the limits I was discussing. I thought you were trying this on hundreds of thousands of files. Forget the ResEdit hacks. You should be able to do what you want using Retrospect 2.1, except, as you might guess, it is untested and unsupported on a 68k emulator on Windows.


Looking back at my version history, I'm not sure whether we ever ran 2.0i (or 2.1) on the PPC 8100; it may have been the prior 68k ASIP server that we had before that - it's been over 15 years, so I'm not sure, and so I'm not sure whether 2.1 ran on a PPC (which would have had a 68k emulator as well); perhaps we had Retrospect 4.x on the 8100.


Try moving the catalog to the Macintosh desktop (so that Retrospect can't find the catalog when it launches), then try to rebuild (rather than repair) the catalog from scratch. It will take a while but not so very long because you don't have that many files (but you will have the overhead of emulation to deal with, which will slow things down).



Link to comment
Share on other sites

Whether I tried to verify, to update, or to repair the storage set, whether I used 2.0 or 2.1 - nothing terminated. Its either a bug or a damaged storage set.


Luckily, I found out that I could read the complete contents of the storage set. So I created a new storage set and copied all data from the old storage set to the new one. The new storage set verifies just fine.


So, even though I couldn't solve the termination mystery, I managed to save my backups.


Thanks for your help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...