Jump to content

Re: 6.2.234 headache

Recommended Posts

Updating clients to 6.2.234 did not go well for me. The main issue I've had is that after updating client machines with client v6.2.234, most disappeared from the "Backup Clients on Network" window and was a lot of trouble to get them re-connected. The second issue is that on machines that I was finally able to connect to and fully set up with Client v6.2.234, it turns itself off after rebooting the machine.


On the machines I was not able to successfully install and connect, I reverted to Client v6.1.130 and they popped right up in the "Backup Clients on Network" as expected.


Details and background of our setup: (My apologies if too much detail.)


Retrospect Server was already at 6.1.230 on an iMac G5 (OS X 10.4.11). After updating them to Client v6.2.234, only 4 of 15 clients show up on the "Backup Clients on Network" window where they had been listed prior to updating from 6.2.229. Ironically, I had just updated them to 6.2.229 the day before the release announcement of 6.2.234. I quickly realized they had the symptoms 6.2.234 was to address (turning themselves off) so was happy to see a quick fix. All had been okay with client 6.1.130 with the exception of lost network connectivity during backups so felt it worth trying an update.


I have checked to verify that Retrospect Client is turned on, Airport is turned off and connected only via ethernet (to rule that out), Firewall is turned off on the Retrospect Server and Clients. We're all on a single gigabit ethernet switch so all on the same subnet.


I have reinstalled Server 6.1.230 with no change.


Interestingly, at first, the only ones I successfully connected were two MacBook Pros, G4 Mirror Door (OS X Server) and an old eMac G4. All clients I had difficulty with were iMac Intel 2.0 Ghz 20" and one iMac Intel (white) 17". All clients are running OS X 10.5.5 except the iMac Intel (white) 17", G4 Server and eMac G4 which are on 10.4.11.


I first had updated the clients via Retrospect Server but have also tried manually uninstalling/installing on the client machine. That method seemed to work for the machines mentioned above but not on the iMacs I tried in the first round. The next day, I was able to get all but three updated to 6.2.234 and connected using a combination of those two methods. The three machines (2-iMac Intel 20", 1-iMac Intel (white) 17") I couldn't connect from the Retrospect Server using the client 6.2.234, I reverted back to client 6.1.130 and they came right up.


I could use the "Add by Address..." option which worked on one I tried but since the IPs are dynamic I didn't think that was a good option.


All machines are connected now but this was a lot of time to get to this point. Obviously, I should have tested on only a few before forging ahead with updating all machines. And, would have been quicker to just revert all machines to 6.1.130 instead of narrowing it down to just three but there you go for what it's worth. I may end up reverting all anyway until the "turning off" problem is fixed. Sure looking forward to Retrospect X.

Link to comment
Share on other sites

The second issue is that on machines that I was finally able to connect to and fully set up with Client v6.2.234, it turns itself off after rebooting the machine.


Do you mean that on startup, the client process does not load (this would be different then it loading on startup, but then crashing)?


There is apparently some sort of issue, just confirmed by EMC, with the startup shell script:



Drag and drop this file onto Text Edit, and take a look see; does it have a line:


/Applications/Retrospect\ Client.app/Contents/Resources/retroclient &


Or by chance does that line end instead with "/pitond &" ?


My apologies if too much detail


Don't apologize for that! There is NEVER too much detail!

Link to comment
Share on other sites

  • 2 weeks later...

It appears that Retrospect Client is turning itself off after backup, even without a machine restart. The client machines are all logged out of the user accounts at time of backup but are not rebooted at all. I haven't tracked down exactly but some clients have this problem but a few do not--even same model (iMac Intel 20") and OS version (OS 10.5.5).


I checked the RetroClient file as you suggested and it does have the "pitond &" at the end.


/Applications/Retrospect\ Client.app/Contents/Resources/pitond &


Thanks for your feedback.

Link to comment
Share on other sites

Scratch that part about Client 6.2.234 turning itself off in my previous post. Upon closer inspection, four out of four clients for which Client had turned itself off, all had restarted their machines. So, I was mistaken in my assumption that it was happening after backup.


The main issue remains that with Client 6.2.234, for some client machines, it does not show up in the Server "Backup Clients on Network" list window. I've had to resort to adding by IP address on a couple. Others showed up okay. I haven't found what the difference is in these machines that may cause this.


On my MacBook Pro, I uninstalled/reinstalled and that took care of the /Library/StartupItems/RetroClient/RetroClient problem. The line mentioned above now ends as it should which fixed the turning off issue: /Applications/Retrospect\ Client.app/Contents/Resources/retroclient &


However, after installing and restarting and getting the "Waiting for first access" message/state on the MBP, the Client app did not bring up the password/log in window. Therefore, I could not log in on the Server side. I noticed I had both an Airport and Ethernet connection on the MBP so turned Airport off and I was then able to login on the Server side.


As I mentioned before, I did not have the "Waiting for First Access"/no show on Server issue with Client 6.1.130.


Thanks again for your feedback.



Link to comment
Share on other sites

after installing and restarting and getting the "Waiting for first access" message/state on the MBP, the Client app did not bring up the password/log in window.


What password/login window?


Do you mean assigning a password for a newly installed client? That's handled by the installer, not by the Retrospect Client application.


Since you note that you were able to successfully log in, then you have the correct password. Not enough information to comment on how your networks settings were involved in your observations.



Link to comment
Share on other sites

I was confused at that myself. I had just performed the exact same function (uninstall/reinstall to Client 6.2.234) on two computers (an iMac Intel 2.0 Ghz and MacBook Pro 2.4 Ghz) and had a different experience. Both already had been setup, accessed and backed up previously and were part of the Server Client Database. The only differences I could see were that the iMac was at Client 6.1.130 and the MBP was at 6.2.234 (and the Airport additional connection I mentioned before).


On the iMac, after the reinstall was complete, I was prompted to enter a password on the Client side. It was then in the "waiting for first access" state. Even with that, it was not visible on the Server "Backup Clients on Network" window. I had to add it via IP Address which may only be temporary since IPs are dynamic.


On the MBP, did the same but was never prompted to enter my password by the Client. It only showed the "waiting for first access" and I didn't even notice the lack of the password prompt until when I attempted to configure it on the Server. It stated "Not logged in" but when I click on the "Log in..." button I got an error. Sorry, I didn't catch what the error number was.


That's when I remembered seeing something on the forum about Ethernet and Airport connections. So, I checked, saw I had both connections and turned off Airport so I had the Ethernet connection only.


At that point, I don't recall exactly but I think going back to the Server I was able then to click the log in button and it then brought up the sign in/password window and was able to make the connection and configure successfully.


Sorry I didn't document that better and, your right, I think it just need to be signed in on the Server side. Curious though why the different experiences on the two machines. Was it that I was upgrading from 6.1.130 on the iMac?


I'm still rather confused by all of this but I'm going to let it go for now. I still have two clients I reverted back to 6.1.130 after having the 'not visible on client list' problem with 6.2.234. But, everyone should be set up to be backed up for now.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...