Jump to content

Retrospect Pro stopped


Recommended Posts

I have been using this for years. After clicking backup on the backup window, it stops completely. It stops everything on the PC. It can only be canceled by Task Manager.


Second time I poked around and using the properties for the source disks in the backup I saw them not available because something else was using them. I did something (I believe powered up the external USB drives) and they were just offline. Nothing in the script for this backup uses thes drives, but I believe the last time I ran Retrospect the backup was going there. They have worked fine for the last couple of months.


I have stopped all of my security pgms (anti virus and spyware).


Just sits and stalls.


I just tried running it again but using the USB drives as the target. Same thing. First it came up and gave an error message that the disk was in use. Then hung (not the whole system) and I needed task manager to cancel it. I ran it again and no message' just hung.

Edited by Guest
Link to comment
Share on other sites

It is XP Pro SP3, but I have never enabled the XP restore function. I will go look and see if it has somehow been enabled.


Retrospect has run just fine for years on this machine. I am not aware of my changing any settings.


My guess was some sort of maintenance update affecting things. I have the problem after all security programs are disabled. Those are the things normally updated frequently.


If it was MS updates, you would have had other reports.


Nothing else has problems accessing or using these disk drives. Whatever is doing it seems to be limited to affecting Retrospect.

Link to comment
Share on other sites

Double clicking on the line of text that appears when I start the backup displays an error message.


VssWBuildSnapshotSet: StartSnapshotSet failed, winerr -2147212522, error -3042


If I cancel the run and try again I get error 843, the drive that should be used to write the backed up files is in use by another operation.


The little red moving indicator is on at the lower left of the screen and the text says one execution running. If I try to cancel Retrospect it will not quit. I have to use task manager to kill it.


I have spent hours and am getting nowhere. I just redid all of the scripts and data set definitions. No change from previous problems.

Link to comment
Share on other sites

Shadow copy seems to be started by Retrospect. I have it set for manual. In the my computer properties I have it turned off.


Something odd happens when I try to start component services from control panel. It opens the window and then hangs. The cursor is a solid hourglass. But task manager does not show any resources being consumed by the related process. Canceling the application does not work. Canceling the process does work.


Clearly something has changed. But I have no clue what. Like I said above, I have tried running retrospect with all of my security add-ons disabled. The only thing left would I believe be XP. Are there any known problems with SP3? I am getting nowhere and spending more hours than I can afford.


Any other ideas about avenues to pursue or tests to try? Is there any way for me to tell what date I installed SP3?


I just watched task manager for a while after starting Retrospect. Every few seconds it uses a little bit of cpu. Almost like it is waiting for something and checking on it.

Edited by Guest
Link to comment
Share on other sites

  • 1 month later...



I had the same problem and found your post while searching for a solution. I'm also running XP with SP3 and Retrospect Express 7.0.326 (with update


Your mentioning of seeing some errors related to the MSDTC caught my eye because I had noticed the same errors in my event log.


One of the errors I had related to MSDTC was the following.


"MS DTC log file not found. After ensuring that all Resource Managers coordinated by MS DTC have no indoubt transactions, please run msdtc -resetlog to create the log file."


Using that suggestion I did the following.


1. Opened a Command Prompt.

2. Ran the following command, "c:\windows\system32\msdtc -resetlog". You won't get any message back after you run it.

3. Opened up my Services and started the service named "Distributed Transaction Coordinator". It was set to Manual, I left it that way.

4. Restarted my machine.

5. Tried using Retrospect again...IT WORKS!


Your mileage may vary but I hope this helps you or anyone else who happens upon this post.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...