Jump to content

Can't install Mac Client 6.2.229, can't revert either

Recommended Posts

When I install 6.2.229 on my 10.4.11 MacBook Pro it will not run with "The Client was installed without root permission". (Note that the installer *did* authenticate and I *did* install from an admin account). Based on one tip I found online I did enable the root account (with great reluctance; it is insane that one would have to open one's computer up like that), but have not tried the installation from that account. I guess I should try that next.


I tried to unintall 6.2.229 and install 6.1.130 instead, but it fails in the same way. So at the moment I have no operable client.

Link to comment
Share on other sites

You should never need to enable to root account to install the Retrospect Client software.


If the 6.1.130 client has the same problem, then you are not seeing an issue with the new client software. You appear to be having some type of system permissions issue.

Link to comment
Share on other sites

Rocky. The creator of this thread reported a problem installing 2 different versions of the client software, not a problem with installing the application that you reported. So this would be a totally different issue.


What happens when you try to install the prior version?

Link to comment
Share on other sites

As I replied on RetroTALK this morning, there used to be an issue if the "Install OS X Client" VISE installer application was launched directly from a file shared remote volume.


If the installer was copied locally, or if the installer was still on the disk image (which could happily live on a shared volume) there would be no issue.


- How, exactly, did you perform the install that failed?



Link to comment
Share on other sites

Clearly something didn't work correctly during the install. We ran a very long beta program and didn't see a single report of this until after the final release. We would like to reproduce the problem and fix it, so any configuration specific details you can offer will be helpful.


You can try to fix this problem by resetting the permissions:


1) Run /Applicatons/Utilities/Terminal.app


2) From Terminal, change directory into Retrospect Client's bundle

cd /Applications/Retrospect\ Client.app/Contents/Resources


3) From Terminal, change permissions on retroclient

chmod u+s retroclient


4) From Terminal, change ownership of pitond. You will be prompted for admin password.

sudo chown root:admin retroclient



Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...