Jump to content

Recommended Posts

There are a couple of issues that have arisen since we installed Retrospect 5.0 that I've never encountered before.




The Server system is a G4 Mac running OS 9.x




First, the computer that is running the server software is not


getting backed up itself. Here are the symptoms:




When I start up the retrospect server program, the computer that is


running it (let's call it the home computer) does NOT automatically


"connect". What I mean is, if I open the "configure clients" window,


and then hit "configure clients", all of the other computers on our


network darken (indicating retrospect "sees" them). However, the home


computer remains grey, and its status is "not connected". At this


point, I *can* highlight it, and say "connect", and it will darken.


However, in this state, the home computer *never* backs up by itself


(during the run of my automatic script). I *can* do an immediate


backup manually. *However*, the server software doesn't seem to


*know* that it's ever been backed up, because when I "start server


software" and all the clients come up with their date of last backup,


the home computer always says "never".




To try to fix this, I have already tried multiple times to tell the


server software to "forget" this client, and then uninstalled the


client software, rebooted, and reinstalled the client software.


Exactly the same symptoms happen again and again.




Second problem: on several ocassions since installing 5.0, there


have been "net retry" error messages popping up during backups. This


has happened several times with several different computers, and it


*never* happened with the previous version of Retrospect, so I find


it hard to believe that the problem is actually with the network. I


could be remembering wrong, but I think this problem has even occured


when I was doing a manual "immediate backup" of the home computer


(one wonders why or whether the network is even necessary for the


backup of the home computer).




Third, problem: just this morning for the first time the following


message appeared on the screen:




Trouble in Retrospect: Internal consistency check failed: Assertion


check at "elem.c-822"




I have no idea whether it is serious or trivial.




If you need any other information, please let me know.




Thank you for any help.

Link to comment
Share on other sites

Issue 1: The local computer is not a client -- it is the local machine and should be backed up as such. Uninstall the client software - it is not needed.




Issue 2: Regarding the net retry, make sure you have not changed the speed threshold for your client backups (set in the script options). Set the speed threshold (under Client Execution) back to 0.




What operating systems are your clients using? OS 9? OS X? Please provide more detailed information about your setup.




Third issue: (from the Knowledgebase)




Retrospect and Retrospect Express for Macintosh use an internal integrity checking system which will alert the user to problems encountered when performing tasks within Retrospect. These "Internal Consistency Check" and "Chunk Checksum" errors could be caused by corruption to a vital Retrospect file, memory corruption or system compatibility problem. This note describes some of these errors, as well as the files with which they are often associated. This document is meant as an overview for a family of error messages. If you believe your error can not be resolved with the troubleshooting options provided, please contact Dantz Technical Support for assistance.






Identifying the Error




The following is a list of internal consistency check errors that have been encountered by Dantz and the resolution. If your error message is not on this list, continue to the next section of this document.






This error occurs only in Retrospect 3.0. Upgrade to the latest version of Retrospect.






This error can occur when a run document is placed in the Shutdown Items folder on a Macintosh running under System 7.5 with Retrospect versions before 3.0. Update to the latest version of Retrospect.






There are three main reasons for this error: 1. The configuration file is damaged. (This is almost always the case and is especially likely if the error occurred while Retrospect or Retrospect Express was launching.) 2. A catalog file may be corrupt. 3. Retrospect 2.0A or an earlier version attempted to erase a removable cartridge while file sharing was turned on. Turn off file sharing or upgrade Retrospect to the latest version.






This is frequently a one-time error which does not re-occur after restarting your Macintosh. If it happens when going to Configure>Backup Sets, then you should upgrade Retrospect or Retrospect Express.






This error may occur if your Backup Server scripts are corrupted. Duplicate your scripts from the Automate>Scripts window and delete the original scripts.






This is almost always a one-time error which does not re-occur after restarting your Macintosh. If it does re-occur, you should follow the advice below. In some cases this error has also been caused by corrupted System Software.






This error may occur when using an OnStream tape drive with Retrospect 4.2. Update to the latest version of Retrospect for the Macintosh






When experiencing internal consistency check, access violation or exception error messages it is very important to restart the computer following each error message. Running Retrospect immediately following an error of this type without a system restart will leave Retrospect in an unstable state.




When troubleshooting Internal Consistency Check and other Retrospect errors it is important to identify what task Retrospect was attempting to perform at the time the error is reported. Knowing when the error happens will help identify the best course of action for the resolution of the problem.






During Retrospect Launch


If Retrospect reports an Internal Consistency Check error message when launching, a likely cause for the error would be corrupt Retrospect preferences. Try moving the retro.config (4.2) or Retro.Express Config (4.2) file onto the trash (don't empty the trash). This file can be found in the Retrospect folder located within System Folder's Preferences folder. The retro.config (4.2) or Retro.Express Config (4.2) file contains all of your Retrospect scripts, options and the database of logged in clients (if appropriate). Restart the computer and attempt to launch Retrospect again. If the problem continues, please contact Dantz Technical Support for assistance. If you are contacting Technical Support via e-mail, please include the most recent Retrospect.error.log file located in the Retrospect preferences folder.




If launching Retrospect was successful after removing the config file from the Retrospect folder, then this indicates the previous retro.config (4.2) or Retro.Express Config (4.2) file may have been damaged. At this point you will need to recreate your scripts and login your existing clients. Rather than rebuild your scripts, some users may be able to restore an older version of the config file from a backup.






When Saving Snapshot, Updating Catalog or Trouble Matching


During a backup Retrospect may report that it can not save changes to the Snapshot or the Snapshot could not be saved due to an error -24205 (chunk file damaged during save) or trouble matching –24201 (chunk checksum didn't match). Retrospect may also report "trouble matching" errors when doing a restore. These errors often indicate corruption within a Retrospect backup set catalog file.




When troubleshooting these error messages it is important to identify which catalog file is damaged. The operations log will often indicate which catalog file was being accessed at the time this error occurred. If the errors appear isolated to one specific catalog file you will need to either rebuild the catalog from the media (chapter 9 of the Retrospect User's Guide) or create a new backup set to replace the one reporting the error. If the error seems to be happening to several backup sets see the section below on "Chronic Errors".




You can also try the following technique to identify which catalog file is damaged. Set up a restore by searching on a blank file name so Retrospect scans all files in the catalog. If the error occurs, you know this catalog is corrupt.






During File Copy


If Retrospect reports an "Internal Consistency Check" error during the copy phase of a backup or restore you may be experiencing one of several possible problems. It is important to first restart the computer following the error. For many users the error will not return following a system restart. Try the previous operation again. Try to reproduce the problem using a different backup set. If the problem is solved by trying a different backup set, you may need to rebuild the catalog file for the previous backup set. If the problem continues, contact Dantz Technical Support for assistance.






When Scanning Icons


If Retrospect reports an error when scanning "Icons" then you may have a corrupt Retro.Icon (4) file. Try removing this file from the Retrospect Preferences folder. The file will be automatically recreated by Retrospect.






Chronic Errors


If you find these error are happening frequently or they come back after the problem appeared to have been fixed, then you may have a more complicated problem that is resulting in chronic errors.






Unreliable Device Communication


Backup devices can be connected to your computer in several different ways (SCSI, USB, FireWire). If your device is not working correctly or is not communicating with the computer as expected, your Retrospect backups may not run as expected. It is important to check with the vendor of your SCSI card, or other adapter vendor for driver and firmware updates that may be appropriate for your configuration. For more details on device communication and configuration see Chapter 3 and 10 of the Retrospect User's Guide.






Third-Party Software Conflicts


Macintosh users can try disabling all non-Apple extensions (including control panels). If that helps, enable extensions one by one, restart, and test until the problem re-occurs, at which time you will know the culprit is the most recently enabled extension. Permanently disable the problem-causing extension.






Operating System


Macintosh users can try to reproduce the error message while booted from the Retrospect CD-ROM. If the error is not reproducible while booted from the Retrospect CD, then this may indicate a corrupt Mac OS system folder. A clean install of the Mac OS may be required to eliminate the error message.






Hard Disk Media Problems


Retrospect preferences or catalog files could become damaged if these files are stored on a hard disk with media problems. Macintosh users should consider running Apple’s Disk First Aid or a commercial disk checking utility like Norton Utilities or Tech Tool Pro.




Also, make sure all you have updated all your applications and software. Retrospect 5.0 is a carbon application, which may conflict with software not designed to run in a carbon environment.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...