Jump to content

IBM TS3100 Autoloader, ATTO SCSI + Retrospect Server 6 -> Autoload Library functions?

Recommended Posts

Hello Forum Folks.


I've recently started trying to get our recent IBM TS3100 Tape Library auto-loader to talk nicely to Retrospect 6 for Mac OS X.


I CAN see this LTO3 drive in Retrospect, as "IBM Ultrium 3 DC, SCSI" in the Storage Device manager.


Or, as "IBM ULT3580-TD3" in the Device Status section of Storage Device manager.


But it is seen as a single drive (i.e. it sees the contents of the main drive bay). None of my library is visible there in the device manager, as per other user posts of how Retrospect should look when a library is visible.


I've added a dozen tapes to the library (with correct barcodes etc.), and Retrospect sees the individual tapes correctly... But the only way to "swap" the tapes, is the old fashioned 'eject' each one out of the main drive, back into the left or right cartridge, and then manually 'move' the next tape into the main drive.


(i.e. autoloading functions not available).


Here are the vital statistics:


-Mac Pro 2x 2.66ghz Dualie Xeon


-Mac OS X 10.4.11 (desktop, not server)

-Retrospect 6.1.222 Beta 2, 'Server' serial

-Latest driver release (RDU6114101 file)

-IBM TS3100 LTO3 autoloader unit

-latest IBM library firmware update: v6.30

-latest IBM Drive firmware update: 69U2

-ATTO SCSI card (ATTO Express PCI UL5D)


Retrospect is running a confirmed SERVER license (not desktop, not workgroup). I've tried this with several different server licenses from colleagues -- confirmed as server versions also.


ATTO SCSI utility also sees the drive as "ULT3580-TD3" device.


Any tips, ideas, pointers, about where to go next (next stage), to see if this device is capable of the library functions via Retrospect?


(according to the Storage Comparision chart, the device is fully supported in Retrospect 6 for Mac, for Workgroup versions or above):



Much appreciated,



Link to comment
Share on other sites



Apple System Profiler sees the LTO3 drive as the following in the section: Hardware -> Parallel SCSI:




SCSI Parallel Domain 2:


Initiator Identifier: 7


SCSI Target Device @ 4:


Manufacturer: IBM

Model: ULT3580-TD3

Revision: 69U2

SCSI Target Identifier: 4

SCSI Device Features: Wide, Sync, DT

SCSI Initiator/Target Features: Wide, Sync, DT

Peripheral Device Type: 1


SCSI Logical Unit @ 0:


Manufacturer: IBM

Model: ULT3580-TD3

Revision: 69U2

SCSI Logical Unit Identifier: 0





I don't know if that is what other people see or not, with their IBM LTO3 autoloaders... Comments most welcome.




Link to comment
Share on other sites

It looks like you've been burned by the same issue which burned me. (See here for the problem I ran into with my new HP StorageWorks drive.)


According to the SCSI documentation for your drive, both the drive mechanism and the loader mechanism share the same SCSI ID, but each uses a different LUN (Logical Unit Number) to distinguish the two devices. In my case, and apparently in your case due to its absence from the list of supported commands in the documentation, the library does not support the command REPORT LUNS. Even worse, recent versions of Mac OS X do not go to plan B when this command fails. (Plan B is scanning for LUNS manually.)


In short, Mac OS X is apparently broken on this issue, has been for some time, and there's nothing we can do about it with current software.


Would it be more effective for EMC to let Apple know about this problem, or us? I suspect EMC would carry more credibility with Apple.


Would it be possible to have Retrospect add this manual scan (TEST UNIT READY for each LUN) in a future RDU update?

Link to comment
Share on other sites

Ed, I don't know if this is the same issue as yours. Without reviewing a detailed SCSI log you can't say for sure what the problem is. derek2008 could be having a very simple SCSI problem which has not need identified since no troubleshooting has been performed to the best of my knowledge


A lot of customers are using Tape libraries with a single SCSI ID w/ multiple LUNS without any problem at all.


derek2008, how is your device terminated? Have you tried another SCSI cable? Have you tried a different SCSI ID, have you tried the SCSI card in another Macintosh?


In the end, if you can not get Apple system profiler to see the tape drive and the library, then you may want to contact IBM or ATTO for help getting it to display correctly.




Link to comment
Share on other sites

Hi Mayoff, EWTHeckman, and other forum folks.


Ah, SCSI termination was the problem... After a some fairly quick SCSI cable and termination changes (in the back of an awkward cabinet), low-and-behold Apple System Profiler saw the full library facility.


And Retrospect then saw the full library facility too.


(No changeable SCSI ID numbers there on the back of the LTO autochanger -- I guess they're inside the LTO unit -- so changes there were not needed)


I've tested it, and tried tricking Retrospect to run a backup with the 'wrong' tape in place, and it happily changes the tape, and backs up correctly. And it gives full tape library access in the Device Manager section :-). Wonderful.


Thanks again,



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...