Jump to content

vista suddently not recognized; error -557


Recommended Posts

My problem appears to be with one machine, and started at the end of March. This client runs Vista, and had backed up fine until then, so I'm wondering if there was a problem with a hotfix.


Anyway, the machine does not back up. It connects, but when I ask to view the volumes I get "can't track volumes, error -557 (transaction already complete)".


The log file on the machine in question indicates that on 3/31 the machine was seen as running XP SP2, rather than Vista, and cites "Assertion failure at "tstring.cpp-745"


A look back in the log shows that prior to this date the machine was correctly recognized as running Vista.


Client is running 7.5.116; server is running 7.5.512 (I upgraded to the latest beta this morning to see if it would help this problem, but it didn't) and hotfix


What I've tried: Dropping the client, reinstalling client software and re-connecting the client.


Any ideas?


Link to comment
Share on other sites

ok, rather than grooming out, try simply using a new backup set instead. The point is I think it might be getting confused while it is comparing the info it has in the backup set (catalog) for a previous backup of the client (where it says Vista) with the info it is now seeing on the client (where it sees XP) or vice-versa.


You said:

What I've tried: Dropping the client, reinstalling client software and re-connecting the client.


What you don't appear to have tried is an empty backup set.


Grooming Out:

Version 7.5 allows you to open the backup set properties, choose several snapshots to forget and forgetting them, then pressing the groom now button. The snapshots you just forgot thus get deleted, even if they were the last ones for that client. This overrides the defined policy that always keeps at least 2 snapshots for each client, and thus allows you to fully clean a client out from a backup set.

Link to comment
Share on other sites

The problem doesn't seem to be related to the backup set, though I am initiating a new one. If I simply try to view properties on the machine in question, it shows as connected, but when I ask to view its volumes, I receive the "can't track volumes, error -557 (transaction already complete)" message.

Link to comment
Share on other sites

You said that you have tried installing, but even after you uninstall there are still about 7 files in the retrospect client directory. I am guessing that one of them may be corrupt. I suggest you uninstall, delete those files, and then reinstall. When you access it with your server it should re-create those files and hopefully work again.


Link to comment
Share on other sites

No joy. I uninstalled and then deleted the Retrospect folder in Program Files as well as the one in Program Data, then reinstalled. Same error (-557)appeared when I asked to see the volumes.


I checked the client log, and found this:

PipeRead: ReadFile failed with error 109

Any idea what this might indicate?


One other note: When I get the -557 error on the backup server, the client says "In use by "BACKUP2" for: Preparing...", which remains there until I refresh at the server.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...