Jump to content

Exception code: C0000005 ACCESS_VIOLATION


Recommended Posts

When trying to split this into a new topic, a post got lost. It is below


-robin (sorry)



I have a very similar setup, same version of Retrospect, same error:


Exception code: C0000005 ACCESS_VIOLATION


It's happening during backup to DVD+R DL. Almost every other disk. Results in a hard lockup requiring a power cycle to recover. The disk drive is locked somehow by a software process and I can't kill retrospect.exe using the Task Manager. This just started for me; I've used Retrospect for years.



Complete error:


Thread ID: 00000BB4, Name: Unknown


EAX:00000000 CS:001B EIP:004091E3 EFlags:00010246

EBX:00000000 SS:0023 ESP:0012D4E8 EBP: 0012E728

ECX:0012D610 DS:0023 ESI:00152305 FS: 003B

EDX:00000000 ES:0023 EDI:0012E610 GS: 0000



Module Fn (symbol or seg:offset in DLL) Args

=============== ================================= =======================================================================

retrorun.exe IsServiceInstalled +153 0 0000000B 0 0 0 0 0012E774 0

retrorun.exe launchCmdRequest +11A 1 1 0 0012FFC0 0040A8EC 00400000 0 00152305

retrorun.exe _WinMain +6B 00400000 0 00152305 0000000A 0 00730000 7FFDF000 00000044

retrorun.exe _WinMainCRTStartup +185 0 00730000 7FFDF000 8054A6ED 0012FFC8 87FDC020 -1 7C839AA8

kernel32.dll 0001:00015FD7





OS: Windows XP version 5.1 (build 2600), Service Pack 2, (32 bit)

Application: C:\Program Files\Retrospect\Retrospect 7.5\retrorun.exe,

Exception occurred on 12/16/2006 at 3:15:19 PM

Exception code: C0000005 ACCESS_VIOLATION

Fault address: 004091E3 0001:000081E3 retrorun.exe



I have now done chkdsk /r on all four hard drives and no errors were found. Still having the same issue, very frustrating.

Edited by Guest
Robin fixing his mess
Link to comment
Share on other sites

Sorry for the mess with your posts. Your issue was totally different from the thread you "hijacked", so I started a new one to increase your chance of getting a reply.


Now, what is your exact version of Retrospect?


What is your exact model of DVD drive?


How is the drive connected to the computer?

Link to comment
Share on other sites

I disagree with your characterization of my post. I don't care where the answer is posted so it might as well be here.


My exact version of Retrospect is the same as the other person's, 7.5.508.


I have a Pioneer DVR-212D (acc. to Retospect), internal, SATA.


Retrospect had been working fine, this is the first time this has happened but it happens very frequently. A full backup that should have taken about a day and a have has now stretched into almost 4 days. I'm using tons of disks because after each crash, some files get backed up again. I didn't discover Repair Catalog until after the first four or five crashes, that's part of it too.


The longterm plan is to back up to an external hard drive but DVDs have worked for me so far and I'm not stopping until this backup is complete!

Link to comment
Share on other sites

How does a catalog become corrupt and how would I know it is corrupt?


The symptom is: Retorspect application hangs and retrospect.exe hangs such that I can't kill it from Task Manager. The DVD drive is locked up as well and the only solution is to turn the computer off.


If the catalog is corrupt, why is it that I can usually recover from where I left off (more or less) and continue the backup?


Finally, I started a new backup set. Are the preferences you're referring to for the backup set or for the application, and if the latter, how do I set those preferences?


After the next crash or after I finish this backup I will get driver updates; however, when this problem first started I updated to 7.5.508 and that did not help so I am doubtful further updates will make any difference.

Link to comment
Share on other sites

One more Q: I have just installed the driver update and it's too early to tell whether or not it will prevent another crash.


Assuming the underlying issue is a corrupt catalog, is there any other option besides starting a new backup set (therefore a new catalog)?

Link to comment
Share on other sites

How does a catalog become corrupt ... ?

Who knows. Programming error? Bad disk subsystem? Memory error? Mystery garbage blocks from space?


and how would I know it is corrupt?

If rebuilding the catalog fixes the issue.


Assuming the underlying issue is a corrupt catalog, is there any other option besides starting a new backup set (therefore a new catalog)?

Why would you do that rather than just rebuild the catalog?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...