Jump to content

Out of memory error under V6.1.138 and 10.5.1

Recommended Posts

This post is long-winded so please bear with me.


I had the pleasure of having my imac stolen last week. Fortunately, they did not take the external hard drive sitting next to it with my backup set. The imac taken was running 10.4.11. The replacement imac is running 10.5.1.


I was able to successfully restore my files from the backup set using Retrospect 6.1.138. Once I felt I was pretty much operational again I went and set aside the drive with the now more-valuable-than-gold backup and went out to get a new 500 Gb external drive for backups going forward.


I created a new backup set, told it to backup all files, and let 'er rip. There were about 200Gb of data to backup so I anticipated the entire process taking about a day and a half. When I got home from work last night I was surprised to find that the Log file indicated an "out of memory" error while trying to create the catalog file. The backup file itself seemed to be about the right size, maybe slightly smaller than I expected.


I quit the "Immediate Backup" step and then tried to recreate the catalog file. This morning, after some 11 hours of cranking away, I got the same error message. So, I restarted the machine, launched only Retrospect and started the backup process again, recycling the backup set.


The amount of data I'm trying to backup is about the same size as the previous backup set created under 10.4.11 and I've never encountered this error before. The new imac is similarly configured to the old one (2 Gb of RAM, 500 Gb internal drive) so it should have LOTS of virtual memory space available (within the 32bit OS limits).


The only thing going on that I think might have affected Retrospect was I continued to move files around during the backup process so I had a few dozen error messages about "file not found" (I intended to do another Backup once the Recycled Backup was complete to tidy things up) but I've done that before under 10.4.11 w/o any problems. I also had been using the machine for several days with all kinds of other processes running at various times that are memory hogs (Firefox) and I easily could have fragmented the memory enough to confuse the app and OS about how much was truly available.


Looking through the FAQ and forum messages I found a note saying that the 138 update was supposed to fix an error from the 126 version that looks an awful lot like what I'm seeing:


"Error -108 (out of application memory) during matching: Under certain circumstances, users previously could experience -108 (out of application memory) errors during matching. This should no longer be the case."


At this point, what I'm hoping to find here are answers to the following questions:


1. Has anyone seen this error using 6.1.138 under 10.5.1?

2. Is the error avoidable?

3. Is it simply related to the number of files and/or the total amount of data? The backup in question has about 1.4E6 files and should be about 200 Gbytes of data.


Thanks for having the patience to read all the way to the bottom of this post. This particular issue is very vexing as Retrospect has saved my bacon very nicely here and I want to continue to use it going forward.



Link to comment
Share on other sites

You haven't specifically told us what kind of backup set you're using. Can we assume it's a file-type backup set? Do you see two files on the destination volume: a data file with the name of your backup set, and a catalog file with the same name but with a .cat extension?


What happens if you create separate subvolumes on your source volume and then back up each of these in succession? Does Retrospect successfully complete all of these separate backup sessions, or does it choke when the catalog reaches a certain size?

Link to comment
Share on other sites

> You haven't specifically told us what kind of backup set you're using. Can we assume it's a file-type backup set?


Yes. Sorry for the omission. The data file and catalog file were created where they were supposed to be. The data file is ~193 Gb and the catalog file is ~160 Mb in size. As far as I can tell, Retrospect successfully creates the backup data file, but is having problems with the final update to the catalog file (there's plenty of disk space left, the backup uses only about half the available space). The catalog file doesn't seem unusually large; I'm pretty sure the catalog file I used to restore files from was almost 200 Mbytes. However, it was created under 10.4.11 and maybe that makes all the difference.


Before I left for work I set running a backup that would simply duplicate the files; at this point I just want a backup before I start trying any further debugging.


Trying the subvolume approach sounds like the next step but I'll have to read up on it as I've never tried that before.


Thanks for the suggestions,


Link to comment
Share on other sites

More updates:


I created a subvolume for my wife's account. That data backed up flawlessly in a couple of minutes and verified successfully so there's not something systemically wrong with my setup. I then tried a backup of all data except for User accounts. Not too much data (~50 Gb) but still a huge number of files (~1.3E6). It failed at the same point as the 1st backup, while trying to save the catalog file with the same -108 out of memory error. I'm now trying to backup just the User accounts which will have lots of data (~150 Gb) but only about 100K files.


Is there a known limit to the number of files Retrospect can reliably backup in one Backup Set?

Link to comment
Share on other sites

I just started getting the same error. Same version Retrospect and MacOSX except it is MacOSX Server. Backing up to a large file on a 500GB hard disk. File created 11/18/07 347 GB Cat file 1.78 GB. Older back-up file on another 500GB drive 463.81GB so I know it is not the size. Had worked for several days without a problem and suddenly happened on the 8th. I tried restarting Retrospect and that seemed to do it. Did not need to restart the server. If this happens again, I will report here.


Other info 122663 folders scanned on disk for 727423 files, matched 342 sessions.


I have noticed after upgrading to MacOSX Server that Retrospect seems to be a bit more finicky. Back-ups did not start for a while on a clean install of 10.5.1 but that seemed to resolve when I upgraded my 10.4.x server which had retrospect on it to 10.5.1 and updated clients and app. Will keep you posted.



Link to comment
Share on other sites

Your catalog files are truly huge, the largest I'm presently working with is about 700 Mb.


I was eventually able to back all my data by doing it in pieces; 824K was the largest number of files I put into any one Backup set. I guess it gets the job done, but I sure prefer the elegance of just backing up EVERYTHING with one set.

Link to comment
Share on other sites



Is there a known limit to the number of files Retrospect can reliably backup in one Backup Set?



According to this thread,, the upper level of the number of files in an individual source volume is ~1.5E6.


> I sure prefer the elegance of just backing up EVERYTHING with one set.


If the issue is with the number of files in a Source, then you can indeed put all your files in one Backup Set. Just use all of your defined Subvolumes as your Sources, or, for a more elegant configuration, make a Source Group that contains the Subvolumes and use that Group as the Source and your Backup Set as the Destination.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...